Hi

I was hoping someone could put me in the right direction or help with
this query. I have created an admin user via Devise, I can log in fine
and direct to the correct page. What i would like to do is have an admin
dashboard on that page where the administrator can perform functions
such as update pages via a form ( In particular the news page, this
would just consist of updates in the society- so for example a title,
date, news, posted by), delete users, upload images to specific pages.
There may be more but i would like to know where to start as i am new to
ruby on rails. any help greatly appreciated

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Richard l. at Feb 1, 2012 at 7:58 pm
    Hi

    I was hoping someone could put me in the right direction or help with
    this query. I have created an admin user via Devise, I can log in fine
    and direct to the correct page. What i would like to do is have an admin
    dashboard on that page where the administrator can perform functions
    such as update pages via a form ( In particular the news page, this
    would just consist of updates in the society- so for example a title,
    date, news, posted by), delete users, upload images to specific pages.
    There may be more but i would like to know where to start as i am new to
    ruby on rails. any help greatly appreciated

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Craig White at Feb 1, 2012 at 8:03 pm

    On Feb 1, 2012, at 12:57 PM, Richard l. wrote:

    Hi

    I was hoping someone could put me in the right direction or help with
    this query. I have created an admin user via Devise, I can log in fine
    and direct to the correct page. What i would like to do is have an admin
    dashboard on that page where the administrator can perform functions
    such as update pages via a form ( In particular the news page, this
    would just consist of updates in the society- so for example a title,
    date, news, posted by), delete users, upload images to specific pages.
    There may be more but i would like to know where to start as i am new to
    ruby on rails. any help greatly appreciated
    ----
    Why reinvent the wheel? Perhaps if only to learn but you might find this to have everything you are looking for already.

    http://refinerycms.com/

    Craig

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Colin Law at Feb 1, 2012 at 8:54 pm

    On 1 February 2012 19:57, Richard l. wrote:
    Hi

    I was hoping someone could put me in the right direction or help with
    this query. I have created an admin user via Devise, I can log in fine
    and direct to the correct page. What i would like to do is have an admin
    dashboard on that page where the administrator can perform functions
    such as update pages via a form ( In particular the news page, this
    would just consist of updates in the society- so for example a title,
    date, news, posted by), delete users, upload images to specific pages.
    There may be more but i would like to know where to start as i am new to
    ruby on rails. any help greatly appreciated
    Work through some tutorials such as railstutorial.org, which is free
    to use online. (I seem to have typed that line 100 times in the last
    week). That is the best way to start. Make sure you have installed
    the version of rails that the tutorial is written for.

    Colin
    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Richard l. at Feb 1, 2012 at 9:16 pm
    Hi

    thanks for the replies, i am working through tutorials on a daily basis
    so hopefully it will all become second nature after a while.. i have
    looked at refinery and it looks amazing, though i have tried to setup
    but i need rails 3.0? I have rails 3.1.1 installed. is there any way
    around this

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Colin Law at Feb 1, 2012 at 9:23 pm

    On 1 February 2012 21:15, Richard l. wrote:
    Hi

    thanks for the replies, i am working through tutorials on a daily basis
    so hopefully it will all become second nature after a while.. i have
    looked at refinery and it looks amazing, though i have tried to setup
    but i need rails 3.0? I have rails 3.1.1 installed. is there any way
    around this
    Install rvm and then you can easily have multiple versions of rails,
    google it to save me the trouble :)

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Richard l. at Feb 1, 2012 at 9:39 pm
    i have rvm installed already, to give you an idea in my current app i
    write rvm use default 1.9.2 before i start the app ( ie cd myapp ). As
    my current app is using rails V 3.1.1 will this effect installing
    refinerycms?

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Michal Papis at Feb 1, 2012 at 9:45 pm
    It should be: rvm use --default 1.9.2

    On Feb 1, 10:39 pm, "Richard l." wrote:
    i have rvm installed already, to give you an idea in my current app i
    write rvm use default 1.9.2 before i start the app ( ie cd myapp ). As
    my current app is using rails V 3.1.1 will this effect installing
    refinerycms?

    --
    Posted viahttp://www.ruby-forum.com/.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Richard l. at Feb 1, 2012 at 9:40 pm
    basically im trying to intergrate refinerycms into my current app

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Richard l. at Feb 1, 2012 at 9:48 pm
    what difference does the -- make?

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Michal Papis at Feb 2, 2012 at 12:02 am
    skipping -- will try to use the default ruby and 1.9.2 ... most likely
    only 1.9.2 will be used

    with --default you will use 1.9.2 and ask to make it default
    On Feb 1, 10:47 pm, "Richard l." wrote:
    what difference does the -- make?

    --
    Posted viahttp://www.ruby-forum.com/.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Richard l. at Feb 4, 2012 at 11:12 am
    thanks for the info!!

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedFeb 1, '12 at 7:58p
activeFeb 4, '12 at 11:12a
posts12
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase