Using Rails 3.2

Finally got my app to run on Heroku --cedar
I am using Blueprint so had to add
config.assets.precompile += %w( blueprint/screen.css blueprint/print.css
blueprint/ie.css) to environments/production to get a complete asset
precompile of vendor assets.
Used RAILS_ENV=production bundle exec rake assets:precompile to
precompile

Now, even though the layout of the app is correct based on the current
layout.css.scss file in assets/stylesheets, any modifications I make to
this file are not having any effect. This is on my local server
(http://0.0.0.0:3000/) - not Heroku.

I tried recompiling the assets after making changes but this did not
help, and I think I only need to precompile for production. I am still
learning about the asset pipeline

- any ideas why editing the stylesheet doesn't do anything. I know its
probably something pretty stupid I'm missing...

Thanks

Dave Castellano

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Benjamin Iandavid Rodriguez at Jan 25, 2012 at 2:24 am
    It seems that "RAILS_ENV=production bundle exec rake assets:precompile"
    compiles the assets production and since you are in development.. try to
    run bundle exec rake assets:precompile without the environment to see if it
    works.

    2012/1/24 Dave Castellano <lists@ruby-forum.com>
    Using Rails 3.2

    Finally got my app to run on Heroku --cedar
    I am using Blueprint so had to add
    config.assets.precompile += %w( blueprint/screen.css blueprint/print.css
    blueprint/ie.css) to environments/production to get a complete asset
    precompile of vendor assets.
    Used RAILS_ENV=production bundle exec rake assets:precompile to
    precompile

    Now, even though the layout of the app is correct based on the current
    layout.css.scss file in assets/stylesheets, any modifications I make to
    this file are not having any effect. This is on my local server
    (http://0.0.0.0:3000/) - not Heroku.

    I tried recompiling the assets after making changes but this did not
    help, and I think I only need to precompile for production. I am still
    learning about the asset pipeline

    - any ideas why editing the stylesheet doesn't do anything. I know its
    probably something pretty stupid I'm missing...

    Thanks

    Dave Castellano

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Dave Castellano at Jan 25, 2012 at 2:50 am
    No, that didn't help. I would assume rails uses the uncompiled files in
    development env as those are the files that are edited in development
    (assets/stylesheets/***) The compiled files are in the public folder
    and not in an easily editable format. Maybe there is a cache I don't
    know about???

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Dave Castellano at Jan 25, 2012 at 2:00 pm

    Dave Castellano wrote in post #1042404:
    No, that didn't help. I would assume rails uses the uncompiled files in
    development env as those are the files that are edited in development
    (app/assets/stylesheets/***) The compiled files are in the public
    folder
    and not in an easily editable format. Maybe there is a cache I don't
    know about???
    Reread the Pipeline ApI but still no clue and still cant get changes to
    the layout.css.scss file to effect the pages when modified. Looks like
    the file is no longer being used. There most be a copy of it somewhere
    that is being used now... does anyone know if the precompiled files in
    public could be the new css.scss source files, even in development mode?

    Thanks

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJan 25, '12 at 1:20a
activeJan 25, '12 at 2:00p
posts4
users2
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase