As I need to upgrade a Rails app to 3.1 , I am trying to deploy it on
a remote production server ( Linux Debian, after installing Rails
3.0.9 under rvm with all needed gems including mysql2 version 0.2.18
used by the app)

after deployment, starting the app, I get a Load error w mysql2...

** [out :: www.mydomain.com] /var/www/vhosts/mydomain.com/rails/
testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
9:in `require': libmysqlclient_r.so.15: cannot open shared object
file: No such file or directory - /var/www/vhosts/mydomain.com/rails/
testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2/
mysql2.so (LoadError)
** [out :: www.mydomain.com] from /var/www/vhosts/mydomain.com/rails/
testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
9:in `<top (required)>'

I surely forgot something when install mysql2 w this gem set ...
but I don't see what ..

( I am using the same server w Rails 3.1 wo any problem...)

thanks for your feedback

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Alex Mercer at Jan 14, 2012 at 9:31 pm
    Add to your Gemfile:
    gem 'mysql'
    then run `bundle`.
    On 14 янв, 17:25, Erwin wrote:
    As I need to upgrade a Rails app to 3.1 , I am trying to deploy it on
    a remote production server ( Linux Debian, after installing Rails
    3.0.9  under rvm  with all needed gems including mysql2 version 0.2.18
    used by the app)

    after deployment, starting the app, I get a Load error w mysql2...

    ** [out ::www.mydomain.com] /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
    9:in `require': libmysqlclient_r.so.15: cannot open shared object
    file: No such file or directory - /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2/
    mysql2.so (LoadError)
    ** [out ::www.mydomain.com] from /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
    9:in `<top (required)>'

    I surely forgot something when install mysql2 w this gem set ...
    but I don't see what ..

    ( I am using the same server w Rails 3.1 wo any problem...)

    thanks for your feedback
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Erwin at Jan 15, 2012 at 11:53 pm
    thanks , actually was an issue with rvm gem set, fixed ( I cloned my
    localhost gem set ..)
    On Jan 14, 10:31 pm, Alex Mercer wrote:
    Add to your Gemfile:
    gem 'mysql'
    then run `bundle`.

    On 14 янв, 17:25, Erwin wrote:






    As I need to upgrade a Rails app to 3.1 , I am trying to deploy it on
    a remote production server ( Linux Debian, after installing Rails
    3.0.9  under rvm  with all needed gems including mysql2 version 0.2.18
    used by the app)
    after deployment, starting the app, I get a Load error w mysql2...
    ** [out ::www.mydomain.com] /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
    9:in `require': libmysqlclient_r.so.15: cannot open shared object
    file: No such file or directory - /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2/
    mysql2.so (LoadError)
    ** [out ::www.mydomain.com] from /var/www/vhosts/mydomain.com/rails/
    testsbga/shared/bundle/ruby/1.9.1/gems/mysql2-0.2.18/lib/mysql2.rb:
    9:in `<top (required)>'
    I surely forgot something when install mysql2 w this gem set ...
    but I don't see what ..
    ( I am using the same server w Rails 3.1 wo any problem...)
    thanks for your feedback
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJan 14, '12 at 3:25p
activeJan 15, '12 at 11:53p
posts3
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Erwin: 2 posts Alex Mercer: 1 post

People

Translate

site design / logo © 2021 Grokbase