Hi,

I have rvm running locally and capistrano 2.9.0 installed on my mac,
im using ruby ree-1.8.7-2010.02. I can deploy fine which deploys the
latest version of the code from git, i am not using rvm on my staging
server.

I want the bundler to install the gems so i have added require
'bundler/capistrano' to the top of my deploy.rb file.

When i deploy now i get the following error:

* executing "cd /var/www/rails/xxxxxxxx/site/releases/20120112102943
&& bundle install --gemfile /var/www/rails/xxxxxxxxx/site/releases/
20120112102943/Gemfile --path /var/www/rails/xxxxxxxx/site/shared/
bundle --deployment --quiet --without development test"
servers: ["xxxxxxxxx.eu-west-1.compute.amazonaws.com"]
[xxxxxxxx.eu-west-1.compute.amazonaws.com:12344] executing command
** [out :: xxxxxxxxxxxxx.eu-west-1.compute.amazonaws.com:12344] sh:
bundle: command not found

I have googled around and most of the solutions are for servers
running rvm which my server is not.

If i ssh via root or the deploy user and run which bundle i get the
correct location /opt/ruby/bin/bundle

Anyone got any suggestions?

JB


--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Craig White at Jan 12, 2012 at 3:13 pm

    On Jan 12, 2012, at 3:39 AM, johnnybutler7 wrote:

    Hi,

    I have rvm running locally and capistrano 2.9.0 installed on my mac,
    im using ruby ree-1.8.7-2010.02. I can deploy fine which deploys the
    latest version of the code from git, i am not using rvm on my staging
    server.

    I want the bundler to install the gems so i have added require
    'bundler/capistrano' to the top of my deploy.rb file.

    When i deploy now i get the following error:

    * executing "cd /var/www/rails/xxxxxxxx/site/releases/20120112102943
    && bundle install --gemfile /var/www/rails/xxxxxxxxx/site/releases/
    20120112102943/Gemfile --path /var/www/rails/xxxxxxxx/site/shared/
    bundle --deployment --quiet --without development test"
    servers: ["xxxxxxxxx.eu-west-1.compute.amazonaws.com"]
    [xxxxxxxx.eu-west-1.compute.amazonaws.com:12344] executing command
    ** [out :: xxxxxxxxxxxxx.eu-west-1.compute.amazonaws.com:12344] sh:
    bundle: command not found

    I have googled around and most of the solutions are for servers
    running rvm which my server is not.

    If i ssh via root or the deploy user and run which bundle i get the
    correct location /opt/ruby/bin/bundle

    Anyone got any suggestions?
    ----
    (as root)
    ln -s /opt/ruby/bin/* /usr/local/bin/

    obviously you have added the path '/opt/ruby/bin' to your path so when you have a shell, it works but running a script, it doesn't. Creating the symbolic links per above will fix that.

    Craig

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedJan 12, '12 at 10:40a
activeJan 12, '12 at 3:13p
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Craig White: 1 post Johnnybutler7: 1 post

People

Translate

site design / logo © 2021 Grokbase