I commented the following code in my deploy.rb , to avoid pre-
compiling upon deployment ..

# namespace :assets do
# desc "Compile assets"
# task :precompile, :roles => :app do
# run "cd #{release_path} && rake RAILS_ENV=#{rails_env}
# end
# end

but it seems to have no effect .... cap deploy log show precompiling
triggering after callbacks for `deploy:update_code'
* executing `deploy:assets:precompile'
* executing "cd /var/www/vhosts/videopromo.tv/rails/videopromo/
releases/20120103234418 && bundle exec rake RAILS_ENV=production
RAILS_GROUPS=assets assets:precompile"

I have an issue with the .swf file being pre-compiled and I don't
want that ..
so I run a local pre-compile before deployment ...
rake assets:precompile --trace with config.assets.digest = false in
and that was fine ... I got the files player.swf and ova-jw.swf
in public/assets/jwplayer folder

then I put back config.assets.digest = true in production.rb and did
my cap deploy
but on the remote production server , in public/assets I have
player.swf and ova-jw.swf BUT also
ova-jw-cd5839fa631138fe59903b79af552531 and
seems not to be an issue for the player.swf , but it's definitely an
issue for the ova-jw.swf which is a plugin and need dynamic
settings ...

feedback will appreciated on how to solve this issue ( the ova-jw.swf
plug is running fine in local development mode, but
cannot be set up in production ...

You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
postedJan 4, '12 at 12:01a
activeJan 4, '12 at 12:01a

1 user in discussion

Erwin: 1 post



site design / logo © 2022 Grokbase