I'm not sure what I've done - may have tried to roll my own on some things
and missed some dependencies? Not sure. I thought it might have been
something with my ubuntu install but I finally talked the boss into a
macbook the other day and the results are the same on the mac so that wasn't
it. I plan on rolling it back incrementally in git and see when it went
sideways as a first step to tracking it down (in a clone repo of course - I
love git)



If you have any advice on this I'm all "ears".



Thanks.


Max



-------------- start of error paste

Allens-MacBook-Pro:test allenmaxwell$ rails g controller testcontroller
/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/
generators/named_base.rb:158:in `parse_attributes!': undefined method
`attributes=' for #<Rails::Generators::ControllerGenerator:0x007fc386db2490>

(NoMethodError)

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/
generators/named_base.rb:21:in

`initialize'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/grou
p.rb:226:in

`new'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/grou
p.rb:226:in

`dispatch'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/base
.rb:389:in

`start'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/
generators.rb:168:in

`invoke'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/
commands/generate.rb:12:in `<top (required)>'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:240:in

`require'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:240:in `block in require'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:223:in `block in load_dependency'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:640:in

`new_constants_in'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:223:in

`load_dependency'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/a
ctive_support/dependencies.rb:240:in

`require'

from

/Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails/
commands.rb:28:in `<top (required)>'

from script/rails:6:in `require'

from script/rails:6:in `<main>'

--------------- end of paste





--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Max at Nov 22, 2011 at 1:53 am
    it looks like i got this fixed. I walked back into my git repo until
    i found a commit that didn't have
    the error. as it turned out the problem was with the prototype gem.
    i had it in the Gemfile as gem 'prototype'
    after googling etc I found that changing it to gem 'prototype-rails'
    did the trick. seems to be working now!
    thanks again..

    On Nov 21, 10:21 am, "Allen A. Maxwell" wrote:
    I'm not sure what I've done - may have tried to roll my own on some things
    and missed some dependencies?  Not sure.  I thought it might have been
    something with my ubuntu install but I finally talked the boss into a
    macbook the other day and the results are the same on the mac so that wasn't
    it.  I plan on rolling it back incrementally in git and see when it went
    sideways as a first step to tracking it down (in a clone repo of course - I
    love git)

    If you have any advice on this I'm all "ears".

    Thanks.

    Max

    -------------- start of error paste

    Allens-MacBook-Pro:test allenmaxwell$ rails g controller testcontroller
    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails /
    generators/named_base.rb:158:in `parse_attributes!': undefined method
    `attributes=' for #<Rails::Generators::ControllerGenerator:0x007fc386db2490>

    (NoMethodError)

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails /
    generators/named_base.rb:21:in

    `initialize'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/gro u
    p.rb:226:in

    `new'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/gro u
    p.rb:226:in

    `dispatch'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/thor-0.14.6/lib/thor/bas e
    .rb:389:in

    `start'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails /
    generators.rb:168:in

    `invoke'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails /
    commands/generate.rb:12:in `<top (required)>'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:240:in

    `require'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:240:in `block in require'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:223:in `block in load_dependency'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:640:in

    `new_constants_in'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:223:in

    `load_dependency'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/activesupport-3.1.1/lib/ a
    ctive_support/dependencies.rb:240:in

    `require'

    from

    /Users/allenmaxwell/.rvm/gems/ruby-1.9.2-p290/gems/railties-3.1.1/lib/rails /
    commands.rb:28:in `<top (required)>'

    from script/rails:6:in `require'

    from script/rails:6:in `<main>'

    --------------- end of paste
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 21, '11 at 5:25p
activeNov 22, '11 at 1:53a
posts2
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Max: 2 posts

People

Translate

site design / logo © 2022 Grokbase