Background
Devise 1.0.11 Rails 2.3.8 added ldap authentication strategy - double login
required / losing Devise current_user
https://groups.google.com/forum/#!topic/plataformatec-devise/8NtIjc-LIqU

Latest:

Using the Ruby debugger

With debugger I can see the current_user here right before we send if off
with a respond_to_do to the index view

(rdb:437) method iv current_user
@attributes = {"encrypted_password"=>"", "created_at"=>"2011-11-16
00:49:31", "confirmation_sent_at"=>nil, "last_sign_in_ip"=>"192.168.5.
1", "updated_at"=>"2011-11-18 01:09:32", "creator"=>nil,
"last_sign_in_at"=>"2011-11-18 00:58:57", "id"=>"29",
"sign_in_count"=>"29", "lastname"=>"xxxxxx", "password_salt"=>"",
"reset_password_token"=>nil, "remember_token"=>nil,
"current_sign_in_ip"=>"192.168.5.1", "firstname"=>"xxxxl",
"confirmation_token"=>nil, "remember_created_at"=>nil,
"current_sign_in_at"=>"2011-11-18 01:09:32", "shortlast"=>nil,
"login"=>"xxxxxx", "email"=>"xxxxxxxxx", "confirmed_at"=>nil}
@attributes_cache = {}
(rdb:437) l

respond_to do |format|
format.html # index.html.erb
format.xml { render :xml => @workbenches }
end

Any idea what could cause it to be blank when the partial in the view
attempts to reference it? Again this worked fine with
database_authenticate??

<% if user_signed_in? %>
Signed in as <%= [current_user.firstname, current_user.lastname].join("
") %>


--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/jz0LWcihUOoJ.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Michael Pavling at Nov 18, 2011 at 8:58 am

    On 18 November 2011 01:34, habumaster wrote:
    With debugger I can see the current_user here right before we send if off
    with a respond_to_do to the index view

    Any idea what could cause it to be blank when the partial in the view
    attempts to reference it? Again this worked fine with
    database_authenticate??
    Is the current_user method set in the controller to be a helper_method?

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 18, '11 at 8:53a
activeNov 18, '11 at 8:58a
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Habumaster: 1 post Michael Pavling: 1 post

People

Translate

site design / logo © 2022 Grokbase