it's the first time I see it ...

I have the following in my routes.rb

namespace :users do
resource :dashboard, :only => [:show ]
end

and users_dashboard_path => "/users/dashboard" where I only print
the logged in current_user name ( using Devise gem auth..)

on localhost after sign in , I can go to http://localhost:3000/users/dashboard
...

but once deployed , after sign in, http://www.yoodish.com/users/dashboard
raises : The page you were looking for doesn't exist.
You may have mistyped the address or the page may have moved.

where could be the difference ? I am tired tonight !

thanks for your feedback

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Colin Law at Nov 15, 2011 at 8:26 pm

    On 15 November 2011 19:01, Erwin wrote:
    it's the first time I see it ...

    I have the following in my routes.rb

    namespace :users do
    resource :dashboard, :only => [:show ]
    end

    and users_dashboard_path =>  "/users/dashboard"   where I only print
    the logged in current_user name ( using Devise gem auth..)

    on localhost after sign in , I can go to  http://localhost:3000/users/dashboard
    ...

    but once deployed , after sign in,  http://www.yoodish.com/users/dashboard
    raises : The page you were looking for doesn't exist.
    You may have mistyped the address or the page may have moved.
    What does production.log show when that happens?

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Erwin at Nov 15, 2011 at 10:02 pm
    Got it thanks !
    Started GET "/users/dashboard" for 2.13.101.56 at 2011-11-15 21:40:36
    +0000
    ActionController::RoutingError (uninitialized constant
    Users::DashboardsController):

    I had to define dashboard inside Users as per the routes ....
    (namespace :users !)


    On Nov 15, 9:25 pm, Colin Law wrote:
    On 15 November 2011 19:01, Erwin wrote:








    it's the first time I see it ...
    I have the following in my routes.rb
    namespace :users do
    resource :dashboard, :only => [:show ]
    end
    and users_dashboard_path =>  "/users/dashboard"   where I only print
    the logged in current_user name ( using Devise gem auth..)
    on localhost after sign in , I can go to  http://localhost:3000/users/dashboard
    ...
    but once deployed , after sign in,  http://www.yoodish.com/users/dashboard
    raises : The page you were looking for doesn't exist.
    You may have mistyped the address or the page may have moved.
    What does production.log show when that happens?

    Colin
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Colin Law at Nov 15, 2011 at 9:52 pm

    On 15 November 2011 21:50, Erwin wrote:
    Got it thanks !
    Started GET "/users/dashboard" for 2.13.101.56 at 2011-11-15 21:40:36
    +0000
    ActionController::RoutingError (uninitialized constant
    Users::DashboardsController):

    I had to define dashboard inside Users as per the routes ....
    (namespace :users !)
    But it was ok in development mode?

    Colin

    On Nov 15, 9:25 pm, Colin Law wrote:
    On 15 November 2011 19:01, Erwin wrote:








    it's the first time I see it ...
    I have the following in my routes.rb
    namespace :users do
    resource :dashboard, :only => [:show ]
    end
    and users_dashboard_path =>  "/users/dashboard"   where I only print
    the logged in current_user name ( using Devise gem auth..)
    on localhost after sign in , I can go to  http://localhost:3000/users/dashboard
    ...
    but once deployed , after sign in,  http://www.yoodish.com/users/dashboard
    raises : The page you were looking for doesn't exist.
    You may have mistyped the address or the page may have moved.
    What does production.log show when that happens?

    Colin
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.


    --
    gplus.to/clanlaw

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 15, '11 at 7:13p
activeNov 15, '11 at 10:02p
posts4
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Colin Law: 2 posts Erwin: 2 posts

People

Translate

site design / logo © 2021 Grokbase