Can anyone help with setting up my environment? This all started when
I tried to install Aptana Studio 3, and want to use the debugger. I
have installed ruby 1.9.2, and rails 3.1.0. When I try to install the
ruby-debug-base gem, I get an error that does not make sense to me -
it tells me it needs ruby version > 1.8.7. Here is the error message,
along with other details. I am running this on a Windows XP machine:

C:\>ruby -v
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

C:\>gem install ruby-debug-base --include-dependencies
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
ERROR: Error installing ruby-debug-base:
rbx-require-relative requires Ruby version ~> 1.8.7.

C:\>ruby -v
ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

C:\>gem install ruby-debug-base
ERROR: Error installing ruby-debug-base:
rbx-require-relative requires Ruby version ~> 1.8.7.

Thanks for any help you can offer

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Colin Law at Nov 14, 2011 at 9:04 pm

    On 14 November 2011 20:51, srj wrote:
    Can anyone help with setting up my environment?  This all started when
    I tried to install Aptana Studio 3, and want to use the debugger.  I
    have installed ruby 1.9.2, and rails 3.1.0.  When I try to install the
    ruby-debug-base gem, I get an error that does not make sense to me -
    it tells me it needs ruby version > 1.8.7.  Here is the error message,
    along with other details.  I am running this on a Windows XP machine:

    C:\>ruby -v
    ruby 1.9.2p180 (2011-02-18) [i386-mingw32]

    C:\>gem install ruby-debug-base --include-dependencies
    INFO:  `gem install -y` is now default and will be removed
    INFO:  use --ignore-dependencies to install only the gems you list
    ERROR:  Error installing ruby-debug-base:
    rbx-require-relative requires Ruby version ~> 1.8.7.
    Having had my feeble knowledge on this matter enhanced by Rob
    Bledenharn (thanks Rob) in a thread yesterday I can now confidently
    say that Ruby version ~> 1.8.7 means that it needs a version >= 1.8.7
    but less than 1.9, so 1.9.2 will not do.

    If I remember correctly there is a different version of ruby-debug for
    1.9, ruby-debug19 I think. You might want to google that to check.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Priyanka pathak at Nov 16, 2011 at 5:00 am
    Hello,
    ruby-debug19 is compatible with rails 3.x and ruby 1.9.2.
    I have uninstall the ruby-debug and related dependency and than install
    ruby-debug19 gem by following below command:

    gem install ruby-debug19 --
    --with-ruby-include=$rvm_path/src/ruby-1.9.2-preview3

    gem install ruby-debug-ide19 --
    --with-ruby-include=$rvm_path/src/ruby-1.9.2-rc2/

    where $rvm_path defines the path of your .rvm directory. eg.
    /home/user_name/.rvm

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 14, '11 at 8:51p
activeNov 16, '11 at 5:00a
posts3
users3
websiterubyonrails.org
irc#RubyOnRails

3 users in discussion

Srj: 1 post Priyanka pathak: 1 post Colin Law: 1 post

People

Translate

site design / logo © 2021 Grokbase