Googling around, I found that apparently adding to the gem file will
fix my problems, but where do i find the gem file? what is the name of
the gem file?

"group :test do
# Pretty printed test output
gem 'minitest' ####### add this line #######
end"

Here is what happens when i run rake test, please note that i have
already installed minitest (2.7.0)

-------------------------------
eldorado@ubuntu:~/work/depot$ gem list

*** LOCAL GEMS ***

actionmailer (3.1.1)
actionpack (3.1.1)
activemodel (3.1.1)
activerecord (3.1.1)
activeresource (3.1.1)
activesupport (3.1.1)
ansi (1.3.0)
arel (2.2.1)
builder (3.0.0)
bundler (1.0.21 ruby)
coffee-rails (3.1.1)
coffee-script (2.2.0)
coffee-script-source (1.1.2)
erubis (2.7.0)
execjs (1.2.9)
hike (1.2.1)
i18n (0.6.0)
jquery-rails (1.0.16)
json (1.6.1)
mail (2.3.0)
mime-types (1.17.2)
minitest (2.7.0)
multi_json (1.0.3)
polyglot (0.3.3)
rack (1.3.5)
rack-cache (1.1)
rack-mount (0.8.3)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.1.1)
railties (3.1.1)
rake (0.9.2.2, 0.9.2)
rdoc (3.11)
sass (3.1.10)
sass-rails (3.1.4)
sprockets (2.0.3)
sqlite3 (1.3.4)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
turn (0.8.3)
tzinfo (0.3.30)
uglifier (1.0.4)
eldorado@ubuntu:~/work/depot$ rake test
/home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/turn-0.8.3/lib/turn/
autorun/minitest.rb:14:in `<top (required)>': MiniTest v1.6.0 is out
of date. (RuntimeError)
`gem install minitest` and add `gem 'minitest' to you test helper.
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/turn-0.8.3/
lib/turn.rb:13:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
railties-3.1.1/lib/rails/test_help.rb:19:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/work/depot/test/test_helper.rb:3:in `<top
(required)>'
from /home/eldorado/work/depot/test/unit/helpers/
products_helper_test.rb:1:in `require'
from /home/eldorado/work/depot/test/unit/helpers/
products_helper_test.rb:1:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:10:in `require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:10:in `block (2 levels) in
<main>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:9:in `each'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:9:in `block in <main>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:4:in `select'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:4:in `<main>'
/home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/turn-0.8.3/lib/turn/
autorun/minitest.rb:14:in `<top (required)>': MiniTest v1.6.0 is out
of date. (RuntimeError)
`gem install minitest` and add `gem 'minitest' to you test helper.
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/turn-0.8.3/
lib/turn.rb:13:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
railties-3.1.1/lib/rails/test_help.rb:19:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in `block
in require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:225:in
`load_dependency'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
activesupport-3.1.1/lib/active_support/dependencies.rb:240:in
`require'
from /home/eldorado/work/depot/test/test_helper.rb:3:in `<top
(required)>'
from /home/eldorado/work/depot/test/functional/
products_controller_test.rb:1:in `require'
from /home/eldorado/work/depot/test/functional/
products_controller_test.rb:1:in `<top (required)>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:10:in `require'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:10:in `block (2 levels) in
<main>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:9:in `each'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:9:in `block in <main>'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:4:in `select'
from /home/eldorado/.rvm/gems/ruby-1.9.2-p290/gems/
rake-0.9.2.2/lib/rake/rake_test_loader.rb:4:in `<main>'
Errors running test:units, test:functionals!
eldorado@ubuntu:~/work/depot$
-------------------------

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Colin Law at Nov 5, 2011 at 4:23 pm

    On 5 November 2011 13:42, eldorado554 wrote:
    Googling around, I found that apparently  adding to the gem file will
    fix my problems, but where do i find the gem file? what is the name of
    the gem file?
    It is called Gemfile and should be in the top level of the rails
    project (in the directory with app, config and so on.

    Colin

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Eldorado554 at Nov 5, 2011 at 11:11 pm
    Thank you Colin. Issue resolved.
    On Nov 5, 12:22 pm, Colin Law wrote:
    On 5 November 2011 13:42, eldorado554 wrote:

    Googling around, I found that apparently  adding to the gem file will
    fix my problems, but where do i find the gem file? what is the name of
    the gem file?
    It is called Gemfile and should be in thetoplevel of the rails
    project (in the directory with app, config and so on.

    Colin
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 5, '11 at 3:48p
activeNov 5, '11 at 11:11p
posts3
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Eldorado554: 2 posts Colin Law: 1 post

People

Translate

site design / logo © 2021 Grokbase