problem: anytime I access the oracle database and bring an active record
object from that database into memory it gives me "ArgumentError (wrong
number of arguments (3 for 2)):" and it lists this line as the problem:
"items = EinsteinItem.all(:conditions => ["rec_key = ?",
rec_key.rec_key])"

details:

Working on getting my application updated to rails 3.1 and for some
reason the upgrade seems to kill my oracle interface. Right now my
application interacts with it's primary database which is SQL and a
secondary database that is running an older version of oracle (10.2.04).
My predecessor got the interface working with ruby-oci8 v 1.7 (he
specifically noted version 2 breaks the connection) and
activerecord-oracle-adapter v1.0.0.9250. From what I can tell somewhere
in the upgrade from 3.0.9 to 3.1 it breaks. The only changes to gems I
do is switching from ar-extensions to activerecord-import and I add in
the prototype-rails gem. Any ideas for what's going on here?

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedNov 2, '11 at 5:32p
activeNov 2, '11 at 5:32p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Richard Palackas: 1 post

People

Translate

site design / logo © 2022 Grokbase