I'm deploy a demo web rails to heroku:

I trying with database: postgresql and sqlite3, but still error.
with SQLite3, i edit Gemfile to:
group :production do
gem 'pg'
end
group :development, :test do
gem 'sqlite3'
end

with PostgreSQL, i config in file: database.yml : database, username
and password follow server heroku ( $ heroku console
Ruby console for myapp.heroku.com
ENV['DATABASE_URL']
=> "postgres://username:password@hostname/database")

But when i run myapp from Heroku, is error:

"We're sorry, but something went wrong.
We've been notified about this issue and we'll take a look at it
shortly."

Please help me!
Sorry, because My English is not good!

Thanks

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Max at Oct 24, 2011 at 5:39 pm
    if you enter "heroku logs" you can often get more info on what's going
    on for the heroku errors... that usually helps a lot.

    Heroku will not work with sqlite.. i found that postresql worked great
    once i got the gemfile set up properly... Here is what i'm using... i
    hope this helps:


    source 'http://rubygems.org'

    gem 'rails', '~>3.1.0'

    group :development do
    gem 'sqlite3', '1.3.4'
    gem 'rspec-rails', '2.6.1'
    gem 'annotate', :git => 'git://github.com/ctran/annotate_models.git'
    gem 'faker', '0.3.1'
    end

    gem 'therubyracer'
    gem 'execjs'
    gem 'gravatar_image_tag', '1.0.0.pre2'
    gem 'will_paginate', "~>3.0.2"

    group :production, :staging do
    gem 'pg'
    end

    gem 'sass-rails', " ~> 3.1.0"
    gem 'coffee-script'
    gem 'uglifier'

    group :test do
    gem 'turn', :require => false
    gem 'rspec-rails', '2.6.1'
    gem 'webrat', '0.7.1'
    gem 'factory_girl_rails', '1.0'
    gem 'rack', '1.3.3'
    end

    gem 'jquery-rails'

    HTH
    On Oct 23, 9:09 pm, Tuyen Hoang Long wrote:
    I'm deploy a demo web rails to heroku:

    I trying with database: postgresql and sqlite3, but still error.
    with SQLite3, i edit Gemfile to:
    group :production do
    gem 'pg'
    end
    group :development, :test do
    gem 'sqlite3'
    end

    with PostgreSQL, i config in file: database.yml : database, username
    and password follow server heroku ( $ heroku console
    Ruby console for myapp.heroku.com>> ENV['DATABASE_URL']

    => "postgres://username:password@hostname/database")

    But when i run myapp from Heroku, is error:

    "We're sorry, but something went wrong.
    We've been notified about this issue and we'll take a look at it
    shortly."

    Please help me!
    Sorry, because My English is not good!

    Thanks
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 24, '11 at 8:54a
activeOct 24, '11 at 5:39p
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Max: 1 post Tuyen Hoang Long: 1 post

People

Translate

site design / logo © 2022 Grokbase