Hi all,

I'm new to this and trying to set up my dev environment on a
Window 7 x64 machine.

I used the latest version of RailsInstaller to start with.

I'm running into a problem using the github gem. When I try 'gh
create-from-local', I get:
"You must 'gem install win32-open3' to use the github command on
Windows"

However, when I try 'gem install win32-open3', I get:
"ERROR: Error installing win32-open3:
win32-open3 requires Ruby version < 1.9.0."

Googling has led me to believe that open3 is already baked into Ruby
1.9.2, which is what I'm using.

Is this just an issue of the github gem being out of date (I'm using
0.6.2), or am I doing something wrong?

Thanks!

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Luis Lavena at Oct 24, 2011 at 8:27 am

    On Oct 23, 9:20 am, "Joshua H." wrote:
    Hi all,

    I'm new to this and trying to set up my dev environment on a
    Window 7 x64 machine.

    I used the latest version of RailsInstaller to start with.

    I'm running into a problem using the github gem.  When I try 'gh
    create-from-local', I get:
    "You must 'gem install win32-open3' to use the github command on
    Windows"

    However, when I try 'gem install win32-open3', I get:
    "ERROR:  Error installing win32-open3:
    win32-open3 requires Ruby version < 1.9.0."

    Googling has led me to believe that open3 is already baked into Ruby
    1.9.2, which is what I'm using.

    Is this just an issue of the github gem being out of date (I'm using
    0.6.2), or am I doing something wrong?
    Seems you're not doing anything wrong.

    Please report the issue to the GitHub gem repository:

    https://github.com/defunkt/github-gem/issues

    Windows is not the most tested platform for a lot of Ruby code.

    --
    Luis Lavena

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 23, '11 at 7:21a
activeOct 24, '11 at 8:27a
posts2
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Joshua H.: 1 post Luis Lavena: 1 post

People

Translate

site design / logo © 2021 Grokbase