Appreciate any help -

I am working through Agile web development (4.0) and am stuck on the
deployment using phusion passenger. I get this:

"Forbidden

You don't have permission to access / on this server."

when I put depot.yourhost.com in the browser.

I have been through various web searches and for file permissions and
suggestions to change the <Files> container. However, before I tread
where I fear in the land of conf I thought perhaps it may be a simple
config issue and my lack of understanding of how things are knitted
together.

Here is my Virtual host config:

<VirtualHost *:80>
ServerName depot.yourhost.com
DocumentRoot /home/railsapps/rails_3/depot/public/
<Directory /home/railsapps/rails_3/depot/public>
AllowOverride all
Options -Multiviews
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
#


My hosts file in /etc has the 127.0.0.1 depot.yourhost.com

Does anything look amiss here? Thank you in advance.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Nathan Wu at Oct 20, 2011 at 4:16 pm
    try this AllowOverride None
    and put index.html in this dir /home/railsapps/rails_3/depot/public/
    then access index.html page
    On Oct 20, 9:17 pm, akkdio wrote:
    Appreciate any help -

    I am working through Agile web development (4.0) and am stuck on the
    deployment using phusion passenger.  I get  this:

    "Forbidden

    You don't have permission to access / on this server."

    when I put depot.yourhost.com in the browser.

    I have been through various web searches and for file permissions  and
    suggestions to change the <Files> container.  However, before I tread
    where I fear in the land of conf I thought perhaps it may be a simple
    config issue and my lack of understanding of how things are knitted
    together.

    Here is my Virtual host config:

    <VirtualHost *:80>
    ServerName depot.yourhost.com
    DocumentRoot /home/railsapps/rails_3/depot/public/
    <Directory /home/railsapps/rails_3/depot/public>
    AllowOverride all
    Options -Multiviews
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    #

    My hosts file in /etc has the 127.0.0.1  depot.yourhost.com

    Does anything look amiss here?   Thank you in advance.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Akkdio at Jun 12, 2012 at 8:03 pm

    On Thursday, October 20, 2011 9:17:07 AM UTC-4, akkdio wrote:
    Appreciate any help -

    I am working through Agile web development (4.0) and am stuck on the
    deployment using phusion passenger. I get this:

    "Forbidden

    You don't have permission to access / on this server."

    when I put depot.yourhost.com in the browser.

    I have been through various web searches and for file permissions and
    suggestions to change the <Files> container. However, before I tread
    where I fear in the land of conf I thought perhaps it may be a simple
    config issue and my lack of understanding of how things are knitted
    together.

    Here is my Virtual host config:

    <VirtualHost *:80>
    ServerName depot.yourhost.com
    DocumentRoot /home/railsapps/rails_3/depot/public/
    <Directory /home/railsapps/rails_3/depot/public>
    AllowOverride all
    Options -Multiviews
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    #


    My hosts file in /etc has the 127.0.0.1 depot.yourhost.com

    Does anything look amiss here? Thank you in advance.


    On Thursday, October 20, 2011 9:17:07 AM UTC-4, akkdio wrote:

    Appreciate any help -

    I am working through Agile web development (4.0) and am stuck on the
    deployment using phusion passenger. I get this:

    "Forbidden

    You don't have permission to access / on this server."

    when I put depot.yourhost.com in the browser.

    I have been through various web searches and for file permissions and
    suggestions to change the <Files> container. However, before I tread
    where I fear in the land of conf I thought perhaps it may be a simple
    config issue and my lack of understanding of how things are knitted
    together.

    Here is my Virtual host config:

    <VirtualHost *:80>
    ServerName depot.yourhost.com
    DocumentRoot /home/railsapps/rails_3/depot/public/
    <Directory /home/railsapps/rails_3/depot/public>
    AllowOverride all
    Options -Multiviews
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>
    #


    My hosts file in /etc has the 127.0.0.1 depot.yourhost.com

    Does anything look amiss here? Thank you in advance.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To view this discussion on the web visit https://groups.google.com/d/msg/rubyonrails-talk/-/uvUgKgHfBmoJ.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 20, '11 at 1:17p
activeJun 12, '12 at 8:03p
posts3
users2
websiterubyonrails.org
irc#RubyOnRails

2 users in discussion

Akkdio: 2 posts Nathan Wu: 1 post

People

Translate

site design / logo © 2022 Grokbase