Testing locally I uploaded files into public/system/... folders
( default for Paperclip)
Upon deployment ( capistrano) on the remote server, I can see a
symlink from public/system to the shared/system/ but the content
( all images ) is not transferred.... I had to do it myself via
ftp ..

Is it a standard behavior ? or did I miss adding a task in the
deployment ?

thanks for your feedback

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Roy Situmorang at Oct 21, 2011 at 12:45 am
    Well, the deployed files are only those included in repository.
    On Fri, Oct 21, 2011 at 5:35 AM, Erwin wrote:

    Testing locally I uploaded files into public/system/... folders
    ( default for Paperclip)
    Upon deployment ( capistrano) on the remote server, I can see a
    symlink from public/system to the shared/system/ but the content
    ( all images ) is not transferred.... I had to do it myself via
    ftp ..

    Is it a standard behavior ? or did I miss adding a task in the
    deployment ?

    thanks for your feedback

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Peter De Berdt at Oct 21, 2011 at 6:48 am

    On 21 Oct 2011, at 02:45, Roy Situmorang wrote:

    Well, the deployed files are only those included in repository.

    On Fri, Oct 21, 2011 at 5:35 AM, Erwin wrote:
    Testing locally I uploaded files into public/system/... folders
    ( default for Paperclip)
    Upon deployment ( capistrano) on the remote server, I can see a
    symlink from public/system to the shared/system/ but the content
    ( all images ) is not transferred.... I had to do it myself via
    ftp ..

    Is it a standard behavior ? or did I miss adding a task in the
    deployment ?
    It is standard behavior, you might read up on capistrano on urls like http://www.practicalecommerce.com/blogs/post/468-Creating-Symlinks-When-Deploying-a-Rails-Application
    (plenty of others that deal with the why and how of the symlinked
    directories.


    Best regards

    Peter De Berdt

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 20, '11 at 10:36p
activeOct 21, '11 at 6:48a
posts3
users3
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase