Hi,

i've set up my win7 64bit box for ROR development. i got every thing
installed but now i'm stuck at debugging my application. i installed
aptana studio 3 and tried to run 'debug server', the following errors
returned.

Fast Debugger (ruby-debug-ide 0.4.16, ruby-debug-base 0.10.4) listens on
127.0.0.1:55255
C:/Ruby/work/whistle/config/../config/preinitializer.rb:8
C:/Ruby/work/whistle/config/boot.rb:28:in load'
C:/Ruby/work/whistle/config/boot.rb:28:inpreinitialize'
C:/Ruby/work/whistle/config/boot.rb:10:in boot!'
C:/Ruby/work/whistle/config/boot.rb:126
c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:ingem_original_require'
c:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in require'
C:\Ruby\work\whistle\script\server:2
c:/Ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.16/lib/ruby-debug-ide.rb:112:indebug_load'
c:/Ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.16/lib/ruby-debug-ide.rb:112:in
debug_program'
c:/Ruby/lib/ruby/gems/1.8/gems/ruby-debug-ide-0.4.16/bin/rdebug-ide:87
c:/Ruby/bin/rdebug-ide:19:inload'
c:/Ruby/bin/rdebug-ide:19 Uncaught exception: Could not load the bundler
gem. Install it with gem install bundler.

i'm pretty sure it's related to rmagick, but i don't know what i've done
wrong. i use bundler for gem management. if i comment the "gem
"rmagick", "2.12.0"" line in gemfile, i can successfully start the
server by running "ruby script/server". i just don't know what's wrong
with the debug.

can anybody tell me what is going wrong? how can i fix it? thx.

windows 7 prof 64bit
aptana studio 3
ruby 1.8.7
rails 2.3.14
ruby-debug-base 0.10.4
ruby-debug-ide 0.4.16
rmagick 2.12.0
(C:\Ruby\lib\ruby\gems\1.8\gems\rmagick-2.12.0-x86-mswin32)
imagemagick (C:\Program Files (x86)\ImageMagick-6.5.6-Q8)
bundler 1.0.18 gemfile (gem "rmagick", "2.12.0")
preinitializer.rb
require 'rubygems'
require 'RMagick'
require 'bundler'

Ref.
http://stackoverflow.com/questions/7622007/win7-rails-aptana-studio-3-rmagick-cannot-start-debug-server


batterhead

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedOct 4, '11 at 1:26a
activeOct 4, '11 at 1:26a
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Paul C.: 1 post

People

Translate

site design / logo © 2022 Grokbase