I have a Rails 3.1 application that I am trying to use JMeter to load
test. Our site is targeted around collecting information so users
sign-up and then walk through a question and answer workflow and after
answering a few questions, they are rewarded with some useful
information. My JMeter test is configured to walk through sign-up and
then the full Q&A workflow.

Environment details:

RedHat Enterprise 6
Rails 3.1
Ruby 1.9.2p290
DB: Postgres 9

I have run tests with 20 and 100 concurrent threads and a ramp-up time
of 1 thread per second and the results are ok. However, as soon as I
decrease the rampup time so there are multiple threads spawned in a
second (even as little as 2 per second), about half of the signup calls
fail with an error 422. Once that happens, for those same threads, the
Q&A workflow breaks because we are assuming that there is a valid user
answering questions.

I'm trying to figure out if there is a problem with the application
code, server configuration, or JMeter setup.

Any thoughts or suggestions on how to troubleshoot this further would be
greatly appreciated.

Thanks,
Amit

--
Posted via http://www.ruby-forum.com/.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedSep 27, '11 at 8:17p
activeSep 27, '11 at 8:17p
posts1
users1
websiterubyonrails.org
irc#RubyOnRails

1 user in discussion

Amit Gulati: 1 post

People

Translate

site design / logo © 2022 Grokbase