Hi,

since upgrading my gems from activerecord-3.0.10 to activerecord-3.1.0
my scripts using activerecord don't work anymore. I get an error
message

Error Please install the mysql adapter: `gem install activerecord-
mysql-adapter` (Could not find RubyGem mysql (~> 2.8.1)
)


but gem does not find such a package:

ERROR: Could not find a valid gem 'activerecord-mysql-adapter' (>= 0)
in any repository

it's not even listed on rubygems.org.

How would I get this running?

(And why is rails distributed over such an unreliable distribution way
like gems? Why can't it come as a regular bundle just like any other
software?)


regards
Hadmut

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Rpilani at Oct 14, 2011 at 2:38 pm
    hi were u able to figure the error out?
    I'm getting the same error...
    except mine gets weirder...
    i get:
    Please install the adapter: `gem install activerecord--adapter`
    if u make any progress on this then please let me know
    On Sep 23, 8:30 pm, Hadmut wrote:
    Hi,

    since upgrading my gems from activerecord-3.0.10 to activerecord-3.1.0
    my scripts using activerecord don't work anymore. I get an error
    message

    Error Please install the mysql adapter: `gem install activerecord-
    mysql-adapter` (Could not find RubyGem mysql (~> 2.8.1)
    )

    but gem does not find such a package:

    ERROR:  Could not find a valid gem 'activerecord-mysql-adapter' (>= 0)
    in any repository

    it's not even listed on rubygems.org.

    How would I get this running?

    (And why is rails distributed over such an unreliable distribution way
    like gems? Why can't it come as a regular bundle just like any other
    software?)

    regards
    Hadmut
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Owen Dall at Oct 19, 2011 at 3:51 pm
    I have the same issue. Also, I searched on rubygems.org and didn't see
    it either. Very strange...

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Loganathan sellappa at Oct 19, 2011 at 3:57 pm
    Hope your adapter is not updated on database.yml file, update the adapter as
    'mysql', then execute 'bundle install'.

    regards,
    Loganathan
    On Wed, Oct 19, 2011 at 9:20 PM, Owen Dall wrote:

    I have the same issue. Also, I searched on rubygems.org and didn't see
    it either. Very strange...

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Owen Dall at Oct 19, 2011 at 8:12 pm

    Loganathan S. wrote in post #1027423:
    Hope your adapter is not updated on database.yml file, update the
    adapter as
    'mysql', then execute 'bundle install'.

    regards,
    Loganathan
    Thanks for that. What I found is on Windows I needed to install a
    version not requiring recompiling.
    gem install mysql2 -v 0.2.6
    -Owen

    --
    Posted via http://www.ruby-forum.com/.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedSep 23, '11 at 3:30p
activeOct 19, '11 at 8:12p
posts5
users4
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2022 Grokbase