Hi,

I followed a Tutorial on Nettuts to install Ruby with RVM and this went
well. I then tried to install Rails to follow the 'How to build a dropbox
live service' from Netttus but appear to get errors can anybody help?.

Once I installed rails I created a new rails project using the command

(Rails new sharebox -d mysql)

This worked and created the folder structure.

I then went and added the following to the gem folder for the project as
suggested by the netuts tutorial

source 'http://rubygems.org'

gem 'rails', '3.0.3'
gem 'ruby-mysql'

I then did the bundle install but this kept causing errors, eventually
somehow I got this to work and it said bundle installed correctly.

However when I try the command rails server i get the following error:

/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
uglifier-1.0.3] (Gem::LoadError)
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
`gem'
from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
Bens-MacBook-Pro:~ bengibson$


And when I try the command

rake db:create

I get a similar error

Bens-MacBook-Pro:sharebox bengibson$ rake db:create
rake aborted!
undefined method `groups' for Rails:Module

(See full trace by running task with --trace)
Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
-bash: db:create: command not found
Bens-MacBook-Pro:sharebox bengibson$ rake --trace
rake aborted!
undefined method `groups' for Rails:Module
/Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
(required)>'
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
/Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
`load'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
`load_rakefile'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
`raw_load_rakefile'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
`block in load_rakefile'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
`standard_exception_handling'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
`load_rakefile'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
`block in run'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
`standard_exception_handling'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
`run'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
`<top (required)>'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
/Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
Bens-MacBook-Pro:sharebox bengibson$ Rails server
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
`to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
uglifier-1.0.3] (Gem::LoadError)
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
`block in activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`each'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
`activate_dependencies'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
`activate'
from
/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
`gem'
from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

Could anybody help me out (i'm new to terminal so need simple explanations),
or help me completely uninstall rails and rubygems and start from scratch.


--
View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
Sent from the RubyOnRails Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com.
To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Search Discussions

  • Venkata reddy at Sep 19, 2011 at 11:31 am
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

    Could anybody help me out (i'm new to terminal so need simple explanations),
    or help me completely uninstall rails and rubygems and start from scratch.

    --
    View this message in context:http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:43 am
    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy wrote:

    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from scratch.
    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:47 am
    Use gem 'mysql'

    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck

    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy wrote:

    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from scratch.
    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:48 am
    Do not Use gem 'ruby-mysql'

    Please use

    gem 'mysql'

    for rails 3

    gem 'mysql', '2.8.1'
    On Mon, Sep 19, 2011 at 5:17 PM, Rajarshi wrote:

    Use gem 'mysql'


    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck


    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy <venkatareddy.cs@gmail.com
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from scratch.
    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 11:52 am
    :( nope dint work, this gives me the error


    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index for http://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for more
    details. You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib


    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/mysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:13:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$



    Rajarshi-3 wrote:
    Use gem 'mysql'

    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck


    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from scratch.
    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google
    Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494321.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Venkata reddy at Sep 19, 2011 at 11:56 am
    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib

    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/ vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1 3:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$







    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.
    Once I installed rails I created a new rails project using the command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 11:59 am
    I'm working on a late 2009 Macbook pro with the latest version of OSX lion.
    Not sure what other information you need. let me know

    Thanks



    venkata reddy wrote:

    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib

    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `<main>'
    Bens-MacBook-Pro:sharebox bengibson$







    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494373.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 12:00 pm
    why mysql2

    just install mysql-server
    mysql clint
    and libmysqldev

    other libraries
    then install mysql gem 2.8.1

    it will run

    no required mysql2

    On Mon, Sep 19, 2011 at 5:26 PM, venkata reddy wrote:


    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for more
    details. You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib

    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$







    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Venkata reddy at Sep 19, 2011 at 12:13 pm
    I am working on windows 7 32 bit. I came across the same problem. But
    for me the below procedure worked great!


    1. edit Gemfile => gem 'mysql2', '0.2.6'
    2. download mysql-noinstall-5.1.50-win32.zip at
    http://downloads.mysql.com/archives/mysql-5.1/mysql-noinstall-5.1.50-...
    ,unzip
    3. gem install mysql2 -v 0.2.6 -- --with-mysql-lib=E:\ROR
    \mysql-5.1.50-win32\lib --with-mysql-include=E:\ROR\mysql-5.1.50-
    win32\include (replace the file "E:\ROR\mysql-5.1.50-win32" path
    with
    yours)
    4. this should work now,try bundle install,generate some
    model ,and run rake db:migrate to see if it works,make sure your
    database config is right,like this
    development:
    adapter: mysql2
    encoding: utf8
    reconnect: false
    database: depot_development
    pool: 5
    username: root
    password: root
    host: localhost
    5.if it still not work ,try this => https://github.com/brianmario/mysql2/issues/8
    On Sep 19, 5:00 pm, Rajarshi wrote:
    why mysql2

    just install mysql-server
    mysql clint
    and libmysqldev

    other libraries
    then install mysql gem 2.8.1

    it will run

    no required mysql2

    On Mon, Sep 19, 2011 at 5:26 PM, venkata reddy wrote:








    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error
    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.
    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib
    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$
    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 12:18 pm
    development:
    adapter: mysql2
    encoding: utf8
    reconnect: false
    database: depot_development
    pool: 5
    username: root
    password: root
    host: localhost


    Please use adapter:mysql
    On Mon, Sep 19, 2011 at 5:43 PM, venkata reddy wrote:

    I am working on windows 7 32 bit. I came across the same problem. But
    for me the below procedure worked great!


    1. edit Gemfile => gem 'mysql2', '0.2.6'
    2. download mysql-noinstall-5.1.50-win32.zip at
    http://downloads.mysql.com/archives/mysql-5.1/mysql-noinstall-5.1.50-...
    ,unzip
    3. gem install mysql2 -v 0.2.6 -- --with-mysql-lib=E:\ROR
    \mysql-5.1.50-win32\lib --with-mysql-include=E:\ROR\mysql-5.1.50-
    win32\include (replace the file "E:\ROR\mysql-5.1.50-win32" path
    with
    yours)
    4. this should work now,try bundle install,generate some
    model ,and run rake db:migrate to see if it works,make sure your
    database config is right,like this
    development:
    adapter: mysql2
    encoding: utf8
    reconnect: false
    database: depot_development
    pool: 5
    username: root
    password: root
    host: localhost
    5.if it still not work ,try this =>
    https://github.com/brianmario/mysql2/issues/8
    On Sep 19, 5:00 pm, Rajarshi wrote:
    why mysql2

    just install mysql-server
    mysql clint
    and libmysqldev

    other libraries
    then install mysql gem 2.8.1

    it will run

    no required mysql2

    On Mon, Sep 19, 2011 at 5:26 PM, venkata reddy <
    venkatareddy...@gmail.com>wrote:







    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error
    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem
    native
    extension. (Gem::Installer::ExtensionBuildError)
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for more
    details. You may need configuration options.
    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib
    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1
    for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `load'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `<main>'
    Bens-MacBook-Pro:sharebox bengibson$
    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and
    this
    went
    well. I then tried to install Rails to follow the 'How to build
    a
    dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed
    correctly.
    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3,
    activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18,
    coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 12:20 pm
    do you know google search

    you do not know mysql installation plese see goggole
    On Mon, Sep 19, 2011 at 5:48 PM, Rajarshi wrote:

    development:
    adapter: mysql2
    encoding: utf8
    reconnect: false
    database: depot_development
    pool: 5
    username: root
    password: root
    host: localhost


    Please use adapter:mysql

    On Mon, Sep 19, 2011 at 5:43 PM, venkata reddy wrote:

    I am working on windows 7 32 bit. I came across the same problem. But
    for me the below procedure worked great!


    1. edit Gemfile => gem 'mysql2', '0.2.6'
    2. download mysql-noinstall-5.1.50-win32.zip at
    http://downloads.mysql.com/archives/mysql-5.1/mysql-noinstall-5.1.50-...
    ,unzip
    3. gem install mysql2 -v 0.2.6 -- --with-mysql-lib=E:\ROR
    \mysql-5.1.50-win32\lib --with-mysql-include=E:\ROR\mysql-5.1.50-
    win32\include (replace the file "E:\ROR\mysql-5.1.50-win32" path
    with
    yours)
    4. this should work now,try bundle install,generate some
    model ,and run rake db:migrate to see if it works,make sure your
    database config is right,like this
    development:
    adapter: mysql2
    encoding: utf8
    reconnect: false
    database: depot_development
    pool: 5
    username: root
    password: root
    host: localhost
    5.if it still not work ,try this =>
    https://github.com/brianmario/mysql2/issues/8
    On Sep 19, 5:00 pm, Rajarshi wrote:
    why mysql2

    just install mysql-server
    mysql clint
    and libmysqldev

    other libraries
    then install mysql gem 2.8.1

    it will run

    no required mysql2

    On Mon, Sep 19, 2011 at 5:26 PM, venkata reddy <
    venkatareddy...@gmail.com>wrote:







    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error
    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem
    native
    extension. (Gem::Installer::ExtensionBuildError)
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers. Check the mkmf.log file for
    more
    details. You may need configuration options.
    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib
    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `load'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `<main>'
    Bens-MacBook-Pro:sharebox bengibson$
    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi <rdas2...@gmail.com>
    wrote:
    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and
    this
    went
    well. I then tried to install Rails to follow the 'How to
    build a
    dropbox
    live service' from Netttus but appear to get errors can
    anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed
    correctly.
    However when I try the command rails server i get the
    following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3,
    activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18,
    coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 12:17 pm
    Really dont know how to install this mysql library stuff.

    Detailed instructions or links to downloads would be much apprenticed

    thanks



    venkata reddy wrote:

    That might be because of the mysql2 adapter is missing
    let me know your environment details including os..
    On Sep 19, 4:52 pm, ben_hawk wrote:
    :( nope dint work, this gives me the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle install
    Fetching source index forhttp://rubygems.org/
    Using rake (0.9.2)
    Using abstract (1.0.0)
    Using activesupport (3.0.3)
    Using builder (2.1.2)
    Using i18n (0.6.0)
    Using activemodel (3.0.3)
    Using erubis (2.6.6)
    Using rack (1.2.3)
    Using rack-mount (0.6.14)
    Using rack-test (0.5.7)
    Using tzinfo (0.3.29)
    Using actionpack (3.0.3)
    Using mime-types (1.16)
    Using polyglot (0.3.2)
    Using treetop (1.4.10)
    Using mail (2.2.19)
    Using actionmailer (3.0.3)
    Using arel (2.0.10)
    Using activerecord (3.0.3)
    Using activeresource (3.0.3)
    Using bundler (1.0.18)
    Installing mysql (2.8.1) with native extensions
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:552:in
    `rescue in block in build_extensions': ERROR: Failed to build gem native
    extension. (Gem::Installer::ExtensionBuildError)

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby extconf.rb
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lm... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lz... yes
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lsocket... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lnsl... no
    checking for mysql_query() in -lmysqlclient... no
    checking for main() in -lmygcc... no
    checking for mysql_query() in -lmysqlclient... no
    *** extconf.rb failed ***
    Could not create Makefile due to some reason, probably lack of
    necessary libraries and/or headers.  Check the mkmf.log file for more
    details.  You may need configuration options.

    Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/bin/ruby
    --with-mysql-config
    --without-mysql-config
    --with-mysql-dir
    --without-mysql-dir
    --with-mysql-include
    --without-mysql-include=${mysql-dir}/include
    --with-mysql-lib
    --without-mysql-lib=${mysql-dir}/lib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mlib
    --without-mlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-zlib
    --without-zlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-socketlib
    --without-socketlib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-nsllib
    --without-nsllib
    --with-mysqlclientlib
    --without-mysqlclientlib
    --with-mygcclib
    --without-mygcclib
    --with-mysqlclientlib
    --without-mysqlclientlib

    Gem files will remain installed in
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1 for
    inspection.
    Results logged to
    /Users/bengibson/Documents/sharebox/rails/ruby/1.9.1/gems/mysql-2.8.1/ext/m
    ysql_api/gem_make.out
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:530:in
    `block in build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:505:in
    `build_extensions'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/installer.rb:180:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:101:in
    `block in install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:78:in
    `preserve_paths'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    source.rb:91:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:58:in
    `block (2 levels) in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    rubygems_integration.rb:93:in
    `with_build_args'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:57:in
    `block in run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:49:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    installer.rb:8:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    cli.rb:220:in
    `install'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/task.rb:22:in
    `run'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/invocation.rb:118:in
    `invoke_task'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor.rb:263:in
    `dispatch'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/
    vendor/thor/base.rb:386:in
    `start'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/bin/bundle:1
    3:in
    `<top (required)>'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `load'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/bundle:19:in
    `<main>'
    Bens-MacBook-Pro:sharebox bengibson$







    Rajarshi-3 wrote:
    Use gem 'mysql'
    On Mon, Sep 19, 2011 at 5:13 PM, Rajarshi wrote:

    TRY rake fuck
    On Mon, Sep 19, 2011 at 5:01 PM, venkata reddy
    wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the
    project
    as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1,
    rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2,
    rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    ...

    read more »
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494486.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 11:48 am
    Hi, thanks for the help

    Didn't work unfortunately, it gives the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle exec rake db:migrate
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)



    venkata reddy wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from
    scratch.

    --
    View this message in
    context:http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494300.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:51 am
    use gem 'mysql'

    then bundle update

    On Mon, Sep 19, 2011 at 5:18 PM, ben_hawk wrote:


    Hi, thanks for the help

    Didn't work unfortunately, it gives the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle exec rake db:migrate
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)



    venkata reddy wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a
    dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from
    scratch.

    --
    View this message in
    context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494300.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:51 am
    bundle install
    On Mon, Sep 19, 2011 at 5:21 PM, Rajarshi wrote:

    use gem 'mysql'

    then bundle update


    On Mon, Sep 19, 2011 at 5:18 PM, ben_hawk wrote:


    Hi, thanks for the help

    Didn't work unfortunately, it gives the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle exec rake db:migrate
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)



    venkata reddy wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a
    dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project
    as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from
    scratch.

    --
    View this message in
    context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494300.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:53 am
    why bundle exec rake db:migrate?

    first u have to intialize all gem so use

    bundle install
    or bundle update

    then make sure you have install mysql-server and mysql-client

    before doing all stuff other wise

    On Mon, Sep 19, 2011 at 5:21 PM, Rajarshi wrote:

    bundle install

    On Mon, Sep 19, 2011 at 5:21 PM, Rajarshi wrote:

    use gem 'mysql'

    then bundle update


    On Mon, Sep 19, 2011 at 5:18 PM, ben_hawk wrote:


    Hi, thanks for the help

    Didn't work unfortunately, it gives the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle exec rake db:migrate
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)



    venkata reddy wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this
    went
    well. I then tried to install Rails to follow the 'How to build a
    dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project
    as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from
    scratch.

    --
    View this message in
    context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com .
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494300.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Rajarshi at Sep 19, 2011 at 11:55 am
    install mysql client

    Please refer this

    http://forums.mysql.com/read.php?116,178217,178217
    On Mon, Sep 19, 2011 at 5:23 PM, Rajarshi wrote:

    why bundle exec rake db:migrate?

    first u have to intialize all gem so use

    bundle install
    or bundle update

    then make sure you have install mysql-server and mysql-client

    before doing all stuff other wise


    On Mon, Sep 19, 2011 at 5:21 PM, Rajarshi wrote:

    bundle install

    On Mon, Sep 19, 2011 at 5:21 PM, Rajarshi wrote:

    use gem 'mysql'

    then bundle update


    On Mon, Sep 19, 2011 at 5:18 PM, ben_hawk wrote:


    Hi, thanks for the help

    Didn't work unfortunately, it gives the error

    Bens-MacBook-Pro:sharebox bengibson$ bundle exec rake db:migrate
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)



    venkata reddy wrote:
    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this
    went
    well. I then tried to install Rails to follow the 'How to build a
    dropbox
    live service' from Netttus but appear to get errors can anybody
    help?.
    Once I installed rails I created a new rails project using the
    command
    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project
    as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors,
    eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following
    error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in
    `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3,
    activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10,
    bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0,
    erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14,
    mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3,
    rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in
    `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations),
    or help me completely uninstall rails and rubygems and start from
    scratch.

    --
    View this message in
    context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to
    rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494300.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google
    Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Viaduct Productions at Sep 19, 2011 at 1:32 pm
    Isn't the mysql2 gem used with Rails 3?



    Cheers
    _____________
    Rich in Toronto
    On 2011-09-19, at 7:55 AM, Rajarshi wrote:


    install mysql client

    Please refer this

    http://forums.mysql.com/read.php?116,178217,178217
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Viaduct Productions at Sep 19, 2011 at 1:25 pm
    Hi there. I too am having the same issues. I've done everything that I know of to make sure things are all up to date. Using RVM, Rails 3.1 on Snow Leopard.

    Upon this command, I still get the following error:

    $ bundle exec rake db:migrate
    /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/dependency.rb:52:in `initialize': Valid types are [:development, :runtime], not nil (ArgumentError)
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:352:in `new'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:352:in `search'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:346:in `gems_size'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:179:in `resolve'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/source_index.rb:95:in `sort_by'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `each'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `sort_by'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:175:in `resolve'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:160:in `start'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:128:in `resolve'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:127:in `catch'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/resolver.rb:127:in `resolve'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/definition.rb:151:in `resolve'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/definition.rb:90:in `specs'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/definition.rb:135:in `specs_for'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/definition.rb:124:in `requested_specs'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/environment.rb:23:in `requested_specs'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/runtime.rb:11:in `setup'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler.rb:107:in `setup'
    from /Users/rich/.rvm/gems/ruby-1.9.2-p290/gems/bundler-1.0.18/lib/bundler/setup.rb:7




    Cheers
    _____________
    Rich in Toronto
    On 2011-09-19, at 7:31 AM, venkata reddy wrote:

    Try "bundle exec rake db:migrate"
    On Sep 19, 4:17 pm, ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$

    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst [actionmailer-3.1.0,
    actionmailer-3.0.3, actionpack-3.1.0, actionpack-3.0.3, activemodel-3.1.0,
    activemodel-3.0.3, activerecord-3.1.0, activerecord-3.0.3,
    activeresource-3.1.0, activeresource-3.0.3, activesupport-3.1.0,
    activesupport-3.0.3, ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1,
    builder-3.0.0, builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1,
    coffee-script-2.2.0, coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6,
    execjs-1.2.6, hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0,
    mail-2.2.19, mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7,
    polyglot-0.3.2, rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1, sprockets-2.0.0,
    thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2, tzinfo-0.3.29,
    uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

    Could anybody help me out (i'm new to terminal so need simple explanations),
    or help me completely uninstall rails and rubygems and start from scratch.

    --
    View this message in context:http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494138.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 12:30 pm
    Still not got this working anyone else have any ideas??

    Thanks



    ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$


    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494567.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Venkata reddy at Sep 19, 2011 at 12:35 pm
    Dear ben, trust google and do the related search like installing mysql
    libraries to your environment.
    Do it first. Thats the problem, your system is missing mysql libraries
    for sure. If it is windows i could have definitely helped you!
    On Sep 19, 5:29 pm, ben_hawk wrote:
    Still not got this working anyone else have any ideas??

    Thanks









    ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.
    Once I installed rails I created a new rails project using the command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module
    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.
    --
    View this message in context:http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494567.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 1:02 pm
    I think I have MySQL working now.. I reinstalled the MYSQL dmg and made a few
    other changes to the database configuration file and now 'bundle install'
    works

    However when i try to do the following

    rake db:create

    I get the error message

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$


    Does anyone know what the problem is now??


    venkata reddy wrote:
    Dear ben, trust google and do the related search like installing mysql
    libraries to your environment.
    Do it first. Thats the problem, your system is missing mysql libraries
    for sure. If it is windows i could have definitely helped you!
    On Sep 19, 5:29 pm, ben_hawk wrote:
    Still not got this working anyone else have any ideas??

    Thanks









    ben_hawk wrote:
    Hi,
    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.
    Once I installed rails I created a new rails project using the command
    (Rails new sharebox -d mysql)
    This worked and created the folder structure.
    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial
    source 'http://rubygems.org'
    gem 'rails', '3.0.3'
    gem 'ruby-mysql'
    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.
    However when I try the command rails server i get the following error:
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$
    And when I try the command
    rake db:create
    I get a similar error
    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module
    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_mo
    dule.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/applica
    tion.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubyg
    ems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.
    --
    View this message in
    context:http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494567.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.
    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494820.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Jim Ruther Nill at Sep 19, 2011 at 12:41 pm

    On Mon, Sep 19, 2011 at 8:29 PM, ben_hawk wrote:
    Still not got this working anyone else have any ideas??
    you need to install mysql library first.
    http://lmgtfy.com/?q=install+mysql+osx+lion

    Thanks



    ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$


    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494567.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 1:01 pm
    I think I have MySQL working now.. I reinstalled the MYSQL dmg and made a few
    other changes to the database configuration file and now 'bundle install'
    works

    However when i try to do the following

    rake db:create

    I get the error message

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$


    Does anyone know what the problem is now??


    Jim ruther Nill wrote:
    On Mon, Sep 19, 2011 at 8:29 PM, ben_hawk wrote:


    Still not got this working anyone else have any ideas??
    you need to install mysql library first.
    http://lmgtfy.com/?q=install+mysql+osx+lion

    Thanks



    ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$


    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>
    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.

    --
    View this message in context:
    http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494567.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    -------------------------------------------------------------
    visit my blog at http://jimlabs.heroku.com

    --
    You received this message because you are subscribed to the Google Groups
    "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to
    rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at
    http://groups.google.com/group/rubyonrails-talk?hl=en.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494808.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 12:50 pm
    I think I have MySQL working now.. I reinstalled the MYSQL dmg and made a few
    other changes to the database configuration file and now 'bundle install'
    works

    However when i try to do the following

    rake db:create

    I get the error message

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$


    Does anyone know what the problem is now??



    ben_hawk wrote:
    Still not got this working anyone else have any ideas??

    Thanks



    ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$


    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494721.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Ben_hawk at Sep 19, 2011 at 1:12 pm
    I tried removing rails using the gem unistall rails '3.0.3'

    and then reinstall it and I get the following error with the rails
    installation

    Bens-MacBook-Pro:sharebox bengibson$ gem install rails '3.0.3'
    Fetching: rails-3.1.0.gem (100%)
    Successfully installed rails-3.1.0
    ERROR: Could not find a valid gem '3.0.3' (>= 0) in any repository
    1 gem installed
    Installing ri documentation for rails-3.1.0...
    file 'lib' not found
    Installing RDoc documentation for rails-3.1.0...
    file 'lib' not found

    What is going on?!?!

    Thanks





    ben_hawk wrote:
    Hi,

    I followed a Tutorial on Nettuts to install Ruby with RVM and this went
    well. I then tried to install Rails to follow the 'How to build a dropbox
    live service' from Netttus but appear to get errors can anybody help?.

    Once I installed rails I created a new rails project using the command

    (Rails new sharebox -d mysql)

    This worked and created the folder structure.

    I then went and added the following to the gem folder for the project as
    suggested by the netuts tutorial

    source 'http://rubygems.org'

    gem 'rails', '3.0.3'
    gem 'ruby-mysql'

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.

    However when I try the command rails server i get the following error:

    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
    Bens-MacBook-Pro:~ bengibson$


    And when I try the command

    rake db:create

    I get a similar error

    Bens-MacBook-Pro:sharebox bengibson$ rake db:create
    rake aborted!
    undefined method `groups' for Rails:Module

    (See full trace by running task with --trace)
    Bens-MacBook-Pro:sharebox bengibson$ db:create --trace
    -bash: db:create: command not found
    Bens-MacBook-Pro:sharebox bengibson$ rake --trace
    rake aborted!
    undefined method `groups' for Rails:Module
    /Users/bengibson/Documents/sharebox/config/application.rb:7:in `<top
    (required)>'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
    `require'
    /Users/bengibson/Documents/sharebox/Rakefile:5:in `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/rake_module.rb:25:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:495:in
    `raw_load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:78:in
    `block in load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:77:in
    `load_rakefile'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:61:in
    `block in run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:129:in
    `standard_exception_handling'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/lib/rake/application.rb:59:in
    `run'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/gems/rake-0.9.2/bin/rake:32:in
    `<top (required)>'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `load'
    /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/rake:19:in `<main>'
    Bens-MacBook-Pro:sharebox bengibson$ Rails server
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/dependency.rb:247:in
    `to_specs': Could not find abstract (>= 1.0.0) amongst
    [actionmailer-3.1.0, actionmailer-3.0.3, actionpack-3.1.0,
    actionpack-3.0.3, activemodel-3.1.0, activemodel-3.0.3,
    activerecord-3.1.0, activerecord-3.0.3, activeresource-3.1.0,
    activeresource-3.0.3, activesupport-3.1.0, activesupport-3.0.3,
    ansi-1.3.0, arel-2.2.1, arel-2.0.10, bcrypt-ruby-3.0.1, builder-3.0.0,
    builder-2.1.2, bundler-1.0.18, coffee-rails-3.1.1, coffee-script-2.2.0,
    coffee-script-source-1.1.2, erubis-2.7.0, erubis-2.6.6, execjs-1.2.6,
    hike-1.2.1, i18n-0.6.0, jquery-rails-1.0.14, mail-2.3.0, mail-2.2.19,
    mime-types-1.16, multi_json-1.0.3, mysql2-0.3.7, polyglot-0.3.2,
    rack-1.3.2, rack-1.2.3, rack-cache-1.0.3, rack-mount-0.8.3,
    rack-mount-0.6.14, rack-ssl-1.3.2, rack-test-0.6.1, rack-test-0.5.7,
    rails-3.0.3, railties-3.1.0, railties-3.0.3, rake-0.9.2, rdoc-3.9.4,
    rdoc-2.5.11, rdoc-data-2.5.3, sass-3.1.7, sass-rails-3.1.1,
    sprockets-2.0.0, thor-0.14.6, tilt-1.3.3, treetop-1.4.10, turn-0.8.2,
    tzinfo-0.3.29, uglifier-1.0.3] (Gem::LoadError)
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:761:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:764:in
    `block in activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `each'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:758:in
    `activate_dependencies'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:742:in
    `activate'
    from
    /Users/bengibson/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1211:in
    `gem'
    from /Users/bengibson/.rvm/gems/ruby-1.9.2-p290/bin/Rails:18:in `<main>

    Could anybody help me out (i'm new to terminal so need simple
    explanations), or help me completely uninstall rails and rubygems and
    start from scratch.

    --
    View this message in context: http://old.nabble.com/Installing-Rails-Help%21-tp32494138p32494897.html
    Sent from the RubyOnRails Users mailing list archive at Nabble.com.

    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.
  • Viaduct Productions at Sep 19, 2011 at 1:26 pm
    Hi Ben. I get something similar, line 52 in dependency.rb. If you find a solution, let me know.



    Cheers
    _____________
    Rich in Toronto
    On 2011-09-19, at 7:17 AM, ben_hawk wrote:

    I then did the bundle install but this kept causing errors, eventually
    somehow I got this to work and it said bundle installed correctly.
    --
    You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group.
    To post to this group, send email to rubyonrails-talk@googlegroups.com.
    To unsubscribe from this group, send email to rubyonrails-talk+unsubscribe@googlegroups.com.
    For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouprubyonrails-talk @
categoriesrubyonrails
postedSep 19, '11 at 11:18a
activeSep 19, '11 at 1:32p
posts28
users5
websiterubyonrails.org
irc#RubyOnRails

People

Translate

site design / logo © 2021 Grokbase