FAQ
why on redis_version:2.8.4?

127.0.0.1:6379> CONFIG set maxclients 60000
(error) ERR The operating system is not able to handle the specified number
of clients, try with 4000

despite the following:

root@test:~# ulimit
unlimited



--
You received this message because you are subscribed to the Google Groups "Redis DB" group.
To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
To post to this group, send email to redis-db@googlegroups.com.
Visit this group at http://groups.google.com/group/redis-db.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Jan-Erik Rediger at Jan 24, 2015 at 2:58 pm
    Without a argument, ulimit displays the file size limit (-f).

    "ulimit -n" will give you the "open file descriptors" limit, which is
    probably 4096.
    On Sat, Jan 24, 2015 at 04:08:51AM -0800, Tampa312 wrote:

    why on redis_version:2.8.4?

    127.0.0.1:6379> CONFIG set maxclients 60000
    (error) ERR The operating system is not able to handle the specified number
    of clients, try with 4000

    despite the following:

    root@test:~# ulimit
    unlimited



    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.
  • Tampa312 at Jan 25, 2015 at 2:36 am
    Per the below ulimit is set to 100000.

    root@test:/home/ubuntu# ulimit -n
    100000

    127.0.0.1:6379> CONFIG set maxclients 10000
    (error) ERR The operating system is not able to handle the specified number
    of clients, try with 4000


    Thanks


    On Saturday, January 24, 2015 at 9:58:19 PM UTC+7, janerik wrote:

    Without a argument, ulimit displays the file size limit (-f).

    "ulimit -n" will give you the "open file descriptors" limit, which is
    probably 4096.
    On Sat, Jan 24, 2015 at 04:08:51AM -0800, Tampa312 wrote:

    why on redis_version:2.8.4?

    127.0.0.1:6379> CONFIG set maxclients 60000
    (error) ERR The operating system is not able to handle the specified number
    of clients, try with 4000

    despite the following:

    root@test:~# ulimit
    unlimited



    --
    You received this message because you are subscribed to the Google
    Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to redis-db+u...@googlegroups.com <javascript:>.
    To post to this group, send email to redi...@googlegroups.com
    <javascript:>.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.
  • Matt Palmer at Jan 25, 2015 at 5:15 am

    On Sat, Jan 24, 2015 at 06:36:11PM -0800, Tampa312 wrote:
    Per the below ulimit is set to 100000.

    root@test:/home/ubuntu# ulimit -n
    100000
    That shows what your shell has access to 100k fds, but it doesn't have any
    bearing on what Redis is allowed to have. Get the PID of your Redis server
    process (`pgrep redis-server`) and then `cat /proc/<PID>/limits` and give us
    that output.
    127.0.0.1:6379> CONFIG set maxclients 10000
    (error) ERR The operating system is not able to handle the specified number
    of clients, try with 4000
    In addition to this error in the console, your Redis log should also have a
    WARNING-level message along the lines of "Unable to set the max number of
    files limit to ...". The full error message may be useful, to you or to us.

    - Matt

    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupredis-db @
categoriesredis
postedJan 24, '15 at 12:08p
activeJan 25, '15 at 5:15a
posts4
users3
websiteredis.io
irc#redis

People

Translate

site design / logo © 2022 Grokbase