FAQ
Hi

I am trying to run unstable version of redis in cluster mode and add them
to cluster.
But i was not able to run redis-trib.rb, i am new to redis & linx too.
Please help me!!

tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load
such file -- redis (LoadError)
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from ./redis-trib.rb:25:in `<main>'

Thanks
Naveen

--
You received this message because you are subscribed to the Google Groups "Redis DB" group.
To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
To post to this group, send email to redis-db@googlegroups.com.
Visit this group at http://groups.google.com/group/redis-db.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jan-Erik Rediger at Jan 3, 2014 at 1:33 pm

    On Fri, Dec 27, 2013 at 11:57:21AM -0800, Naveen Chitturi wrote:
    Hi

    I am trying to run unstable version of redis in cluster mode and add them
    to cluster.
    But i was not able to run redis-trib.rb, i am new to redis & linx too.
    Please help me!!

    tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load
    such file -- redis (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from ./redis-trib.rb:25:in `<main>'
    You need the redis gem[1] installed.

       gem install redis

    [1]: https://rubygems.org/gems/redis

    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Dipak Bhimani at Jan 3, 2014 at 2:12 pm
    I have recently gone through this exercise. You need to follow -

    1. install the rubygem ( http://rubygems.org/pages/download)
    2. ruby setup.rb ( You will find setup.rb in rubygem installation path)
    3. gem install rubygems-update -v 1.8.7 ( I have ruby version 1.8.7 so I
    have upgrade rubygems accordingly)
    4. gem install redis

    In case you face the SSL issue on step 3 and 4, you can disable the SSL
    with following CLI ( If you are doing on LAB setup, this is quick work
    around)
    sudo gem sources -r https://rubygems.org/
    sudo gem sources -a http://rubygems.org/

    Thanks,
    Dipak

    On Friday, January 3, 2014 7:03:20 PM UTC+5:30, Jan-Erik Rediger wrote:
    On Fri, Dec 27, 2013 at 11:57:21AM -0800, Naveen Chitturi wrote:
    Hi

    I am trying to run unstable version of redis in cluster mode and add them
    to cluster.
    But i was not able to run redis-trib.rb, i am new to redis & linx too.
    Please help me!!

    tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load
    such file -- redis (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from ./redis-trib.rb:25:in `<main>'
    You need the redis gem[1] installed.

    gem install redis

    [1]: https://rubygems.org/gems/redis
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Aka at Feb 10, 2014 at 8:33 pm
    I have the same problem and tried to follow the steps here but I still
    cant' find redis-trib.rb. What else needs to happen in order for this file
    to get generated? ( I installed ruby and rubygems but i don't know if/how
    redis is going to find them...)
    On Friday, January 3, 2014 6:12:44 AM UTC-8, Dipak Bhimani wrote:

    I have recently gone through this exercise. You need to follow -

    1. install the rubygem ( http://rubygems.org/pages/download)
    2. ruby setup.rb ( You will find setup.rb in rubygem installation path)
    3. gem install rubygems-update -v 1.8.7 ( I have ruby version 1.8.7 so I
    have upgrade rubygems accordingly)
    4. gem install redis

    In case you face the SSL issue on step 3 and 4, you can disable the SSL
    with following CLI ( If you are doing on LAB setup, this is quick work
    around)
    sudo gem sources -r https://rubygems.org/
    sudo gem sources -a http://rubygems.org/

    Thanks,
    Dipak

    On Friday, January 3, 2014 7:03:20 PM UTC+5:30, Jan-Erik Rediger wrote:
    On Fri, Dec 27, 2013 at 11:57:21AM -0800, Naveen Chitturi wrote:
    Hi

    I am trying to run unstable version of redis in cluster mode and add them
    to cluster.
    But i was not able to run redis-trib.rb, i am new to redis & linx too.
    Please help me!!

    tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load
    such file -- redis (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from ./redis-trib.rb:25:in `<main>'
    You need the redis gem[1] installed.

    gem install redis

    [1]: https://rubygems.org/gems/redis
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Owiec at Feb 3, 2015 at 12:44 pm
    apt-get update
    apt-get install ruby
    gem install redis


    W dniu piątek, 27 grudnia 2013 20:57:21 UTC+1 użytkownik Naveen Chitturi
    napisał:
    Hi

    I am trying to run unstable version of redis in cluster mode and add them
    to cluster.
    But i was not able to run redis-trib.rb, i am new to redis & linx too.
    Please help me!!

    tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot
    load such file -- redis (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from ./redis-trib.rb:25:in `<main>'

    Thanks
    Naveen
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.
  • Freire Zhu at Feb 10, 2015 at 12:17 pm
    try this:
    $ yum install ruby ruby-devel rubygems rpm-build
    $ gem install redis

    在 2013年12月28日星期六 UTC+8上午3:57:21,Naveen Chitturi写道:
    Hi

    I am trying to run unstable version of redis in cluster mode and add them
    to cluster.
    But i was not able to run redis-trib.rb, i am new to redis & linx too.
    Please help me!!

    tzrqbr@tzrqbr:~/redis/redis-unstable/src$ ./redis-trib.rb
    /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot
    load such file -- redis (LoadError)
    from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
    from ./redis-trib.rb:25:in `<main>'

    Thanks
    Naveen
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupredis-db @
categoriesredis
postedJan 3, '14 at 12:16p
activeFeb 10, '15 at 12:17p
posts6
users6
websiteredis.io
irc#redis

People

Translate

site design / logo © 2022 Grokbase