FAQ
I have a 2.6 Redis instance that is periodically doing very slow (10+ sec)
ZADDs to sets that have about 10 elements.

The total memory used by this instance is ~1GB, with about 7 million keys.

Possibly related to this is that the bgsaves are taking ~16 seconds (a keys
* takes about 12 seconds so maybe that's
about the length of time to iterate over the keys?). Per redis info, the
fork() portion of the bgsave is only taking a few
millisecs. I thought that after the fork() the bgsave wouldn't
interfere with other operations.

I have the vm.overcommit_memory option enabled

Any ideas why the ZADD would take so long in this configuration, or ideas
about what to look into next?

Thanks,
Archie

PS Apologies if this is a duplicate post

--
You received this message because you are subscribed to the Google Groups "Redis DB" group.
To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
To post to this group, send email to redis-db@googlegroups.com.
Visit this group at http://groups.google.com/group/redis-db?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Yiftach Shoolman at May 30, 2013 at 1:00 pm
    Hi Archie,

    The slow BGSAVE seems unrelated to me, as it forks another child process -
    unless you have too many running processes on a machine with a low number
    of cores.

    Can you send the output of your INFO and slowlog, ?


    On Wed, May 29, 2013 at 10:31 PM, Archie R wrote:


    I have a 2.6 Redis instance that is periodically doing very slow (10+ sec)
    ZADDs to sets that have about 10 elements.

    The total memory used by this instance is ~1GB, with about 7 million keys.

    Possibly related to this is that the bgsaves are taking ~16 seconds (a
    keys * takes about 12 seconds so maybe that's
    about the length of time to iterate over the keys?). Per redis info, the
    fork() portion of the bgsave is only taking a few
    millisecs. I thought that after the fork() the bgsave wouldn't
    interfere with other operations.

    I have the vm.overcommit_memory option enabled

    Any ideas why the ZADD would take so long in this configuration, or ideas
    about what to look into next?

    Thanks,
    Archie

    PS Apologies if this is a duplicate post

    --
    You received this message because you are subscribed to the Google Groups
    "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.



    --

    Yiftach Shoolman
    +972-54-7634621

    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupredis-db @
categoriesredis
postedMay 30, '13 at 7:56a
activeMay 30, '13 at 1:00p
posts2
users2
websiteredis.io
irc#redis

2 users in discussion

Archie R: 1 post Yiftach Shoolman: 1 post

People

Translate

site design / logo © 2022 Grokbase