FAQ
Hi

I have a big app on Rails 3.0.19. Used redis-rb 2. I'm trying to
update to 3.0.2 gem. Encountered the following problem. When the
application redis-rb is wrong returns the results of commands that
must be of type Boolean. In place of boolean returns fixnum. In
particular, this happens with exist.
I started to debug the code in the method of call, Redis::Client param
block why is nil, although there is passed block.
And the strange thing is that if I create a pure Ruby application, the
same code (gem redis-rb 3.0.2), works correctly. It turns out that the
problem occurs when our set of gems and code.

Use Ruby 1.9.3 with some patches, ubuntu, redis server 2.6.8.

I find a similar problem here:
https://groups.google.com/group/redis-db/msg/25893fef2ded3c15

--
You received this message because you are subscribed to the Google Groups "Redis DB" group.
To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
To post to this group, send email to redis-db@googlegroups.com.
Visit this group at http://groups.google.com/group/redis-db?hl=en.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Josiah Carlson at Feb 18, 2013 at 5:40 am
    You may want to post an issue to the redis-rb issue tracker at Github:
    https://github.com/redis/redis-rb
    On Fri, Feb 15, 2013 at 11:07 AM, Artem wrote:
    Hi

    I have a big app on Rails 3.0.19. Used redis-rb 2. I'm trying to
    update to 3.0.2 gem. Encountered the following problem. When the
    application redis-rb is wrong returns the results of commands that
    must be of type Boolean. In place of boolean returns fixnum. In
    particular, this happens with exist.
    I started to debug the code in the method of call, Redis::Client param
    block why is nil, although there is passed block.
    And the strange thing is that if I create a pure Ruby application, the
    same code (gem redis-rb 3.0.2), works correctly. It turns out that the
    problem occurs when our set of gems and code.

    Use Ruby 1.9.3 with some patches, ubuntu, redis server 2.6.8.

    I find a similar problem here:
    https://groups.google.com/group/redis-db/msg/25893fef2ded3c15

    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Artem at Feb 18, 2013 at 7:31 am
    Thank you. I found a problem. problem was in the heme rack-bug. Monkey
    patching. Fixed.

    --
    You received this message because you are subscribed to the Google Groups "Redis DB" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to redis-db+unsubscribe@googlegroups.com.
    To post to this group, send email to redis-db@googlegroups.com.
    Visit this group at http://groups.google.com/group/redis-db?hl=en.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
groupredis-db @
categoriesredis
postedFeb 15, '13 at 7:09p
activeFeb 18, '13 at 7:31a
posts3
users2
websiteredis.io
irc#redis

2 users in discussion

Artem: 2 posts Josiah Carlson: 1 post

People

Translate

site design / logo © 2022 Grokbase