FAQ
When I run


  /opt/puppetlabs/bin/puppet node find <nodename>

I get the expected wall of JSON and agents work fine too.

However, I would like to set up monitoring. When I run:

curl --cert /etc/puppetlabs/puppet/ssl/certs/mymachine.pem \
      --key /etc/puppetlabs/puppet/ssl/private_keys/mymachine.pem \
      --cacert /etc/puppetlabs/puppet/ssl/ca/ca_crt.pem \
      -H 'Accept: pson' \
      https://<puppetmaster>:8140/puppet/v3/catalog/<nodename>?environment=production

the server returns Error 403: Forbidden

Is there something in auth.conf to add to enable acces to API outside of
CLI?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/ebdac597-b4c4-4677-ba7a-ab74da9092dd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 11, '15 at 2:31p
activeSep 14, '15 at 4:00p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Josh Cooper: 1 post Chris Cowley: 1 post

People

Translate

site design / logo © 2022 Grokbase