FAQ
HI,
I have set up a master with 400+ agents. My master has 2015.2. I have to
setup 4 environments and all are test environments. I've tried creating
directories named with the test environments at
/etc/puppetlabs/code/environments/test1
/etc/puppetlabs/code/environments/test2
/etc/puppetlabs/code/environments/test3 and
/etc/puppetlabs/code/environments/test4.
I have also changed the environment field to test1 in one of the agents but
it doesn't seems to be happy. could anyone help me on this please.


Regards
Giridhar

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/5cf87f13-ba2f-45c3-9bdc-dd108a059e31%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Lindsey Smith at Sep 8, 2015 at 3:49 pm

    On Mon, Sep 7, 2015 at 9:18 PM, giridhar kazama wrote:

    HI,
    I have set up a master with 400+ agents. My master has 2015.2. I have to
    setup 4 environments and all are test environments. I've tried creating
    directories named with the test environments at
    /etc/puppetlabs/code/environments/test1
    /etc/puppetlabs/code/environments/test2
    /etc/puppetlabs/code/environments/test3 and
    /etc/puppetlabs/code/environments/test4.
    I have also changed the environment field to test1 in one of the agents
    but it doesn't seems to be happy. could anyone help me on this please.
    Could you expand on what you tried and what the output was? I created an
    empty /etc/puppetlabs/code/environments/test directory, refreshed classes
    in the PE UI instead of waiting for puppet server to refresh on a timer and
    the test environment was present in the UI.


    Regards
    Giridhar

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/5cf87f13-ba2f-45c3-9bdc-dd108a059e31%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/5cf87f13-ba2f-45c3-9bdc-dd108a059e31%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAPyei8XxrLg_TLorfDbejCyVmYjUDLEzVwZUxyK%3D7c7WeDL5dw%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Giridhar kazama at Sep 9, 2015 at 2:09 pm
    Thanks alot. That really did the trick. I realized it very lately. I wasn't
    refreshing the classes so didn't get it immediately.Your help is very much
    appreciated.

    Now I am having a hustle while picking up the hiera data. Its working when
    I am using the static directory structure in the datadir but it doesn't if
    I give variables.


    static dir : /etc/puppetlabs/code/environments/production/hieradata
    dynamic : /etc/puppetlabs/code/environments/%{environments}/hieradata

    On Tuesday, September 8, 2015 at 10:00:52 AM UTC+5:30, giridhar kazama
    wrote:
    HI,
    I have set up a master with 400+ agents. My master has 2015.2. I have to
    setup 4 environments and all are test environments. I've tried creating
    directories named with the test environments at
    /etc/puppetlabs/code/environments/test1
    /etc/puppetlabs/code/environments/test2
    /etc/puppetlabs/code/environments/test3 and
    /etc/puppetlabs/code/environments/test4.
    I have also changed the environment field to test1 in one of the agents
    but it doesn't seems to be happy. could anyone help me on this please.


    Regards
    Giridhar
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/29ed3d95-4b8b-4b1c-a4d7-925b13c50489%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Giridhar kazama at Sep 9, 2015 at 2:22 pm
    Sorry forgot to post the output:
    [root@example1234 hieradata]# hiera example12345
    nil
    [root@example1234 hieradata]# hiera example12345 --debug
    DEBUG: 2015-09-09 15:12:35 +0100: Hiera YAML backend starting
    DEBUG: 2015-09-09 15:12:35 +0100: Looking up example12345 in YAML backend
    DEBUG: 2015-09-09 15:12:35 +0100: Looking for data source defaults
    DEBUG: 2015-09-09 15:12:35 +0100: Cannot find datafile
    /etc/puppetlabs/code/environments//hieradata/defaults.yaml, skipping
    DEBUG: 2015-09-09 15:12:35 +0100: Looking for data source global
    DEBUG: 2015-09-09 15:12:35 +0100: Cannot find datafile
    /etc/puppetlabs/code/environments//hieradata/global.yaml, skipping
    nil





    On Tuesday, September 8, 2015 at 10:00:52 AM UTC+5:30, giridhar kazama
    wrote:
    HI,
    I have set up a master with 400+ agents. My master has 2015.2. I have to
    setup 4 environments and all are test environments. I've tried creating
    directories named with the test environments at
    /etc/puppetlabs/code/environments/test1
    /etc/puppetlabs/code/environments/test2
    /etc/puppetlabs/code/environments/test3 and
    /etc/puppetlabs/code/environments/test4.
    I have also changed the environment field to test1 in one of the agents
    but it doesn't seems to be happy. could anyone help me on this please.


    Regards
    Giridhar
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/09774dce-d797-43a2-bfcc-4b88744b5867%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Jamese at Sep 9, 2015 at 2:47 pm
    Hi,

    You want to specify: %{environment}
    rather than: %{environments}

    J

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/9d98e2f1-724f-4acb-9a17-f5913af56b24%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 8, '15 at 4:30a
activeSep 9, '15 at 2:47p
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase