FAQ
Hi,

I try to install puppet-dashboard from Debian respository, but see the
error :

puppet-dashboard depends on ruby1.8 (>= 1.8.7); however:
   Package ruby1.8 is not installed.


puppet-dashboard depends on libdbd-mysql-ruby; however:
   Package libdbd-mysql-ruby is not installed.

Thanks.


--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/a8a62e47-e2fb-4880-b40e-b136c989c959%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Dirk Heinrichs at Aug 28, 2015 at 6:34 am

    Am 28.08.2015 um 02:42 schrieb Marcos Renato:

    I try to install puppet-dashboard from Debian respository, but see the
    error :
    puppet-dashboard depends on ruby1.8 (>= 1.8.7); however:
    Package ruby1.8 is not installed.
    puppet-dashboard depends on libdbd-mysql-ruby; however:
    Package libdbd-mysql-ruby is not installed.
    Don't give too much details, people may be able to help you.

    So, how do you try to install it (please provide exact command plus its
    complete output)?

    Bye...

         Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com
    *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E000F1.1090900%40recommind.com.
    For more options, visit https://groups.google.com/d/optout.
  • Marcos Ata1983 at Aug 28, 2015 at 11:59 am
    apt-get install puppet-dashboard

    Lendo listas de pacotes... Pronto
    Construindo árvore de dependências
    Lendo informação de estado... Pronto
    Alguns pacotes não puderam ser instalados. Isto pode significar que
    você solicitou uma situação impossível ou, se você está usando a
    distribuição instável, que alguns pacotes requeridos não foram
    criados ainda ou foram retirados da "Incoming".
    A informação a seguir pode ajudar a resolver a situação:

    Os pacotes a seguir têm dependências desencontradas:
       puppet-dashboard : Depende: ruby1.8 (>= 1.8.7) mas não é instalável
                          Depende: libdbd-mysql-ruby mas não é instalável
    E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

    Em 28-08-2015 03:34, Dirk Heinrichs escreveu:
    Am 28.08.2015 um 02:42 schrieb Marcos Renato:
    I try to install puppet-dashboard from Debian respository, but see
    the error :
    puppet-dashboard depends on ruby1.8 (>= 1.8.7); however:
    Package ruby1.8 is not installed.
    puppet-dashboard depends on libdbd-mysql-ruby; however:
    Package libdbd-mysql-ruby is not installed.
    Don't give too much details, people may be able to help you.

    So, how do you try to install it (please provide exact command plus
    its complete output)?

    Bye...

    Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>
    --
    You received this message because you are subscribed to a topic in the
    Google Groups "Puppet Users" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/puppet-users/NMhaHBplYoY/unsubscribe.
    To unsubscribe from this group and all its topics, send an email to
    puppet-users+unsubscribe@googlegroups.com
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/55E000F1.1090900%40recommind.com
    <https://groups.google.com/d/msgid/puppet-users/55E000F1.1090900%40recommind.com?utm_medium=email&utm_source=footer>.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E04CFC.5010009%40gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Dirk Heinrichs at Aug 28, 2015 at 12:02 pm

    Am 28.08.2015 um 13:58 schrieb marcos.ata1983@gmail.com:

    apt-get install puppet-dashboard

    Lendo listas de pacotes... Pronto
    Try again please with

    LC_ALL=C apt-get install puppet-dashboard

    so that I can actually understand the language ;)

    Bye...

         Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com
    *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E04DB7.6040106%40recommind.com.
    For more options, visit https://groups.google.com/d/optout.
  • Marcos Ata1983 at Aug 28, 2015 at 12:12 pm
    sorry,


    apt-get install puppet-dashboard

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
       puppet-dashboard : Depends: ruby1.8 (>= 1.8.7) but it is not installable
                          Depends: libdbd-mysql-ruby but it is not installable
    E: Unable to correct problems, you have held broken packages.



    /etc/apt/sources.list.d/puppetlabs.list

    deb http://apt.puppetlabs.com wheezy main
    deb-src http://apt.puppetlabs.com wheezy main
    deb http://apt.puppetlabs.com wheezy dependencies
    deb-src http://apt.puppetlabs.com wheezy dependencies

    jessie does not have puppet-dashboard.

    Em 28-08-2015 09:01, Dirk Heinrichs escreveu:
    LC_ALL=C apt-get install puppet-dashboard
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E05017.5030401%40gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Dirk Heinrichs at Aug 28, 2015 at 12:16 pm

    Am 28.08.2015 um 14:12 schrieb marcos.ata1983@gmail.com:
    /etc/apt/sources.list.d/puppetlabs.list

    deb http://apt.puppetlabs.com wheezy main
    deb-src http://apt.puppetlabs.com wheezy main
    deb http://apt.puppetlabs.com wheezy dependencies
    deb-src http://apt.puppetlabs.com wheezy dependencies

    jessie does not have puppet-dashboard.
    Yep, because it's deprecated. And Jessie doesn't have ruby1.8 anymore.
    Try The Foreman <http://theforeman.org/> instead of Dashboard.

    HTH...

         Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com
    *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E05120.3030409%40recommind.com.
    For more options, visit https://groups.google.com/d/optout.
  • Dirk Heinrichs at Aug 28, 2015 at 12:11 pm

    Am 28.08.2015 um 02:42 schrieb Marcos Renato:

    I try to install puppet-dashboard from Debian respository, but see the
    error :

    puppet-dashboard depends on ruby1.8 (>= 1.8.7); however: Package
    ruby1.8 is not installed.

    puppet-dashboard depends on libdbd-mysql-ruby; however: Package
    libdbd-mysql-ruby is not installed.
    Guess you tried to use the Wheezy repository on Jessie. Jessie doesn't
    have ruby1.8 anymore.

    Bye...

         dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com
    *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E04FD7.6020202%40recommind.com.
    For more options, visit https://groups.google.com/d/optout.
  • Dirk Heinrichs at Aug 28, 2015 at 12:14 pm

    Am 28.08.2015 um 02:42 schrieb Marcos Renato:
    I try to install puppet-dashboard
    Puppet Dashboard is also deprecated, I'd recommend you use The Foreman
    <http://theforeman.org/> instead.

    HTH...

         Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com
    *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E05082.7030007%40recommind.com.
    For more options, visit https://groups.google.com/d/optout.
  • Marcos Ata1983 at Aug 28, 2015 at 12:17 pm
    I understand, thank you for the answers . I try The Foreman.
    Em 28-08-2015 09:13, Dirk Heinrichs escreveu:
    Am 28.08.2015 um 02:42 schrieb Marcos Renato:
    I try to install puppet-dashboard
    Puppet Dashboard is also deprecated, I'd recommend you use The Foreman
    <http://theforeman.org/> instead.

    HTH...

    Dirk
    --

    *Dirk Heinrichs*, Senior Systems Engineer, Engineering Solutions
    *Recommind GmbH*, Von-Liebig-Straße 1, 53359 Rheinbach
    *Tel*: +49 2226 1596666 (Ansage) 1149
    *Email*: dhs@recommind.com *Skype*: dirk.heinrichs.recommind
    www.recommind.com <http://www.recommind.com>
    --
    You received this message because you are subscribed to a topic in the
    Google Groups "Puppet Users" group.
    To unsubscribe from this topic, visit
    https://groups.google.com/d/topic/puppet-users/NMhaHBplYoY/unsubscribe.
    To unsubscribe from this group and all its topics, send an email to
    puppet-users+unsubscribe@googlegroups.com
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/55E05082.7030007%40recommind.com
    <https://groups.google.com/d/msgid/puppet-users/55E05082.7030007%40recommind.com?utm_medium=email&utm_source=footer>.
    For more options, visit https://groups.google.com/d/optout.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/55E05138.9040301%40gmail.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 28, '15 at 12:42a
activeAug 28, '15 at 12:17p
posts9
users2
websitepuppetlabs.com

2 users in discussion

Dirk Heinrichs: 5 posts Marcos Ata1983: 4 posts

People

Translate

site design / logo © 2022 Grokbase