FAQ
Hello all,

I also have similar issue with launching the Puppet Dashboard UI, Below is
my config file. Please can anyone help me on this issue.

Error I am getting : [Thu Aug 20 05:25:09 2015] [error] [client
192.168.XXX.XXX] Directory index forbidden by Options directive:
/usr/share/puppet-dashboard/public/
Below is my VirtualHost file.

# UPDATE THESE PATHS TO SUIT YOUR ENVIRONMENT
#LoadModule passenger_module
/var/lib/gems/1.8/gems/passenger-2.2.11/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-5.0.15
PassengerRuby /usr/
#PassengerRuby /usr/bin/ruby

# you may want to tune these settings
PassengerHighPerformance on
PassengerMaxPoolSize 12
PassengerPoolIdleTime 1500
# PassengerMaxRequests 1000
PassengerStatThrottleRate 120
#RailsAutoDetect On
Listen 3000

<VirtualHost *:3000>
         ServerName puppetma.domain.net
         ServerAlias puppetma
         DocumentRoot /usr/share/puppet-dashboard/public/
<Directory /usr/share/puppet-dashboard/public/>
                 Options None
                 Order allow,deny
                 allow from all
         </Directory>
   ErrorLog /var/log/httpd/puppet-dashboard_error.log
   LogLevel warn
   CustomLog /var/log/httpd/puppet-dashboard_access.log combined
   ServerSignature On

I could see my DNS is absolutely working fine, I have also ensured
stopping my host level firewall and selinux.

Thanks,
Kiran
On Friday, March 9, 2012 at 5:33:23 AM UTC-8, theirpuppet wrote:

Hello all

Puppet, puppetmaster, ruby, etc installed from standard Ubuntu 11.10
x86_64 APT repos
Dashboard 1.26 from .deb pulled from
http://apt.puppetlabs.com/pool/oneiric/main/p/puppet-dashboard/
Apache config pulled
from /usr/share/puppet-dashboard/ext/passenger/dashboard-vhost.conf

My simple test with webbrick worked a treat. So I installed Apache and
passenger mod (from Ubuntu APT repos) and that's where I had a problem. The
error from Apache2 error log:
[Fri Mar 09 13:09:35 2012] [error] [client 1.2.3.4] Directory index
forbidden by Options directive: /usr/share/puppet-dashboard/public/,
referer: http://[IP ADDRESS]:3000/nodes/unchanged

Adding Options +Indexes is not the resolution as it just displays the
static files in that directory.

Here's my /etc/apache2/sites-enabled/010-dashboard.conf:
#PassengerRoot /var/lib/gems/1.8/gems/passenger-2.2.11
PassengerRoot /usr/lib/phusion_passenger
PassengerRuby /usr/bin/ruby
# you may want to tune these settings
PassengerHighPerformance on
PassengerMaxPoolSize 12
PassengerPoolIdleTime 1500
# PassengerMaxRequests 1000
PassengerStatThrottleRate 120
RailsAutoDetect On
<VirtualHost *:3000>
ServerName FQDN
ServerAlias X.X.X.X

DocumentRoot /usr/share/puppet-dashboard/public/
<Directory /usr/share/puppet-dashboard/public/>
Options None
Order allow,deny
allow from all
</Directory>
#ErrorLog /var/log/apache2/dashboard.example.com_error.log
LogLevel warn
#CustomLog /var/log/apache2/dashboard.example.com_access.log combined
ServerSignature On
</VirtualHost>

The only thing I can think of is that I had connected via IP Address, not
FQDN. So I've updated DNS but unfortunately I don't have control over my
employer's resolvers. Thus I have to wait until the cached failure expires
- or bother the team responsible...

Any and all ideas are welcome. I think it's either the DNS issue or
something wrong with Passenger?

Thanks
David
--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/40040503-7f10-438b-9e36-9e0f5cb6d2f8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 20, '15 at 10:40p
activeAug 20, '15 at 10:40p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Kiran Sysadm: 1 post

People

Translate

site design / logo © 2022 Grokbase