FAQ
I recently upgraded my deployment from 2.7 to 3.8.1. I'm using the
apt.puppetlabs.com package for Ubuntu Precise. Since that upgrade,
I've been periodically seeing this error from my agents in the puppet
dashboard.

Failed to apply catalog: no 'environments' in
{:root_environment=>#<Puppet::Node::Environment:0x7f4602a679b8
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name=:"*root*">,
:http_pool=>#<Puppet::Network::HTTP::Pool:0x7f45ff6ab638
@factory=#<Puppet::Network::HTTP::Factory:0x7f45ff6ab4f8>,
@keepalive_timeout=4,
@pool={#<Puppet::Network::HTTP::Site:0x7f45ff5c16a0 @scheme="https",
@port=8140, @host="puppet">=>[#<Puppet::Network::HTTP::Session:0x7f45ffb73300
@expiration_time=Tue Aug 04 08:25:30 -0400 2015,
@connection=#<Net::HTTP puppet:8140 open=true>>]}>,
:current_environment=>#<Puppet::Node::Environment:0x7f45ff5b9d88
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name="production">} at top of [[0, nil, nil], [14,
{:root_environment=>#<Puppet::Node::Environment:0x7f4602a679b8
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name=:"*root*">,
:current_environment=>#<Puppet::Node::Environment:0x7f4602a679b8
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name=:"*root*">}, "root"], [15,
{:root_environment=>#<Puppet::Node::Environment:0x7f4602a679b8
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name=:"*root*">,
:http_pool=>#<Puppet::Network::HTTP::Pool:0x7f45ff6ab638
@factory=#<Puppet::Network::HTTP::Factory:0x7f45ff6ab4f8>,
@keepalive_timeout=4,
@pool={#<Puppet::Network::HTTP::Site:0x7f45ff5c16a0 @scheme="https",
@port=8140, @host="puppet">=>[#<Puppet::Network::HTTP::Session:0x7f45ffb73300
@expiration_time=Tue Aug 04 08:25:30 -0400 2015,
@connection=#<Net::HTTP puppet:8140 open=true>>]}>,
:current_environment=>#<Puppet::Node::Environment:0x7f4602a679b8
@watching=true, @config_version=nil, @manifest=:no_manifest,
@modulepath=[], @name=:"*root*">}, ""]]

I think this messages comes from here:
<https://github.com/puppetlabs/puppet/blob/3.8.1/lib/puppet/context.rb#L54>.

I'm using directory environments (though there's only one environment:
production). My puppetmaster is running on passenger 5.0.14. Here
are the Passenger configuration lines from my apache config:

PassengerHighPerformance on
PassengerMaxPoolSize 12
PassengerPoolIdleTime 1500
PassengerStatThrottleRate 120
PassengerSpawnMethod direct

These are what I think are the relevant lines from puppet.conf:

[master]
environmentpath=$confdir/environments
environment_timeout=unlimited
always_cache_features=true

In attempting to fix the issue, I've cleaned the /var/lib/puppet
directories (except for the ssl subdir) on the agents and the master.

As of now, I've never noticed this error when running puppet agent -t,
only during "natural" runs.

--
George Macon
george.macon@gmail.com

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAJtuvcmMa%3DUQT220%2B0SpZ5KzcP2bj_Boeu2MZkUi8Ur%3DPOqe5w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 4, '15 at 2:48p
activeAug 4, '15 at 2:48p
posts1
users1
websitepuppetlabs.com

1 user in discussion

George Macon: 1 post

People

Translate

site design / logo © 2022 Grokbase