FAQ
Hi Puppet users,

I am testing out the new puppetserver vs the apache/passenger setup for the
master,
problem is that when i created a new environment I am unable to start
puppetserver.

Anything i need to know?

checking the logs the main error i keep on getting is


ERROR [puppet-server] /File[/etc/puppet/modules/production]/ensure change
from absent to directory failed: Could not set 'directory' on ensure:
Permission denied - /etc/puppet/modules/production
2015-07-23 14:26:34,427
ERROR [p.t.internal] shutdown-on-error triggered because of exception!
Thanks! and regards
Gene

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/8e73d2b1-a9ab-4875-8e72-942952d6c534%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

  • Kevin Corcoran at Jul 23, 2015 at 4:51 pm
    Hi Gene,

    That looks like a problem with the permissions on that directory. I'd
    start by making sure that the 'puppet' user has read permissions on
    /etc/puppet/modules/production.

    - Kevin

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAF-bMBfCTPfY5gfan94VtntfHp4-EaNTc-GbEtKeisRLewaCew%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.
  • Gene Fontanilla at Jul 24, 2015 at 7:38 am
    Hi kevin,

    I already tried changing the ownership to puppet:puppet, and even change
    file permission to 777 just to be sure, I still get the same error,
    I also noticed that all puppet files are owned by root upon installation.

    Regards,
    Gene
    On Friday, July 24, 2015 at 12:51:15 AM UTC+8, Kevin Corcoran wrote:

    Hi Gene,

    That looks like a problem with the permissions on that directory. I'd
    start by making sure that the 'puppet' user has read permissions on
    /etc/puppet/modules/production.

    - Kevin
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/27887686-57fc-4f91-8c30-2b1ba736a18c%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 23, '15 at 6:29a
activeJul 24, '15 at 7:38a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Gene Fontanilla: 2 posts Kevin Corcoran: 1 post

People

Translate

site design / logo © 2022 Grokbase