FAQ
Hi all,

updating Puppet from 3.7.5 to 3.8.1 fails on all my Windows Server 2008R2
nodes.

I'm using the following code (puppet.pp):

*package { 'Puppet':*
* ensure => "3.8.1",*
* source =>
"\\\\puppet\\puppetsamba\\puppet_agent\\windows\\puppet-3.8.1.msi",*
* provider => windows,*
* install_options => { 'INSTALLDIR' => 'C:\puppet' }*
* }*

This completes without any problem:

*C:\Scripts>puppet apply puppet.pp*
*Notice: Compiled catalog for server.local.domain in environment production
in 1.33 seconds*
*Notice: /Stage[main]/Main/Package[Puppet]/ensure: ensure changed '3.7.5'
to '3.8.1'*
*Notice: Finished catalog run in 84.66 seconds*

But after the installation I am unable to use Puppet:

*C:\Scripts>puppet agent -t*
*'ruby' is not recognized as an internal or external command, operable
program or batch file.*


Any ideas?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/365a9306-7809-4ab8-9b27-e632c8ae94d8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 17, '15 at 12:59p
activeJul 24, '15 at 2:42p
posts8
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase