Has anyone encountered problem of running Puppet Dashboard on Ruby
Passenger 5? If yes does it really work with that Passenger version?


    I've already setup and configured the necessary files required to run
    Puppet Dashboard via Passenger. Currently, the Apache test page is shown
    instead of the dashboard menu. This will not appear if Puppet-Dashboard is
    run in the lightweight Webrick server.

    While scouring most of the installation samples and the manuals on how
    to install and configure it for Centos 6. I've seen most of them were based
    on Passenger 3 / 4. *I am currently using 5.0.10* as it is used in
    conjunction with Puppet 3.8.1. One thing certain is that RailsAutoDetect is
    deprecated in version 5 and that has been commented out.

    Below my puppet-dashboard.conf file (the load module has been moved to
    another file to avoid double-instantiation)

    On the logs, the first error reported is that the path of
    /usr/share/puppet-dashboard/public/reports/upload is not there, so I've
    created those sub-folders to see if what would be the next error.

    The next error in the log file after that is now shown like: Attempt to
    serve directory: /usr/share/puppet-dashboard/public/reports/upload/

    External node and node terminus option has been commented out as not to
    disrupt normal puppet run-interval activities during office hours.

    PassengerHighPerformance onPassengerMaxPoolSize 6PassengerPoolIdleTime 1500PassengerStatThrottleRate 120
    Listen 3000<VirtualHost *:3000>
       ServerName mi-cloud-mgmt-config-01
       ServerAlias mi-cloud-mgmt-config-01.mimos.local
       RailsBaseURI /
       PassengerAppRoot /usr/share/puppet-dashboard/
       DocumentRoot /usr/share/puppet-dashboard/public/
    # UPDATE THIS TO YOUR FQDN<Directory /usr/share/puppet-dashboard/public/>
        Options None
        Order allow,deny
        allow from all</Directory>
    ErrorLog /var/log/httpd/dashboard_error.logLogLevel debugCustomLog /var/log/httpd/dashboard_access.log combinedServerSignature Off</VirtualHost>

You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/f9c77371-a14d-4137-acb3-3719e18bb708%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
postedJun 15, '15 at 10:21a
activeJun 15, '15 at 10:21a

1 user in discussion

Melvin Mah: 1 post



site design / logo © 2022 Grokbase