FAQ
Hey Everyone,

I am running puppet I'm having an issue when I run the puppet agent on my
node, it errors out on loading this one customer fact.

[root@munin-new puppet]# puppetd -t --noop
info: Retrieving plugin
info: Loading facts in gateway
info: Loading facts in permgen_check
info: Loading facts in ram
info: Loading facts in mysql_version
info: Loading facts in gateway
info: Loading facts in permgen_check
info: Loading facts in ram
info: Loading facts in mysql_version
mysql: unrecognized service
mysql: unrecognized service
mysql: unrecognized service
info: Caching catalog for munin-new.pss.dev
info: Applying configuration version '1393262564'
notice: /Stage[main]/Munin-node/Exec[/usr/bin/munin-cron]/returns: is
notrun, should be 0 (noop)
notice: Finished catalog run in 6.83 seconds

What's odd is that the mysql_version custom fact is called twice. MySQL is
not installed on the box, hence the error. However I can't understand why
it errors out the second time, but not the first. Any suggestions?


This is occuring on a CentOS 5.4 box running Puppet 2.62. Thanks.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/835b020a-2c27-437b-9484-b23c59aa4c36%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Felix Frank at Apr 14, 2014 at 3:57 pm
    Hi,

    for what it's worth, all the custom fact are loaded twice with your
    puppet version. From experience, it's nothing to worry about.

    I'm not entirely certain that the fact code is indeed *run* twice, so
    the late error messages may be quite in order as well.

    HTH,
    Felix
    On 02/24/2014 07:13 PM, Philippe Conway wrote:
    What's odd is that the mysql_version custom fact is called twice. MySQL
    is not installed on the box, hence the error. However I can't understand
    why it errors out the second time, but not the first. Any suggestions?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/534C0563.7020803%40alumni.tu-berlin.de.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 24, '14 at 6:13p
activeApr 14, '14 at 3:57p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Felix Frank: 1 post Philippe Conway: 1 post

People

Translate

site design / logo © 2022 Grokbase