FAQ
I have a strange problem with some of my puppet clients. After a while they
stop reporting in with the master. If i run the puppet agent manually with
command (sudo puppet agent -t) everthings looks fine.

The puppet agent is started at boot by the launch daemon that is described
at puppetlabs.com. I have checked that it's running in the background. So
it seems to me that there is a issue with the puppet schedule. The issue is
not relatet to OS, because i have multiple clients running both 10.8 and
10.9 that's working...

If anyone have any suggestions how to fix this i would be thrilled..

Cheers,
Kristian

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/7fe947e6-7e94-4b01-a159-fdc8a2f3bf54%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Philip Powell at Feb 13, 2014 at 2:09 pm
    I have the same problem.
    Looking at the puppet logs on the affected nodes it looks like the puppet
    agent will occasionally assume "localhost" as its fqdm and then gives up
    when the certs don't match. Maybe it's connected to waking from sleep and
    the puppet agent going off before all relevant networky things have been
    established.
    I too would be majorly chuffed with some kind of fix.

    Phil

    On Wednesday, February 12, 2014 1:24:27 PM UTC+1, Kristian Johannessen
    wrote:
    I have a strange problem with some of my puppet clients. After a while
    they stop reporting in with the master. If i run the puppet agent manually
    with command (sudo puppet agent -t) everthings looks fine.

    The puppet agent is started at boot by the launch daemon that is described
    at puppetlabs.com. I have checked that it's running in the background. So
    it seems to me that there is a issue with the puppet schedule. The issue is
    not relatet to OS, because i have multiple clients running both 10.8 and
    10.9 that's working...

    If anyone have any suggestions how to fix this i would be thrilled..

    Cheers,
    Kristian
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/5db0b07e-01c3-406a-bf1e-e6d57502fa08%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Moses Mendoza at Feb 14, 2014 at 6:36 pm
    Phil, Kristian,

    Would you mind posting a gist (any private info retracted of course)
    of the logs you find this information in?
    On Thu, Feb 13, 2014 at 5:44 AM, Philip Powell wrote:
    I have the same problem.
    Looking at the puppet logs on the affected nodes it looks like the puppet
    agent will occasionally assume "localhost" as its fqdm and then gives up
    when the certs don't match. Maybe it's connected to waking from sleep and
    the puppet agent going off before all relevant networky things have been
    established.
    I too would be majorly chuffed with some kind of fix.

    Phil

    On Wednesday, February 12, 2014 1:24:27 PM UTC+1, Kristian Johannessen
    wrote:
    I have a strange problem with some of my puppet clients. After a while
    they stop reporting in with the master. If i run the puppet agent manually
    with command (sudo puppet agent -t) everthings looks fine.

    The puppet agent is started at boot by the launch daemon that is described
    at puppetlabs.com. I have checked that it's running in the background. So it
    seems to me that there is a issue with the puppet schedule. The issue is not
    relatet to OS, because i have multiple clients running both 10.8 and 10.9
    that's working...

    If anyone have any suggestions how to fix this i would be thrilled..

    Cheers,
    Kristian
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/5db0b07e-01c3-406a-bf1e-e6d57502fa08%40googlegroups.com.

    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Moses Mendoza
    Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco -
    http://bit.ly/pupconf14

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CA%2B421WY62%3DOiqX9JjY6RnByQd%3Dv9Q_AyfJWBQXemTzLmOQDGbw%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Philip Powell at Feb 14, 2014 at 10:57 pm
    Here's one. (When it's in this state I can ssh in and do a sudo puppet
    agent -t and everything's fine again.)

    https://gist.github.com/pkpowell/9011179

    Somewhat surprisingly there was no private info there to redact. Would
    there be more relevant info in the system.log?


    Cheers
    Phil


    On Friday, February 14, 2014 7:36:44 PM UTC+1, Moses Mendoza wrote:

    Phil, Kristian,

    Would you mind posting a gist (any private info retracted of course)
    of the logs you find this information in?
    On Thu, Feb 13, 2014 at 5:44 AM, Philip Powell wrote:
    I have the same problem.
    Looking at the puppet logs on the affected nodes it looks like the puppet
    agent will occasionally assume "localhost" as its fqdm and then gives up
    when the certs don't match. Maybe it's connected to waking from sleep and
    the puppet agent going off before all relevant networky things have been
    established.
    I too would be majorly chuffed with some kind of fix.

    Phil

    On Wednesday, February 12, 2014 1:24:27 PM UTC+1, Kristian Johannessen
    wrote:
    I have a strange problem with some of my puppet clients. After a while
    they stop reporting in with the master. If i run the puppet agent
    manually
    with command (sudo puppet agent -t) everthings looks fine.

    The puppet agent is started at boot by the launch daemon that is
    described
    at puppetlabs.com. I have checked that it's running in the background.
    So it
    seems to me that there is a issue with the puppet schedule. The issue
    is not
    relatet to OS, because i have multiple clients running both 10.8 and
    10.9
    that's working...

    If anyone have any suggestions how to fix this i would be thrilled..

    Cheers,
    Kristian
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/5db0b07e-01c3-406a-bf1e-e6d57502fa08%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Moses Mendoza
    Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco -
    http://bit.ly/pupconf14
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/e8ff3dcb-53d2-48aa-aa3c-0c44c52dad25%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Philip Powell at Mar 3, 2014 at 3:27 pm
    Hey Moses

    I'm still experiencing the same problems with puppet checking in as
    'localhost' after waking form sleep. Any ideas what could be causing this?
    The clients are either running vers. 3.4.2 or 3.4.3.
    Any other troubleshooting suggestions?

    Cheers
    Phil

    On Friday, February 14, 2014 7:36:44 PM UTC+1, Moses Mendoza wrote:

    Phil, Kristian,

    Would you mind posting a gist (any private info retracted of course)
    of the logs you find this information in?
    On Thu, Feb 13, 2014 at 5:44 AM, Philip Powell wrote:
    I have the same problem.
    Looking at the puppet logs on the affected nodes it looks like the puppet
    agent will occasionally assume "localhost" as its fqdm and then gives up
    when the certs don't match. Maybe it's connected to waking from sleep and
    the puppet agent going off before all relevant networky things have been
    established.
    I too would be majorly chuffed with some kind of fix.

    Phil

    On Wednesday, February 12, 2014 1:24:27 PM UTC+1, Kristian Johannessen
    wrote:
    I have a strange problem with some of my puppet clients. After a while
    they stop reporting in with the master. If i run the puppet agent
    manually
    with command (sudo puppet agent -t) everthings looks fine.

    The puppet agent is started at boot by the launch daemon that is
    described
    at puppetlabs.com. I have checked that it's running in the background.
    So it
    seems to me that there is a issue with the puppet schedule. The issue
    is not
    relatet to OS, because i have multiple clients running both 10.8 and
    10.9
    that's working...

    If anyone have any suggestions how to fix this i would be thrilled..

    Cheers,
    Kristian
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/5db0b07e-01c3-406a-bf1e-e6d57502fa08%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Moses Mendoza
    Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco -
    http://bit.ly/pupconf14
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/ec26e1a7-11f8-4120-8057-910957b36122%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Merlin Hartley at Mar 13, 2014 at 2:20 pm
    We had this problem before and the only way we have found to fix it is to
    specify the certname in the each client's puppet.conf
    THe problem then just goes away .

    Hope this helps!

    On Monday, 3 March 2014 15:27:15 UTC, Philip Powell wrote:

    Hey Moses

    I'm still experiencing the same problems with puppet checking in as
    'localhost' after waking form sleep. Any ideas what could be causing this?
    The clients are either running vers. 3.4.2 or 3.4.3.
    Any other troubleshooting suggestions?

    Cheers
    Phil

    On Friday, February 14, 2014 7:36:44 PM UTC+1, Moses Mendoza wrote:

    Phil, Kristian,

    Would you mind posting a gist (any private info retracted of course)
    of the logs you find this information in?

    On Thu, Feb 13, 2014 at 5:44 AM, Philip Powell <pkpo...@gmail.com>
    wrote:
    I have the same problem.
    Looking at the puppet logs on the affected nodes it looks like the puppet
    agent will occasionally assume "localhost" as its fqdm and then gives up
    when the certs don't match. Maybe it's connected to waking from sleep and
    the puppet agent going off before all relevant networky things have been
    established.
    I too would be majorly chuffed with some kind of fix.

    Phil

    On Wednesday, February 12, 2014 1:24:27 PM UTC+1, Kristian Johannessen
    wrote:
    I have a strange problem with some of my puppet clients. After a while
    they stop reporting in with the master. If i run the puppet agent
    manually
    with command (sudo puppet agent -t) everthings looks fine.

    The puppet agent is started at boot by the launch daemon that is
    described
    at puppetlabs.com. I have checked that it's running in the
    background. So it
    seems to me that there is a issue with the puppet schedule. The issue
    is not
    relatet to OS, because i have multiple clients running both 10.8 and
    10.9
    that's working...

    If anyone have any suggestions how to fix this i would be thrilled..

    Cheers,
    Kristian
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/5db0b07e-01c3-406a-bf1e-e6d57502fa08%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Moses Mendoza
    Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco -
    http://bit.ly/pupconf14
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/51a9f826-1e24-4aee-97d6-400f8b82583b%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedFeb 12, '14 at 12:35p
activeMar 13, '14 at 2:20p
posts6
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase