FAQ
Im new to puppet and installed it in my home lab to mess with, when i
installed it i used the hostname rather than FQDN so went back and changed
puppet and reran the certificate tool to regenerate the certificates etc,
the agent works fine now but i am getting an mccollective error i think, is
there anything in the config i need to change for mccollective after
altering the name to the FQDN? My error is below.. Thanks!


root@testnix:~# puppet agent --test

Info: Retrieving plugin

Info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/puppetdb_server_status.rb

Info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/windows.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_version.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/puppet_vardir.rb

Info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/postgres_default_version.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/root_home.rb

Info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/concat_basedir.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/staging_http_get.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/facter_dot_d.rb

Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/custom_auth_conf.rb

Info: Caching catalog for testnix.home.lan

Info: Applying configuration version '1386955608'

Notice:
/Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:

--- /etc/puppetlabs/mcollective/server.cfg 2013-06-07 11:09:23.000000000
-0700

+++ /tmp/puppet-file20131213-2681-oblovd 2013-12-13 09:24:46.579199297 -0800

@@ -1,22 +1,55 @@

-topicprefix = /topic/

+# Centrally managed by Puppet version 3.3.1 (Puppet Enterprise 3.1.0)

+topicprefix = /topic/

  main_collective = mcollective

-collectives = mcollective

-libdir = /opt/puppet/libexec/mcollective/

-logfile = /var/log/pe-mcollective/mcollective.log

-loglevel = info

-daemonize = 1

+collectives = mcollective

+libdir = /opt/puppet/libexec/mcollective/

+logfile = /var/log/pe-mcollective/mcollective.log

+loglevel = info

+daemonize = 1



+identity = testnix.home.lan

  # Plugins

-securityprovider = psk

-plugin.psk = unset

+securityprovider = ssl

+plugin.ssl_server_private =
/etc/puppetlabs/mcollective/ssl/mcollective-private.pem

+plugin.ssl_server_public =
/etc/puppetlabs/mcollective/ssl/mcollective-public.pem

+plugin.ssl_client_cert_dir = /etc/puppetlabs/mcollective/ssl/clients/

+plugin.ssl_serializer = yaml



-connector = stomp

-plugin.stomp.host = localhost

-plugin.stomp.port = 61613

-plugin.stomp.user = mcollective

-plugin.stomp.password = secret

+connector = activemq

+plugin.activemq.pool.size = 1

+plugin.activemq.pool.1.host = puppetmaster.home.lan

+plugin.activemq.pool.1.port = 61613

+plugin.activemq.pool.1.user = mcollective

+plugin.activemq.pool.1.password = ngT4ya8aAEnWHaoEsLQl

+plugin.activemq.pool.1.ssl = true

+plugin.activemq.pool.1.ssl.ca =
/etc/puppetlabs/mcollective/ssl/mcollective-cacert.pem

+plugin.activemq.pool.1.ssl.key =
/etc/puppetlabs/mcollective/ssl/mcollective-private.pem

+plugin.activemq.pool.1.ssl.cert =
/etc/puppetlabs/mcollective/ssl/mcollective-cert.pem



  # Facts

  factsource = yaml

  plugin.yaml = /etc/puppetlabs/mcollective/facts.yaml



+# Puppet Classes

+classesfile = /var/opt/lib/pe-puppet/classes.txt

+

+# Puppet Agent plugin configuration

+plugin.puppet.command = /opt/puppet/bin/puppet agent

+plugin.puppet.config = /etc/puppetlabs/puppet/puppet.conf

+

+plugin.puppet.splay = true

+plugin.puppet.splaylimit = 120

+

+# Periodcally broadcast metdata for registration purposes.

+# This registration plugin will broadcast current Facter fact values.

+registration = Meta

+# registerinterval is intentionally "long" to prevent systems from being
overly

+# chatty on the message bus by default. If you want a higher frequency,
this

+# may be set to 300 (5 minutes)

+registerinterval = 600

+

+# authorization

+rpcauthorization = 1

+rpcauthprovider = action_policy

+plugin.actionpolicy.allow_unconfigured = 1

+direct_addressing = 1


*Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
Connection refused - connect(2)*

*Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
Connection refused - connect(2)*

*Error:
/Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:
change from {md5}a9c7335a83c5ac9f6a19bb195ea0c63e to
{md5}32b98584ef48c0b099f43fd1f70e05fc failed: Could not back up
/etc/puppetlabs/mcollective/server.cfg: Connection refused - connect(2)*

Notice: /Stage[main]/Pe_mcollective::Server/Service[pe-mcollective]:
Dependency File[/etc/puppetlabs/mcollective/server.cfg] has failures: true

*Warning: /Stage[main]/Pe_mcollective::Server/Service[pe-mcollective]:
Skipping because of failed dependencies*

Notice: Finished catalog run in 1.83 seconds

root@testnix:~#

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/0576748e-81f9-4a07-8020-aa156610110c%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Alan Renouf at Dec 16, 2013 at 3:47 am
    It was a VM so i just went back to the OS snapshot and re-installed puppet
    and made sure i used the FQDN, all working fine now.
    On Friday, December 13, 2013 2:05:12 PM UTC-8, Alan Renouf wrote:

    Im new to puppet and installed it in my home lab to mess with, when i
    installed it i used the hostname rather than FQDN so went back and changed
    puppet and reran the certificate tool to regenerate the certificates etc,
    the agent works fine now but i am getting an mccollective error i think, is
    there anything in the config i need to change for mccollective after
    altering the name to the FQDN? My error is below.. Thanks!


    root@testnix:~# puppet agent --test

    Info: Retrieving plugin

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/puppetdb_server_status.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/windows.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/puppet_vardir.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/postgres_default_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/root_home.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/concat_basedir.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/staging_http_get.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/facter_dot_d.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/custom_auth_conf.rb

    Info: Caching catalog for testnix.home.lan

    Info: Applying configuration version '1386955608'

    Notice:
    /Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:

    --- /etc/puppetlabs/mcollective/server.cfg 2013-06-07 11:09:23.000000000
    -0700

    +++ /tmp/puppet-file20131213-2681-oblovd 2013-12-13 09:24:46.579199297
    -0800

    @@ -1,22 +1,55 @@

    -topicprefix = /topic/

    +# Centrally managed by Puppet version 3.3.1 (Puppet Enterprise 3.1.0)

    +topicprefix = /topic/

    main_collective = mcollective

    -collectives = mcollective

    -libdir = /opt/puppet/libexec/mcollective/

    -logfile = /var/log/pe-mcollective/mcollective.log

    -loglevel = info

    -daemonize = 1

    +collectives = mcollective

    +libdir = /opt/puppet/libexec/mcollective/

    +logfile = /var/log/pe-mcollective/mcollective.log

    +loglevel = info

    +daemonize = 1



    +identity = testnix.home.lan

    # Plugins

    -securityprovider = psk

    -plugin.psk = unset

    +securityprovider = ssl

    +plugin.ssl_server_private =
    /etc/puppetlabs/mcollective/ssl/mcollective-private.pem

    +plugin.ssl_server_public =
    /etc/puppetlabs/mcollective/ssl/mcollective-public.pem

    +plugin.ssl_client_cert_dir = /etc/puppetlabs/mcollective/ssl/clients/

    +plugin.ssl_serializer = yaml



    -connector = stomp

    -plugin.stomp.host = localhost

    -plugin.stomp.port = 61613

    -plugin.stomp.user = mcollective

    -plugin.stomp.password = secret

    +connector = activemq

    +plugin.activemq.pool.size = 1

    +plugin.activemq.pool.1.host = puppetmaster.home.lan

    +plugin.activemq.pool.1.port = 61613

    +plugin.activemq.pool.1.user = mcollective

    +plugin.activemq.pool.1.password = ngT4ya8aAEnWHaoEsLQl

    +plugin.activemq.pool.1.ssl = true

    +plugin.activemq.pool.1.ssl.ca =
    /etc/puppetlabs/mcollective/ssl/mcollective-cacert.pem

    +plugin.activemq.pool.1.ssl.key =
    /etc/puppetlabs/mcollective/ssl/mcollective-private.pem

    +plugin.activemq.pool.1.ssl.cert =
    /etc/puppetlabs/mcollective/ssl/mcollective-cert.pem



    # Facts

    factsource = yaml

    plugin.yaml = /etc/puppetlabs/mcollective/facts.yaml



    +# Puppet Classes

    +classesfile = /var/opt/lib/pe-puppet/classes.txt

    +

    +# Puppet Agent plugin configuration

    +plugin.puppet.command = /opt/puppet/bin/puppet agent

    +plugin.puppet.config = /etc/puppetlabs/puppet/puppet.conf

    +

    +plugin.puppet.splay = true

    +plugin.puppet.splaylimit = 120

    +

    +# Periodcally broadcast metdata for registration purposes.

    +# This registration plugin will broadcast current Facter fact values.

    +registration = Meta

    +# registerinterval is intentionally "long" to prevent systems from being
    overly

    +# chatty on the message bus by default. If you want a higher frequency,
    this

    +# may be set to 300 (5 minutes)

    +registerinterval = 600

    +

    +# authorization

    +rpcauthorization = 1

    +rpcauthprovider = action_policy

    +plugin.actionpolicy.allow_unconfigured = 1

    +direct_addressing = 1


    *Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
    Connection refused - connect(2)*

    *Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
    Connection refused - connect(2)*

    *Error:
    /Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:
    change from {md5}a9c7335a83c5ac9f6a19bb195ea0c63e to
    {md5}32b98584ef48c0b099f43fd1f70e05fc failed: Could not back up
    /etc/puppetlabs/mcollective/server.cfg: Connection refused - connect(2)*

    Notice: /Stage[main]/Pe_mcollective::Server/Service[pe-mcollective]:
    Dependency File[/etc/puppetlabs/mcollective/server.cfg] has failures: true

    *Warning: /Stage[main]/Pe_mcollective::Server/Service[pe-mcollective]:
    Skipping because of failed dependencies*

    Notice: Finished catalog run in 1.83 seconds

    root@testnix:~#
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/59055caf-c7ba-4d03-a3f5-a8d266440ce9%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nan Liu at Dec 16, 2013 at 5:59 am

    On Fri, Dec 13, 2013 at 2:05 PM, Alan Renouf wrote:

    Im new to puppet and installed it in my home lab to mess with, when i
    installed it i used the hostname rather than FQDN so went back and changed
    puppet and reran the certificate tool to regenerate the certificates etc,
    the agent works fine now but i am getting an mccollective error i think, is
    there anything in the config i need to change for mccollective after
    altering the name to the FQDN? My error is below.. Thanks!


    root@testnix:~# puppet agent --test

    Info: Retrieving plugin

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/puppetdb_server_status.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/windows.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/pe_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/puppet_vardir.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/postgres_default_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/root_home.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/concat_basedir.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/staging_http_get.rb

    Info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/facter_dot_d.rb

    Info: Loading facts in
    /var/opt/lib/pe-puppet/lib/facter/custom_auth_conf.rb

    Info: Caching catalog for testnix.home.lan

    Info: Applying configuration version '1386955608'

    Notice:
    /Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:

    --- /etc/puppetlabs/mcollective/server.cfg 2013-06-07 11:09:23.000000000
    -0700

    +++ /tmp/puppet-file20131213-2681-oblovd 2013-12-13 09:24:46.579199297
    -0800

    @@ -1,22 +1,55 @@

    -topicprefix = /topic/

    +# Centrally managed by Puppet version 3.3.1 (Puppet Enterprise 3.1.0)

    +topicprefix = /topic/

    main_collective = mcollective

    -collectives = mcollective

    -libdir = /opt/puppet/libexec/mcollective/

    -logfile = /var/log/pe-mcollective/mcollective.log

    -loglevel = info

    -daemonize = 1

    +collectives = mcollective

    +libdir = /opt/puppet/libexec/mcollective/

    +logfile = /var/log/pe-mcollective/mcollective.log

    +loglevel = info

    +daemonize = 1



    +identity = testnix.home.lan

    # Plugins

    -securityprovider = psk

    -plugin.psk = unset

    +securityprovider = ssl

    +plugin.ssl_server_private =
    /etc/puppetlabs/mcollective/ssl/mcollective-private.pem

    +plugin.ssl_server_public =
    /etc/puppetlabs/mcollective/ssl/mcollective-public.pem

    +plugin.ssl_client_cert_dir = /etc/puppetlabs/mcollective/ssl/clients/

    +plugin.ssl_serializer = yaml



    -connector = stomp

    -plugin.stomp.host = localhost

    -plugin.stomp.port = 61613

    -plugin.stomp.user = mcollective

    -plugin.stomp.password = secret

    +connector = activemq

    +plugin.activemq.pool.size = 1

    +plugin.activemq.pool.1.host = puppetmaster.home.lan

    +plugin.activemq.pool.1.port = 61613

    +plugin.activemq.pool.1.user = mcollective

    +plugin.activemq.pool.1.password = ngT4ya8aAEnWHaoEsLQl

    +plugin.activemq.pool.1.ssl = true

    +plugin.activemq.pool.1.ssl.ca =
    /etc/puppetlabs/mcollective/ssl/mcollective-cacert.pem

    +plugin.activemq.pool.1.ssl.key =
    /etc/puppetlabs/mcollective/ssl/mcollective-private.pem

    +plugin.activemq.pool.1.ssl.cert =
    /etc/puppetlabs/mcollective/ssl/mcollective-cert.pem



    # Facts

    factsource = yaml

    plugin.yaml = /etc/puppetlabs/mcollective/facts.yaml



    +# Puppet Classes

    +classesfile = /var/opt/lib/pe-puppet/classes.txt

    +

    +# Puppet Agent plugin configuration

    +plugin.puppet.command = /opt/puppet/bin/puppet agent

    +plugin.puppet.config = /etc/puppetlabs/puppet/puppet.conf

    +

    +plugin.puppet.splay = true

    +plugin.puppet.splaylimit = 120

    +

    +# Periodcally broadcast metdata for registration purposes.

    +# This registration plugin will broadcast current Facter fact values.

    +registration = Meta

    +# registerinterval is intentionally "long" to prevent systems from being
    overly

    +# chatty on the message bus by default. If you want a higher frequency,
    this

    +# may be set to 300 (5 minutes)

    +registerinterval = 600

    +

    +# authorization

    +rpcauthorization = 1

    +rpcauthprovider = action_policy

    +plugin.actionpolicy.allow_unconfigured = 1

    +direct_addressing = 1


    *Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
    Connection refused - connect(2)*

    *Error: Could not back up /etc/puppetlabs/mcollective/server.cfg:
    Connection refused - connect(2)*

    *Error:
    /Stage[main]/Pe_mcollective::Server/File[/etc/puppetlabs/mcollective/server.cfg]/content:
    change from {md5}a9c7335a83c5ac9f6a19bb195ea0c63e to
    {md5}32b98584ef48c0b099f43fd1f70e05fc failed: Could not back up
    /etc/puppetlabs/mcollective/server.cfg: Connection refused - connect(2)*
    In case you run into this again. This appears to be an issue backing up the
    original configuration files to the puppet server. I would check the global
    configuration in the puppet master site.pp. Double check the server
    setting, should look similar to below:

    File { backup => main }

    filebucket { 'main':
       path => false,
       server => 'puppet.example.com',
    }

    HTH,

    Nan

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CACqVBqDTsMa3LQt5crz-vKV_U_MUxe-MGdeVvn3xGa6NZhE%2Bxw%40mail.gmail.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 13, '13 at 11:30p
activeDec 16, '13 at 5:59a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Alan Renouf: 2 posts Nan Liu: 1 post

People

Translate

site design / logo © 2022 Grokbase