FAQ
Hello out there,

I´m trying to add puppetdb (on a separate host,
puppetdb-1.5.2-1.el6.noarch) to my puppet setup (passenger,
puppet-3.1.0-1.el6.noarch).

I´ve used the PL documenation, but I receive the following message after
restarting apache:
2013-12-11T13:28:47.859827+01:00 belbo puppet-master[26103]: Could not
retrieve facts for host.where.ever: Failed to find facts from PuppetDB at
129.128.100.11:8081: 403 "Forbidden"

strange this is that there´s absolutely no network communication on port
8081 from my puppetmaster to my server running puppetdb ???

puppetdb is up and running, the port 8081 is used by the puppetdb java
process:
[root@puppetdb conf.d]# netstat -utlepn |grep 8081
tcp 0 0 129.128.100.11:8081
0.0.0.0:* LISTEN 496 555873012 7864/java

using telnet/nc and tcpdump on my puppetdb shows that there´s no firewall
problem, the hosts are within the same subnet
(and no local iptables is running).

I´m helpless, I´ve checked everything two/three times, but it´s really
frustrating to have no communication at all.

any ideas?

thanks
,
Stefan

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/c45292d8-0027-40d9-b1b1-3d2de5ab6539%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jeff Bachtel at Dec 11, 2013 at 1:46 pm
    What messages are you seeing in /var/log/puppetdb/puppetdb-daemon.log
    and puppetdb.log on 129.128.100.11? Did you previously have puppetdb
    running on your puppet master?

    Because you got the 403, puppetmaster is at least able to connect to and
    receive a response from 129.128.100.11:8081 via HTTPS. That said, if
    you're confident in your tcpdump that no traffic in fact occurred
    between puppetmaster and that IP, then puppetmaster has another idea
    about where that IP is (bound as an alias, for instance, and there's a
    defunct puppetdb still running on the puppetmaster).

    Jeff
    On 12/11/2013 07:50 AM, Stefan Wiederoder wrote:
    Hello out there,

    I´m trying to add puppetdb (on a separate host,
    puppetdb-1.5.2-1.el6.noarch) to my puppet setup (passenger,
    puppet-3.1.0-1.el6.noarch).

    I´ve used the PL documenation, but I receive the following message
    after restarting apache:
    2013-12-11T13:28:47.859827+01:00 belbo puppet-master[26103]: Could not
    retrieve facts for host.where.ever: Failed to find facts from PuppetDB
    at 129.128.100.11:8081: 403 "Forbidden"

    strange this is that there´s absolutely no network communication on
    port 8081 from my puppetmaster to my server running puppetdb ???

    puppetdb is up and running, the port 8081 is used by the puppetdb java
    process:
    [root@puppetdb conf.d]# netstat -utlepn |grep 8081
    tcp 0 0 129.128.100.11:8081 0.0.0.0:*
    LISTEN 496 555873012 7864/java

    using telnet/nc and tcpdump on my puppetdb shows that there´s no
    firewall problem, the hosts are within the same subnet
    (and no local iptables is running).

    I´m helpless, I´ve checked everything two/three times, but it´s really
    frustrating to have no communication at all.

    any ideas?

    thanks
    ,
    Stefan
    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/c45292d8-0027-40d9-b1b1-3d2de5ab6539%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/52A86CA9.9050109%40bericotechnologies.com.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stefan Wiederoder at Dec 11, 2013 at 3:28 pm
    Hi Jeff,

    thanks for your reply.

    you were right, I´ve once had my first puppetdb installation on the same
    host - but all the
    files have been removed and there was no defunct java process running
    anymore.

    but then I found the problem was within my puppet.conf, because I´ve added
    these two variables
         #http_proxy_host = 1.1.1.1
         #http_proxy_port = 3128

    and that was the reason I saw no communication!

    now everythings running fine!

    thanks for you help.

    bye
    ,
    Stefan




    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/73329629-d6ef-4ffa-aaec-c52b319ce5ca%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedDec 11, '13 at 12:50p
activeDec 11, '13 at 3:28p
posts3
users2
websitepuppetlabs.com

2 users in discussion

Stefan Wiederoder: 2 posts Jeff Bachtel: 1 post

People

Translate

site design / logo © 2022 Grokbase