FAQ
Ran into a problem with Facter on a Windows 2008 R2 system running on a
proxmox server.
Facter reports the machine as being physical.
This is due to the WMI query used in the virtual.rb file is being return
"Bochs" as the Manufacturer and Model.

Adding an additional "When" statement to the Ruby file (virtual.rb)
corrected the check coming back as physical.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Rob Reynolds at Oct 9, 2013 at 8:51 pm
    Would you mind filing a pull request on this? If you already have please
    ignore.

    If you don't feel comfortable with that, please file an issue with the code
    you used to fix it and we will take a look at it. Thanks!

    On Tue, Oct 8, 2013 at 3:49 PM, Jason Harmon wrote:

    Ran into a problem with Facter on a Windows 2008 R2 system running on a
    proxmox server.
    Facter reports the machine as being physical.
    This is due to the WMI query used in the virtual.rb file is being return
    "Bochs" as the Manufacturer and Model.

    Adding an additional "When" statement to the Ruby file (virtual.rb)
    corrected the check coming back as physical.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Rob Reynolds
    Developer, Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jason Harmon at Oct 15, 2013 at 3:11 pm
    I created an issue. Never done one before so I may have balls it up a bit.
      I added you as a watcher

    Wasn't sure how to even properly begin with a pull request. I've barely
    used Git so the proper process of pulling and merging is out of my skill
    set right now.

    On Wednesday, October 9, 2013 2:51:09 PM UTC-6, Rob Reynolds wrote:

    Would you mind filing a pull request on this? If you already have please
    ignore.

    If you don't feel comfortable with that, please file an issue with the
    code you used to fix it and we will take a look at it. Thanks!


    On Tue, Oct 8, 2013 at 3:49 PM, Jason Harmon <jharmo...@gmail.com<javascript:>
    wrote:
    Ran into a problem with Facter on a Windows 2008 R2 system running on a
    proxmox server.
    Facter reports the machine as being physical.
    This is due to the WMI query used in the virtual.rb file is being return
    "Bochs" as the Manufacturer and Model.

    Adding an additional "When" statement to the Ruby file (virtual.rb)
    corrected the check coming back as physical.

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>
    .
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Rob Reynolds
    Developer, Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jason Harmon at Oct 15, 2013 at 3:30 pm
    Noticed that a matching issue was opened a few days ago, so I marked the
    one I opened as duplicate and just added a comment on the open issue
    instead.
    On Tuesday, October 15, 2013 9:11:42 AM UTC-6, Jason Harmon wrote:

    I created an issue. Never done one before so I may have balls it up a
    bit. I added you as a watcher

    Wasn't sure how to even properly begin with a pull request. I've barely
    used Git so the proper process of pulling and merging is out of my skill
    set right now.

    On Wednesday, October 9, 2013 2:51:09 PM UTC-6, Rob Reynolds wrote:

    Would you mind filing a pull request on this? If you already have please
    ignore.

    If you don't feel comfortable with that, please file an issue with the
    code you used to fix it and we will take a look at it. Thanks!

    On Tue, Oct 8, 2013 at 3:49 PM, Jason Harmon wrote:

    Ran into a problem with Facter on a Windows 2008 R2 system running on a
    proxmox server.
    Facter reports the machine as being physical.
    This is due to the WMI query used in the virtual.rb file is being return
    "Bochs" as the Manufacturer and Model.

    Adding an additional "When" statement to the Ruby file (virtual.rb)
    corrected the check coming back as physical.

    --
    You received this message because you are subscribed to the Google
    Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send
    an email to puppet-users...@googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.


    --
    Rob Reynolds
    Developer, Puppet Labs

    Join us at PuppetConf 2014, September 23-24 in San Francisco
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 8, '13 at 10:49p
activeOct 15, '13 at 3:30p
posts4
users2
websitepuppetlabs.com

2 users in discussion

Jason Harmon: 3 posts Rob Reynolds: 1 post

People

Translate

site design / logo © 2022 Grokbase