FAQ
Greetings,

I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

I am seeing many \n strings all over the place when looking at
reports. Specifically the \n's are in the Metrics, Log, Events links.

My nodes are showing up okay, and it seems just to be a problem with
the reports. For instance, a Metrics page starts with:

\n
\n
Metrics
\n
\n
Events

\n\n\n\n\n\n\n\n\n

Any advice on where to dig? /usr/share/puppet-dashboard/log/* does not
yield any hints.

Thanks!

-mz

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Juan Sierra Pons at Oct 3, 2013 at 10:45 pm
    El 03/10/2013 14:00, "Matt Zagrabelny" <mzagrabe@d.umn.edu> escribió:
    Greetings,

    I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

    I am seeing many \n strings all over the place when looking at
    reports. Specifically the \n's are in the Metrics, Log, Events links.

    My nodes are showing up okay, and it seems just to be a problem with
    the reports. For instance, a Metrics page starts with:

    \n
    \n
    Metrics
    \n
    \n
    Events

    \n\n\n\n\n\n\n\n\n

    Any advice on where to dig? /usr/share/puppet-dashboard/log/* does not
    yield any hints.

    Thanks!

    -mz

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    Hi

    I had the same problem and the problem was in the ruby version

    Which one are you using?

    Check the dashboard webpage to find out wich one is the right one.

    Regards

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Matt Zagrabelny at Oct 3, 2013 at 11:04 pm

    On Thu, Oct 3, 2013 at 5:45 PM, Juan Sierra Pons wrote:
    El 03/10/2013 14:00, "Matt Zagrabelny" <mzagrabe@d.umn.edu> escribió:

    Greetings,

    I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

    I am seeing many \n strings all over the place when looking at
    reports. Specifically the \n's are in the Metrics, Log, Events links.

    My nodes are showing up okay, and it seems just to be a problem with
    the reports. For instance, a Metrics page starts with:

    \n
    \n
    Metrics
    \n
    \n
    Events

    \n\n\n\n\n\n\n\n\n

    Any advice on where to dig? /usr/share/puppet-dashboard/log/* does not
    yield any hints.

    Thanks!

    -mz

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    Hi

    I had the same problem and the problem was in the ruby version

    Which one are you using?
    realpath =ruby
    /usr/bin/ruby1.9.1

    Check the dashboard webpage to find out wich one is the right one.
    Looks like 1.8 is what is needed.

    Looks like that worked!

    Thanks!

    -mz

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Nick Triantafillou at Aug 24, 2014 at 8:45 pm
    Thanks for this solution Ximena, Debian 7.6 had the same issue. Swapping
    from Ruby 1.9.1 to 1.8.7 also fixed my dashboard.
    On Tuesday, 24 June 2014 00:43:53 UTC+10, Ximena Cardinali wrote:

    Me again, I've changed the link of /etc/alternatives/ruby (Debian) to
    point to ruby1.8 and everything looks good now on the Dashboard!

    Thanks! :)
    On Monday, 23 June 2014 15:37:59 UTC+2, Ximena Cardinali wrote:

    Hello, sorry to bring this back.

    I just have a question, did you just changed the path of /usr/bin/ruby or
    did you did something else to make it work?

    Thanks in advance,
    X.
    On Friday, 4 October 2013 01:04:22 UTC+2, Matt Zagrabelny wrote:

    On Thu, Oct 3, 2013 at 5:45 PM, Juan Sierra Pons <ju...@elsotanillo.net>
    wrote:
    El 03/10/2013 14:00, "Matt Zagrabelny" <mzag...@d.umn.edu> escribió:

    Greetings,

    I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

    I am seeing many \n strings all over the place when looking at
    reports. Specifically the \n's are in the Metrics, Log, Events links.

    My nodes are showing up okay, and it seems just to be a problem with
    the reports. For instance, a Metrics page starts with:

    \n
    \n
    Metrics
    \n
    \n
    Events

    \n\n\n\n\n\n\n\n\n

    Any advice on where to dig? /usr/share/puppet-dashboard/log/* does
    not
    yield any hints.

    Thanks!

    -mz

    --
    You received this message because you are subscribed to the Google
    Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it,
    send an
    email to puppet-users...@googlegroups.com.
    To post to this group, send email to puppet...@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    Hi

    I had the same problem and the problem was in the ruby version

    Which one are you using?
    realpath =ruby
    /usr/bin/ruby1.9.1

    Check the dashboard webpage to find out wich one is the right one.
    Looks like 1.8 is what is needed.

    Looks like that worked!

    Thanks!

    -mz
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/80328550-e882-4457-ac76-2d21ff744b9b%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Anton Markelov at Feb 16, 2015 at 1:09 am
    Sorry for necroposting. If you use mod_passenger, just change PassengerRuby
    parameter from '/usr/bin/ruby' to '/usr/bin/ruby1.8'.

    пятница, 4 октября 2013 г., 6:00:26 UTC+10 пользователь Matt Zagrabelny
    написал:
    Greetings,

    I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

    I am seeing many \n strings all over the place when looking at
    reports. Specifically the \n's are in the Metrics, Log, Events links.

    My nodes are showing up okay, and it seems just to be a problem with
    the reports. For instance, a Metrics page starts with:

    \n
    \n
    Metrics
    \n
    \n
    Events

    \n\n\n\n\n\n\n\n\n

    Any advice on where to dig? /usr/share/puppet-dashboard/log/* does not
    yield any hints.

    Thanks!

    -mz
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/c61c5608-8342-4c67-9368-3bc86aac15ac%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.
  • Alex Elman at Feb 16, 2015 at 6:55 pm
    More to Anton's point community Puppet Dashboard has not been developed or
    tested on anything newer than Ruby 1.8.7. In order for the Dashboard to
    work as intended you'll need to run it on the recommended version of 1.8.7.
    If you must use a newer Ruby version then consider Puppet Enterprise since
    it has all of the functionality of the dashboard baked in.
    On Sun, Feb 15, 2015 at 7:09 PM, Anton Markelov wrote:

    Sorry for necroposting. If you use mod_passenger, just
    change PassengerRuby parameter from '/usr/bin/ruby' to '/usr/bin/ruby1.8'.

    пятница, 4 октября 2013 г., 6:00:26 UTC+10 пользователь Matt Zagrabelny
    написал:
    Greetings,

    I've setup puppet dashboard 1.2.23 along with puppetmaster 2.7.18.

    I am seeing many \n strings all over the place when looking at
    reports. Specifically the \n's are in the Metrics, Log, Events links.

    My nodes are showing up okay, and it seems just to be a problem with
    the reports. For instance, a Metrics page starts with:

    \n
    \n
    Metrics
    \n
    \n
    Events

    \n\n\n\n\n\n\n\n\n

    Any advice on where to dig? /usr/share/puppet-dashboard/log/* does not
    yield any hints.

    Thanks!

    -mz
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit
    https://groups.google.com/d/msgid/puppet-users/c61c5608-8342-4c67-9368-3bc86aac15ac%40googlegroups.com
    <https://groups.google.com/d/msgid/puppet-users/c61c5608-8342-4c67-9368-3bc86aac15ac%40googlegroups.com?utm_medium=email&utm_source=footer>
    .
    For more options, visit https://groups.google.com/d/optout.


    --
    Alex Elman

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/CAD-8G_qCL_FgSoC3rOJXh-F5CXv25bGb3%2BsUxf5-_1t2z%3Devgg%40mail.gmail.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedOct 3, '13 at 8:00p
activeFeb 16, '15 at 6:55p
posts6
users5
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase