FAQ
Good evening, folks.

Using the module's puppet forge to create a database I get an error below.

Could you help me?

*puppetlabs-mysql (v1.0.0) *

*class mysql_default {*
*
*
* mysql::db { 'mydb':*
* user => 'root',*
* password => '123456',*
* host => 'localhost',*
* grant => ['SELECT', 'UPDATE'],*
* }*
* *
* *
*}*


Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
Invalid parameter provider at
/etc/puppet/environments/development/modules/mysql/manifests/db.pp:60 on
node stfbsbpentaho02.dmz
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run




--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Chris McDermott at Sep 25, 2013 at 4:48 am
    Make sure you have set "pluginsync = true" in your puppet.conf.

    On Mon, Sep 23, 2013 at 6:59 PM, Eduardo Terzella wrote:


    Good evening, folks.

    Using the module's puppet forge to create a database I get an error below.

    Could you help me?

    *puppetlabs-mysql (v1.0.0) *

    *class mysql_default {*
    *
    *
    * mysql::db { 'mydb':*
    * user => 'root',*
    * password => '123456',*
    * host => 'localhost',*
    * grant => ['SELECT', 'UPDATE'],*
    * }*
    * *
    * *
    *}*


    Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
    Invalid parameter provider at
    /etc/puppet/environments/development/modules/mysql/manifests/db.pp:60 on
    node stfbsbpentaho02.dmz
    Warning: Not using cache on failed catalog
    Error: Could not retrieve catalog; skipping run




    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 24, '13 at 12:59a
activeSep 25, '13 at 4:48a
posts2
users2
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase