FAQ
My install was working for a couple of months until I rebooted my puppet
server. The clients do not report an error when I run puppet agent -t.
I've attempted to remove certificates and renew. The clients get new
certificates, but the console still does not update. Even the puppet
server itself is not updating as a client. After reboot the only thing I
have noticed that changed was selinux got re-enabled. I set it back to
disabled and rebooted, but no change. The iptables service is stopped.
  I've scanned all the pe- logs, but I don't see anything that stands out.

Any help would be appreciated.

[root@Puppet ~]# getenforce
Disabled
[root@Puppet ~]# puppet agent -t
info: Retrieving plugin
info: Loading facts in
/etc/puppetlabs/puppet/modules/firewall/lib/facter/iptables_persistent_version.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/firewall/lib/facter/iptables_version.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/firewall/lib/facter/ip6tables_version.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/operatingsystemversion.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_systemtype.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_productkey.rb
info: Loading facts in
/etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_sid.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/stdlib/lib/facter/pe_version.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/stdlib/lib/facter/root_home.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/concat/lib/facter/concat_basedir.rb
info: Loading facts in
/opt/puppet/share/puppet/modules/auth_conf/lib/facter/custom_auth_conf.rb
info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb
info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb
info: Loading facts in
/var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb
info: Caching catalog for puppet
info: Applying configuration version '1379543327'
notice: Finished catalog run in 0.07 seconds
[root@Puppet ~]# service iptables status
iptables: Firewall is not running.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Peter Bukowinski at Sep 19, 2013 at 1:24 pm

    On Sep 18, 2013, at 6:55 PM, getSurreal wrote:

    My install was working for a couple of months until I rebooted my puppet server. The clients do not report an error when I run puppet agent -t. I've attempted to remove certificates and renew. The clients get new certificates, but the console still does not update. Even the puppet server itself is not updating as a client. After reboot the only thing I have noticed that changed was selinux got re-enabled. I set it back to disabled and rebooted, but no change. The iptables service is stopped. I've scanned all the pe- logs, but I don't see anything that stands out.

    Any help would be appreciated.

    [root@Puppet ~]# getenforce
    Disabled
    [root@Puppet ~]# puppet agent -t
    info: Retrieving plugin
    info: Loading facts in /etc/puppetlabs/puppet/modules/firewall/lib/facter/iptables_persistent_version.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/firewall/lib/facter/iptables_version.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/firewall/lib/facter/ip6tables_version.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/operatingsystemversion.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_systemtype.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_productkey.rb
    info: Loading facts in /etc/puppetlabs/puppet/modules/win_facts.old/lib/facter/windows_sid.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/puppet_vardir.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/pe_version.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/facter_dot_d.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/stdlib/lib/facter/root_home.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/concat/lib/facter/concat_basedir.rb
    info: Loading facts in /opt/puppet/share/puppet/modules/auth_conf/lib/facter/custom_auth_conf.rb
    info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_persistent_version.rb
    info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/iptables_version.rb
    info: Loading facts in /var/opt/lib/pe-puppet/lib/facter/ip6tables_version.rb
    info: Caching catalog for puppet
    info: Applying configuration version '1379543327'
    notice: Finished catalog run in 0.07 seconds
    [root@Puppet ~]# service iptables status
    iptables: Firewall is not running.

    Do you get similar output when you do a puppet run on other nodes? I don't see any errors, so from a node perspective it appears that the puppet server is still doing its job. The console is an entirely separate animal that relies on a separate service called 'pe-puppet-dashboard-workers' to process the incoming reports into its database.

    Do you see a large number of pending jobs in the Background Tasks section in the upper-left corner of the console? If so, start or restart the 'pe-puppet-dashboard-workers' service (and make sure it's set to run at boot time) and you'll see the number of pending tasks decrease and run node statuses start to update in the console.

    --
    Peter Bukowinski

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 19, '13 at 8:26a
activeSep 19, '13 at 1:24p
posts2
users2
websitepuppetlabs.com

2 users in discussion

getSurreal: 1 post Peter Bukowinski: 1 post

People

Translate

site design / logo © 2022 Grokbase