FAQ
As of upgrading master and clients to 3.3.0, some of my servers are
saying:

Error: Could not prefetch package provider 'yum': invalid byte sequence in UTF-8
Error: Could not prefetch package provider 'rpm': invalid byte sequence in UTF-8

I can't tell whether this actually stops them from *doing* anything
or not, but I don't think so.

I have tried various things with LANG and LC_ALL to no effect.

Ideas?

-Robin

--
http://intelligence.org/ : Our last, best hope for a fantastic future.
.i ko na cpedu lo nu stidi vau loi jbopre .i danfu lu na go'i li'u .e
lu go'i li'u .i ji'a go'i lu na'e go'i li'u .e lu go'i na'i li'u .e
lu no'e go'i li'u .e lu to'e go'i li'u .e lu lo mamta be do cu sofybakni li'u

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Wolf Noble at Sep 17, 2013 at 8:53 pm
    When I ran into this, what bit me was funky characters hiding in comments
    in the manifests.

    On Tue, Sep 17, 2013 at 3:42 PM, Robin Lee Powell wrote:


    As of upgrading master and clients to 3.3.0, some of my servers are
    saying:

    Error: Could not prefetch package provider 'yum': invalid byte sequence in
    UTF-8
    Error: Could not prefetch package provider 'rpm': invalid byte sequence in
    UTF-8

    I can't tell whether this actually stops them from *doing* anything
    or not, but I don't think so.

    I have tried various things with LANG and LC_ALL to no effect.

    Ideas?

    -Robin

    --
    http://intelligence.org/ : Our last, best hope for a fantastic future.
    .i ko na cpedu lo nu stidi vau loi jbopre .i danfu lu na go'i li'u .e
    lu go'i li'u .i ji'a go'i lu na'e go'i li'u .e lu go'i na'i li'u .e
    lu no'e go'i li'u .e lu to'e go'i li'u .e lu lo mamta be do cu sofybakni
    li'u

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Robin Lee Powell at Sep 21, 2013 at 9:30 am
    No, although I appreciate the attempt!

    [rlpowell@shell01 puppet3]$ find . -type f -name '*.pp' | xargs grep -P '[^\s\t!-~]'
    [rlpowell@shell01 puppet3]$

    (that range covers all of visible ASCII, plus space and tab)

    In fact, the only file that matches that that isn't obviously binary
    is ./modules/stdlib/lib/puppet/parser/functions/shuffle.rb

    Fixing that file does not fix the problem.

    Any further ideas, anybody?

    -Robin
    On Tue, Sep 17, 2013 at 03:53:27PM -0500, Wolf Noble wrote:
    When I ran into this, what bit me was funky characters hiding in comments
    in the manifests.


    On Tue, Sep 17, 2013 at 3:42 PM, Robin Lee Powell <
    rlpowell@digitalkingdom.org> wrote:
    As of upgrading master and clients to 3.3.0, some of my servers are
    saying:

    Error: Could not prefetch package provider 'yum': invalid byte sequence in
    UTF-8
    Error: Could not prefetch package provider 'rpm': invalid byte sequence in
    UTF-8

    I can't tell whether this actually stops them from *doing* anything
    or not, but I don't think so.

    I have tried various things with LANG and LC_ALL to no effect.

    Ideas?

    -Robin

    --
    http://intelligence.org/ : Our last, best hope for a fantastic future.
    .i ko na cpedu lo nu stidi vau loi jbopre .i danfu lu na go'i li'u .e
    lu go'i li'u .i ji'a go'i lu na'e go'i li'u .e lu go'i na'i li'u .e
    lu no'e go'i li'u .e lu to'e go'i li'u .e lu lo mamta be do cu sofybakni
    li'u

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    http://intelligence.org/ : Our last, best hope for a fantastic future.
    .i ko na cpedu lo nu stidi vau loi jbopre .i danfu lu na go'i li'u .e
    lu go'i li'u .i ji'a go'i lu na'e go'i li'u .e lu go'i na'i li'u .e
    lu no'e go'i li'u .e lu to'e go'i li'u .e lu lo mamta be do cu sofybakni li'u

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at Sep 23, 2013 at 4:00 pm

    On Saturday, September 21, 2013 4:30:53 AM UTC-5, Robin Powell wrote:

    No, although I appreciate the attempt!

    [rlpowell@shell01 puppet3]$ find . -type f -name '*.pp' | xargs grep -P
    '[^\s\t!-~]'
    [rlpowell@shell01 puppet3]$

    (that range covers all of visible ASCII, plus space and tab)

    In fact, the only file that matches that that isn't obviously binary
    is ./modules/stdlib/lib/puppet/parser/functions/shuffle.rb

    Fixing that file does not fix the problem.

    Any further ideas, anybody?
    Perhaps you have an installed package with a non-ASCII character in its
    name, version code, or release code.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedSep 17, '13 at 8:42p
activeSep 23, '13 at 4:00p
posts4
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase