FAQ
Hi,

Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

I was told by someone at Puppet Labs that it existed in some fashion...

--Stuart
RHCE/RHCSA/Oracle DBA/Sun/Mensa

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Steven Nemetz at Aug 28, 2013 at 6:30 pm
    Just use the RedHat packages
    We use the same packages for RedHat, CentOS, and Oracle EL

    Some modules need to get slightly modified to recognize Oracle EL

    Steven
    Subject: [Puppet Users] puppet client
    From: smcracraft@me.com
    Date: Wed, 28 Aug 2013 10:02:48 -0700
    To: puppet-users@googlegroups.com

    Hi,

    Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

    Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

    We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

    I was told by someone at Puppet Labs that it existed in some fashion...

    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stuart Cracraft at Aug 29, 2013 at 4:17 pm
    Good morning!

    What are the relevant client rpms and
    URL for puppet client install to Oracle UEK Linux?

    I'm sitting at, in a browser:
      http://yum.puppetlabs.com/el/5Client/products/x86_64

    Also, can you speak more to:
    Some modules need to get slightly modified to recognize Oracle EL


    Thankyou.

    On Aug 28, 2013, at 11:29 AM, Steven Nemetz wrote:

    Just use the RedHat packages
    We use the same packages for RedHat, CentOS, and Oracle EL

    Some modules need to get slightly modified to recognize Oracle EL

    Steven

    Subject: [Puppet Users] puppet client
    From: smcracraft@me.com
    Date: Wed, 28 Aug 2013 10:02:48 -0700
    To: puppet-users@googlegroups.com

    Hi,

    Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

    Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

    We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

    I was told by someone at Puppet Labs that it existed in some fashion...

    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stuart Cracraft at Aug 29, 2013 at 4:28 pm
    I assume it is just the version of puppet client which matches the master's
    own client and server which is 3.2.1.

    I.e.

         puppet-3.2.1-1.el5.noarch.rpm

    facter as well

    Any others for an Oracle UEK client?


    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    On Aug 29, 2013, at 9:17 AM, Stuart Cracraft wrote:


    Good morning!

    What are the relevant client rpms and
    URL for puppet client install to Oracle UEK Linux?

    I'm sitting at, in a browser:
    http://yum.puppetlabs.com/el/5Client/products/x86_64

    Also, can you speak more to:
    Some modules need to get slightly modified to recognize Oracle EL


    Thankyou.

    On Aug 28, 2013, at 11:29 AM, Steven Nemetz wrote:

    Just use the RedHat packages
    We use the same packages for RedHat, CentOS, and Oracle EL

    Some modules need to get slightly modified to recognize Oracle EL

    Steven

    Subject: [Puppet Users] puppet client
    From: smcracraft@me.com
    Date: Wed, 28 Aug 2013 10:02:48 -0700
    To: puppet-users@googlegroups.com

    Hi,

    Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

    Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

    We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

    I was told by someone at Puppet Labs that it existed in some fashion...

    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Steven Nemetz at Aug 29, 2013 at 5:57 pm
    Follow the instructions for RedHat. It is the same. Just match el5 or el6
    If you do it via yum, I think it will auto install all the dependencies.
    puppet, facter, augeas, hiera, ruby-shadow
    Been using enterprise so not sure if there is anything else for community version or 3.x. Still on 2.7

    As far as the module modifications:
    Some modules have conditions to do different things depending on what OS (dir paths, file names, etc.). Many times Oracle EL is not in the condition set. Usually just needs to be added to the same condition that handle RedHat. Be aware the Oracle EL reports itself with different names depending on what version you are running.

    Steven

    From: smcracraft@me.com
    Subject: Re: [Puppet Users] puppet client
    Date: Thu, 29 Aug 2013 09:27:52 -0700
    To: puppet-users@googlegroups.com

    I assume it is just the version of puppet client which matches the master'sown client and server which is 3.2.1.
    I.e.
         puppet-3.2.1-1.el5.noarch.rpm
    facter as well
    Any others for an Oracle UEK client?

    --StuartRHCE/RHCSA/Oracle DBA/Sun/Mensa

    On Aug 29, 2013, at 9:17 AM, Stuart Cracraft wrote:


    Good morning!
    What are the relevant client rpms andURL for puppet client install to Oracle UEK Linux?
    I'm sitting at, in a browser: http://yum.puppetlabs.com/el/5Client/products/x86_64
    Also, can you speak more to:
    Some modules need to get slightly modified to recognize Oracle EL

    Thankyou.

    On Aug 28, 2013, at 11:29 AM, Steven Nemetz wrote:




    Just use the RedHat packages
    We use the same packages for RedHat, CentOS, and Oracle EL

    Some modules need to get slightly modified to recognize Oracle EL

    Steven
    Subject: [Puppet Users] puppet client
    From: smcracraft@me.com
    Date: Wed, 28 Aug 2013 10:02:48 -0700
    To: puppet-users@googlegroups.com

    Hi,

    Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

    Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

    We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

    I was told by someone at Puppet Labs that it existed in some fashion...

    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.





    --

    You received this message because you are subscribed to the Google Groups "Puppet Users" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.

    To post to this group, send email to puppet-users@googlegroups.com.

    Visit this group at http://groups.google.com/group/puppet-users.

    For more options, visit https://groups.google.com/groups/opt_out.






    --

    You received this message because you are subscribed to the Google Groups "Puppet Users" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.

    To post to this group, send email to puppet-users@googlegroups.com.

    Visit this group at http://groups.google.com/group/puppet-users.

    For more options, visit https://groups.google.com/groups/opt_out.






    --

    You received this message because you are subscribed to the Google Groups "Puppet Users" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.

    To post to this group, send email to puppet-users@googlegroups.com.

    Visit this group at http://groups.google.com/group/puppet-users.

    For more options, visit https://groups.google.com/groups/opt_out.


    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Stuart Cracraft at Aug 30, 2013 at 2:23 am
    I'm just placing all the rpm's at the el5 and el6 directories at puppetlabs locally,
    doing a createrepo for each and then using those as the local yum sources.

    For one-offs that require twiddling/tweaking, I'll deal with them as they come up
    post-deployment or in-production already.

    Can't save everything.
    On Aug 29, 2013, at 9:17 AM, Stuart Cracraft wrote:


    Good morning!

    What are the relevant client rpms and
    URL for puppet client install to Oracle UEK Linux?

    I'm sitting at, in a browser:
    http://yum.puppetlabs.com/el/5Client/products/x86_64

    Also, can you speak more to:
    Some modules need to get slightly modified to recognize Oracle EL


    Thankyou.

    On Aug 28, 2013, at 11:29 AM, Steven Nemetz wrote:

    Just use the RedHat packages
    We use the same packages for RedHat, CentOS, and Oracle EL

    Some modules need to get slightly modified to recognize Oracle EL

    Steven

    Subject: [Puppet Users] puppet client
    From: smcracraft@me.com
    Date: Wed, 28 Aug 2013 10:02:48 -0700
    To: puppet-users@googlegroups.com

    Hi,

    Looked but couldn't find information on Puppet client for Oracle Unbreakable Enterprise Kernel Linux.

    Could you point me to the methodology for the above on Open Source Puppet which we have running (well) on and for regular Red Hat Linux which we used Puppet Labs Yum repositories to install server and client effortlessly.

    We use Oracle Unbreakable Enterprise Kernel on our vms which we want all controlled by Puppet.

    I was told by someone at Puppet Labs that it existed in some fashion...

    --Stuart
    RHCE/RHCSA/Oracle DBA/Sun/Mensa

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 28, '13 at 5:03p
activeAug 30, '13 at 2:23a
posts6
users2
websitepuppetlabs.com

2 users in discussion

Stuart Cracraft: 4 posts Steven Nemetz: 2 posts

People

Translate

site design / logo © 2022 Grokbase