FAQ
Hello everyone.

I'm trying to install Puppet Enterprise for test purposes before my company
make a purchase of Puppet Enterprise.

There is a problem with installation (good start i guess :) ).
After Q&A from installator and packages installation I'm getting this
output:
## Setting up puppet master...
## Checking the agent certificate name detection...
## Setting up puppet agent...
## Setting up the database...
Configuring postgresql server...
PostgreSQL server configured.
!! ERROR: The PostgreSQL server failed to start; unable to proceed

My conclusion after browsing install_log:
If you guys could be so nice and put info about remounting /var with exec
that would be nice. :)

Best regards.

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Rahul Khengare at Aug 21, 2013 at 12:54 pm
    Hi Jan,
         This is the problem of postgresql database server. Check postgreSQL
    server on your machine working or not.
    First start the postgresql server and then try to run puppet enterprise
    installation.

    Thanks and Regards,
    Rahul Khengare

    NTT DATA OSS Center Pune, India.**
    On Tuesday, August 20, 2013 6:42:30 PM UTC+5:30, Jan Walczuk wrote:

    Hello everyone.

    I'm trying to install Puppet Enterprise for test purposes before my
    company make a purchase of Puppet Enterprise.

    There is a problem with installation (good start i guess :) ).
    After Q&A from installator and packages installation I'm getting this
    output:
    ## Setting up puppet master...
    ## Checking the agent certificate name detection...
    ## Setting up puppet agent...
    ## Setting up the database...
    Configuring postgresql server...
    PostgreSQL server configured.
    !! ERROR: The PostgreSQL server failed to start; unable to proceed

    My conclusion after browsing install_log:
    If you guys could be so nice and put info about remounting /var with exec
    that would be nice. :)

    Best regards.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Pclonan at Jan 8, 2014 at 4:47 am
    Hello,

    I had the exact same issue. The problem was Postgres, its need to be able
    to resolve localhost.

    Added "127.0.0.1 localhost.localdomain localhost" to /etc/hosts - problem
    fixed.

    Once Puppet was installed, I removed the above entry - and pe-postgresql
    wouldn't start. Added localhost back in - and pe-postgresql starts...

    Cheers,
    Paul.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/fde0dd83-9210-447d-ad11-45607111aa7a%40googlegroups.com.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 20, '13 at 5:06p
activeJan 8, '14 at 4:47a
posts3
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase