FAQ
Hi,

I've setup a new puppet 3.2.2 server - next to my current 2.7.22 server.

When I connect with a client against it (changed puppet.conf to use the new
server), then it removes facts and all (and runs no rules) - but it doesn't
complain anywhere - not on the new puppetmaster either :(

I'm hoping you can give me some ideas, as how to debug this further.

I'm running Passenger btw (on both servers).

Output from client run is this:
# puppet agent -t
Info: Retrieving plugin
Notice: /File[/var/lib/puppet/lib/puppet]/ensure: removed
Notice: /File[/var/lib/puppet/lib/provider]/ensure: removed
Notice: /File[/var/lib/puppet/lib/facter]/ensure: removed
Notice: /File[/var/lib/puppet/lib/type]/ensure: removed
Info: Caching catalog for login01.example.dk
Info: Applying configuration version '1375874403'

Puppet.conf is copied from my existing master:
[main]
     # The Puppet log directory.
     # The default value is '$vardir/log'.
     logdir = /var/log/puppet

     # Where Puppet PID files are kept.
     # The default value is '$vardir/run'.
     rundir = /var/run/puppet

     # Where SSL certificates are kept.
     # The default value is '$confdir/ssl'.
     ssldir = $vardir/ssl
         modulepath = /etc/puppet/modules
         pluginsync = true
         dns_alt_names = puppet,puppet.example.dk,puppetmaster.example.dk

[user]
     # These are needed when the puppetmaster is run by passenger
     # and can safely be removed if webrick is used.
     ssl_client_header = SSL_CLIENT_S_DN
     ssl_client_verify_header = SSL_CLIENT_VERIFY

[agent]
     # The file in which puppetd stores a list of the classes
     # associated with the retrieved configuratiion. Can be loaded in
     # the separate ``puppet`` executable using the ``--loadclasses``
     # option.
     # The default value is '$confdir/classes.txt'.
     classfile = $vardir/classes.txt

     # Where puppetd caches the local configuration. An
     # extension indicating the cache format is added automatically.
     # The default value is '$confdir/localconfig'.
     localconfig = $vardir/localconfig
         server = puppetmaster.example.dk
         ca = false
         ca_server = puppetmaster-01.example.dk
     report = true
         runinterval = 1800
[master]
         certname=puppetmaster.example.dk
         ca_server=puppetmaster-01.example.dk
         templatedir=/var/lib/puppet/templates
         reports = store, http
         #reports = http
          reporturl = http://localhost:3000/reports/upload
         storeconfigs = true
         storeconfigs_backend = puppetdb
         facts_terminus = rest
         inventory_server = localhost
         inventory_port = 8081
         #ENC
         node_terminus = exec
         external_nodes = /usr/local/bin/puppet_node_classifier_enc.sh
         modulepath = /home/$environment/puppet/modules/
         manifest = /home/$environment/puppet/manifests/site.pp

[production]
         modulepath = /etc/puppet/modules
         manifest = /etc/puppet/manifests/site.pp

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedAug 7, '13 at 1:33p
activeAug 7, '13 at 1:33p
posts1
users1
websitepuppetlabs.com

1 user in discussion

Klavs Klavsen: 1 post

People

Translate

site design / logo © 2022 Grokbase