FAQ
Sam,

You could make some changes to you site.pp and set some defaults like this

Exec {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
File {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
Group {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
Mount {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
Package {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
Service {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}
User {
   schedule => $::globalvars_schedule,
   noop => $::globalvars_noop,
}

..... and more .....


Make sure that all puppet types you use within you modules are covered in
the site.pp and have the noop => $::globalvars_noop added.

The final step is to set the topscope variable 'globalvars_noop' somewhere
(for example hiera, or Puppet console) and your node will be run with noop.
No need to touch any puppet config on the clients, and very easy to manage
:-)

Regards,
Rene vd Linden
Blog: https://www.rvanderlinden.net/wordpress

On Tuesday, July 23, 2013 1:29:24 AM UTC+2, Sam Morrison wrote:

I'm trying to set a global noop but it doesn't seem possible,

There are 2 bugs open about this which to me look pretty serious as the
expected behaviour isn't the case.

http://projects.puppetlabs.com/issues/21286
http://projects.puppetlabs.com/issues/6549

If anyone has a work around (that doesn't include modifying puppet.conf
file) I would be very interested.

Cheers,
Sam

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Justin Brown at Jul 27, 2013 at 4:11 pm
    Sam,

    You should setup MCollective. You can implement a simple plugin that
    changes the global noop setting in puppet.conf and restarts the
    daemon.

    That will give you the best scalability, and you have fine-grained
    control in MCollective on which hosts run using metadata in your
    Puppet classes and facts.

    Regards,
    Justin

    On Sat, Jul 27, 2013 at 10:52 AM, rvlinden
    wrote:
    Sam,

    You could make some changes to you site.pp and set some defaults like this

    Exec {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    File {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Group {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Mount {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Package {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Service {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    User {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }

    ..... and more .....



    Make sure that all puppet types you use within you modules are covered in
    the site.pp and have the noop => $::globalvars_noop added.

    The final step is to set the topscope variable 'globalvars_noop' somewhere
    (for example hiera, or Puppet console) and your node will be run with noop.
    No need to touch any puppet config on the clients, and very easy to manage
    :-)

    Regards,
    Rene vd Linden
    Blog: https://www.rvanderlinden.net/wordpress

    On Tuesday, July 23, 2013 1:29:24 AM UTC+2, Sam Morrison wrote:

    I'm trying to set a global noop but it doesn't seem possible,

    There are 2 bugs open about this which to me look pretty serious as the
    expected behaviour isn't the case.

    http://projects.puppetlabs.com/issues/21286
    http://projects.puppetlabs.com/issues/6549

    If anyone has a work around (that doesn't include modifying puppet.conf
    file) I would be very interested.

    Cheers,
    Sam
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Sam Morrison at Jul 29, 2013 at 6:13 am
    Thanks Justin,

    Yes MCollective would be great, just have to find the time.

    Rene: I have gone with your solution at the moment. I still think it's a
    bug that doing it on the Resource resource doesn't work, hopefully someone
    will look into those bugs.

    Cheers,
    Sam



    On Sunday, 28 July 2013 02:11:25 UTC+10, Justin Brown wrote:

    Sam,

    You should setup MCollective. You can implement a simple plugin that
    changes the global noop setting in puppet.conf and restarts the
    daemon.

    That will give you the best scalability, and you have fine-grained
    control in MCollective on which hosts run using metadata in your
    Puppet classes and facts.

    Regards,
    Justin

    On Sat, Jul 27, 2013 at 10:52 AM, rvlinden
    <rene.vand...@gmail.com <javascript:>> wrote:
    Sam,

    You could make some changes to you site.pp and set some defaults like this
    Exec {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    File {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Group {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Mount {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Package {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    Service {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }
    User {
    schedule => $::globalvars_schedule,
    noop => $::globalvars_noop,
    }

    ..... and more .....



    Make sure that all puppet types you use within you modules are covered in
    the site.pp and have the noop => $::globalvars_noop added.

    The final step is to set the topscope variable 'globalvars_noop' somewhere
    (for example hiera, or Puppet console) and your node will be run with noop.
    No need to touch any puppet config on the clients, and very easy to manage
    :-)

    Regards,
    Rene vd Linden
    Blog: https://www.rvanderlinden.net/wordpress

    On Tuesday, July 23, 2013 1:29:24 AM UTC+2, Sam Morrison wrote:

    I'm trying to set a global noop but it doesn't seem possible,

    There are 2 bugs open about this which to me look pretty serious as the
    expected behaviour isn't the case.

    http://projects.puppetlabs.com/issues/21286
    http://projects.puppetlabs.com/issues/6549

    If anyone has a work around (that doesn't include modifying puppet.conf
    file) I would be very interested.

    Cheers,
    Sam
    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users...@googlegroups.com <javascript:>.
    To post to this group, send email to puppet...@googlegroups.com<javascript:>.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 27, '13 at 3:52p
activeJul 29, '13 at 6:13a
posts3
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase