FAQ
Hi everyone!


having a slight problem with the installing the cloud provisioning module
[code]
http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
[/code]
everything worked until I wanted to actually try to fire it up:

[code]
puppet node_aws list
Error: Could not autoload puppet/face/node_aws/fingerprint: cannot load
such file -- guid
Error: Could not parse application options: Could not autoload
puppet/face/node_aws/fingerprint: cannot load such file -- guid
[/code]

I have fog configured with my AWS credentials but it seams like the
installation is just faulty, anyone any clue?


Thanks,
Piotr

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Shivaraj mathrubai at Jul 23, 2013 at 3:11 pm
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot load
    such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 23, 2013 at 3:16 pm
    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot load
    such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Shivaraj mathrubai at Jul 23, 2013 at 4:09 pm
    What is the version of Fog you have ?

    When you do "Puppet Help" do you see an exclamation mark next to node_aws ?
    On Tuesday, 23 July 2013 16:16:19 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot load
    such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 23, 2013 at 4:10 pm
    Hi,

    got the whole list

    root@ip-10-55-86-66:/home/ubuntu# gem list

    *** LOCAL GEMS ***

    builder (3.2.2)
    excon (0.25.3)
    fog (1.14.0)
    formatador (0.2.4)
    guid (0.1.1)
    mime-types (1.23)
    mini_portile (0.5.1)
    minitest (1.6.0)
    multi_json (1.7.7)
    net-scp (1.1.2)
    net-ssh (2.6.8)
    nokogiri (1.6.0)
    rake (0.8.7)
    rdoc (2.5.8)
    ruby-hmac (0.4.0)

    just got the newest one...

    Cheers,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:09:04 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    What is the version of Fog you have ?

    When you do "Puppet Help" do you see an exclamation mark next to node_aws ?
    On Tuesday, 23 July 2013 16:16:19 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning
    module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot load
    such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 24, 2013 at 11:19 am
    Hi,

    tried to play around with the RUBYLIB env var but doesn't seam to help in
    any way.

    Any ideas?

    Thanks,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:10:55 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Hi,

    got the whole list

    root@ip-10-55-86-66:/home/ubuntu# gem list

    *** LOCAL GEMS ***

    builder (3.2.2)
    excon (0.25.3)
    fog (1.14.0)
    formatador (0.2.4)
    guid (0.1.1)
    mime-types (1.23)
    mini_portile (0.5.1)
    minitest (1.6.0)
    multi_json (1.7.7)
    net-scp (1.1.2)
    net-ssh (2.6.8)
    nokogiri (1.6.0)
    rake (0.8.7)
    rdoc (2.5.8)
    ruby-hmac (0.4.0)

    just got the newest one...

    Cheers,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:09:04 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    What is the version of Fog you have ?

    When you do "Puppet Help" do you see an exclamation mark next to node_aws
    ?
    On Tuesday, 23 July 2013 16:16:19 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj
    mathrubai napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning
    module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot
    load such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 24, 2013 at 3:15 pm
    Hi,

    found some of your entries looking around Shivaraj, have you found out the
    cause of this issue on your CentOS intallation?

    Thanks,
    Piotr

    W dniu środa, 24 lipca 2013 12:19:37 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Hi,

    tried to play around with the RUBYLIB env var but doesn't seam to help in
    any way.

    Any ideas?

    Thanks,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:10:55 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Hi,

    got the whole list

    root@ip-10-55-86-66:/home/ubuntu# gem list

    *** LOCAL GEMS ***

    builder (3.2.2)
    excon (0.25.3)
    fog (1.14.0)
    formatador (0.2.4)
    guid (0.1.1)
    mime-types (1.23)
    mini_portile (0.5.1)
    minitest (1.6.0)
    multi_json (1.7.7)
    net-scp (1.1.2)
    net-ssh (2.6.8)
    nokogiri (1.6.0)
    rake (0.8.7)
    rdoc (2.5.8)
    ruby-hmac (0.4.0)

    just got the newest one...

    Cheers,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:09:04 UTC+1 użytkownik shivaraj mathrubai
    napisał:
    What is the version of Fog you have ?

    When you do "Puppet Help" do you see an exclamation mark next to
    node_aws ?
    On Tuesday, 23 July 2013 16:16:19 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj
    mathrubai napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning
    module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot
    load such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Shivaraj mathrubai at Jul 25, 2013 at 3:20 pm
    I just installed the enterprise version and it installed all the
    dependencies required and works like a charm !
    On Wednesday, 24 July 2013 16:15:17 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    found some of your entries looking around Shivaraj, have you found out
    the cause of this issue on your CentOS intallation?

    Thanks,
    Piotr

    W dniu środa, 24 lipca 2013 12:19:37 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Hi,

    tried to play around with the RUBYLIB env var but doesn't seam to help in
    any way.

    Any ideas?

    Thanks,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:10:55 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Hi,

    got the whole list

    root@ip-10-55-86-66:/home/ubuntu# gem list

    *** LOCAL GEMS ***

    builder (3.2.2)
    excon (0.25.3)
    fog (1.14.0)
    formatador (0.2.4)
    guid (0.1.1)
    mime-types (1.23)
    mini_portile (0.5.1)
    minitest (1.6.0)
    multi_json (1.7.7)
    net-scp (1.1.2)
    net-ssh (2.6.8)
    nokogiri (1.6.0)
    rake (0.8.7)
    rdoc (2.5.8)
    ruby-hmac (0.4.0)

    just got the newest one...

    Cheers,
    Piotr

    W dniu wtorek, 23 lipca 2013 17:09:04 UTC+1 użytkownik shivaraj
    mathrubai napisał:
    What is the version of Fog you have ?

    When you do "Puppet Help" do you see an exclamation mark next to
    node_aws ?
    On Tuesday, 23 July 2013 16:16:19 UTC+1, Piotr Jasiulewicz wrote:

    Hi,

    yeap, it;s installed allright:

    root@X:/home/ubuntu# gem install guid
    Successfully installed guid-0.1.1
    1 gem installed
    Installing ri documentation for guid-0.1.1...
    Installing RDoc documentation for guid-0.1.1...

    getting this every time, not sure if that's correct.

    Maybe the version is wrong?


    cheers,
    Piotr


    W dniu wtorek, 23 lipca 2013 16:11:20 UTC+1 użytkownik shivaraj
    mathrubai napisał:
    Did you install guid ?
    On Tuesday, 23 July 2013 11:03:14 UTC+1, Piotr Jasiulewicz wrote:

    Hi everyone!


    having a slight problem with the installing the cloud provisioning
    module
    [code]
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html
    [/code]
    everything worked until I wanted to actually try to fire it up:

    [code]
    puppet node_aws list
    Error: Could not autoload puppet/face/node_aws/fingerprint: cannot
    load such file -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/fingerprint: cannot load such file -- guid
    [/code]

    I have fog configured with my AWS credentials but it seams like the
    installation is just faulty, anyone any clue?


    Thanks,
    Piotr
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Jul 25, 2013 at 4:35 pm
    Is puppet enterprise free also? Not sure I would get consent from my boss... it's a bit sad that the provisioning project looks totally neglected by puppet labs.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Aug 7, 2013 at 12:27 pm
    It's somewhat disappointing that puppet labs expresses commercialism in
    such a nasty way, just breaking the free stuff and giving you an option to
    pay for it... will try on a different system and then switch to Chef.

    Cheers,
    Piotr

    W dniu czwartek, 25 lipca 2013 17:35:10 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Is puppet enterprise free also? Not sure I would get consent from my
    boss... it's a bit sad that the provisioning project looks totally
    neglected by puppet labs.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ellison Marks at Aug 7, 2013 at 6:03 pm
    Honestly, it just sounds like your system is having trouble locating the
    guid gem. try this script:

    require 'guid'

       # generate a GUID
       g = Guid.new
       puts g
       puts g.to_s
       puts g.hexdigest
       puts g.raw.inspect
       puts g.raw.length

       # generate another GUID, should be different everytime
       g2 = Guid.new
       puts g == g2

       # convert a hexstring into Guid object
       g3 = Guid.from_s(g.to_s)
       puts g3
       puts g == g3

       # convert a raw 16-byte string into Guid object
       g4 = Guid.from_raw(g.raw.inspect)
       puts g4
       puts g == g4

    Just some test functions for the gem. Run with ruby scriptname.rb. You should see some guids and hexy things and true or false values.

    If it errors out, either you didn't install the guid gem correctly or your ruby environment is slightly borked. If it does work, something else is going on.


    On Wednesday, August 7, 2013 5:27:38 AM UTC-7, Piotr Jasiulewicz wrote:

    It's somewhat disappointing that puppet labs expresses commercialism in
    such a nasty way, just breaking the free stuff and giving you an option to
    pay for it... will try on a different system and then switch to Chef.

    Cheers,
    Piotr

    W dniu czwartek, 25 lipca 2013 17:35:10 UTC+1 użytkownik Piotr Jasiulewicz
    napisał:
    Is puppet enterprise free also? Not sure I would get consent from my
    boss... it's a bit sad that the provisioning project looks totally
    neglected by puppet labs.
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jcbollinger at Aug 8, 2013 at 1:38 pm

    On Wednesday, August 7, 2013 7:27:38 AM UTC-5, Piotr Jasiulewicz wrote:
    It's somewhat disappointing that puppet labs expresses commercialism in
    such a nasty way, just breaking the free stuff and giving you an option to
    pay for it... will try on a different system and then switch to Chef.
    That would be disappointing if it were accurate, but I don't see any reason
    to think it is. In fact, I would be very surprised indeed to find that
    PuppetLabs had intentionally broken anything in the open source project.
    Indeed, the fact that it is open source rather protects against it, for any
    breakage PL might hypothetically introduce could and surely would be fixed
    by third parties. In all likelihood, the project would fork, which would
    not be a good result for PL.

    Instead, I think the Enterprise version adds careful installation
    engineering and testing (among other things) to ensure that everything
    works out of the box. That includes managing third party gems -- versions,
    installation locations, etc. -- so that they work correctly with the Puppet
    installation. There are any number of ways they otherwise might fail to do
    so, by no fault of PL's, and I think it's likely that you have stumbled on
    one of those.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Piotr Jasiulewicz at Aug 13, 2013 at 1:30 pm
    Hi,

    fair enough, what I was trying to say, was my disappointment on how the
    cloud provisioning project was being lead (basically nothing happens in the
    project for months, as you can see in their redmine). Of course puppet is a
    great piece of software and I don't deny that it is mostly my inexperience
    with it that is the problem here. However it is not good if a community
    driven project straight ignores community given bug reports wouldn't you
    say?

    @Ellison:

    thanks for the script, fired it up and got some errors:

    ubuntu@server:~$ ruby testguid.rb
    893d6e07-1920-f67d-cfb1-d8c7019d3eeb
    893d6e07-1920-f67d-cfb1-d8c7019d3eeb
    893d6e071920f67dcfb1d8c7019d3eeb
    "\x98\xD3\xE6p\x91\x02o\xD7\xFC\e\x8D|\x10\xD9\xE3\xBE"
    16
    false
    893d6e07-1920-f67d-cfb1-d8c7019d3eeb
    true
    /usr/local/ruby/lib/ruby/gems/1.9.1/gems/guid-0.1.1/lib/guid.rb:115:in
    `from_raw': Invalid GUID raw bytes, length must be 16 bytes (ArgumentError)
    from testguir.rb:21:in `<main>'

    Not sure what the problem is though.

    Any ideas?

    Thanks,
    Piotr


    W dniu czwartek, 8 sierpnia 2013 14:38:43 UTC+1 użytkownik jcbollinger
    napisał:

    On Wednesday, August 7, 2013 7:27:38 AM UTC-5, Piotr Jasiulewicz wrote:

    It's somewhat disappointing that puppet labs expresses commercialism in
    such a nasty way, just breaking the free stuff and giving you an option to
    pay for it... will try on a different system and then switch to Chef.
    That would be disappointing if it were accurate, but I don't see any
    reason to think it is. In fact, I would be very surprised indeed to find
    that PuppetLabs had intentionally broken anything in the open source
    project. Indeed, the fact that it is open source rather protects against
    it, for any breakage PL might hypothetically introduce could and surely
    would be fixed by third parties. In all likelihood, the project would
    fork, which would not be a good result for PL.

    Instead, I think the Enterprise version adds careful installation
    engineering and testing (among other things) to ensure that everything
    works out of the box. That includes managing third party gems -- versions,
    installation locations, etc. -- so that they work correctly with the Puppet
    installation. There are any number of ways they otherwise might fail to do
    so, by no fault of PL's, and I think it's likely that you have stumbled on
    one of those.


    John
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 23, '13 at 10:03a
activeAug 13, '13 at 1:30p
posts13
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2022 Grokbase