FAQ
Here is my manifest...

package { 'tractor blade':
                 provider => 'rpm',
                 ensure => present,
                 source =>
'puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
                 name =>
'tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
         }


Here is where that file is...

...modules/mpsvfx/files/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm

Here is the error I get...

Error: Execution of '/bin/rpm -i
puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm'
returned 1: error: open of
puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm
failed: No such file or directory

Anybody know what I am doing wrong?

Thanks.
Mark

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Jcbollinger at Jul 18, 2013 at 9:47 pm

    On Thursday, July 18, 2013 2:15:50 PM UTC-5, Mark Hatch wrote:
    Here is my manifest...

    package { 'tractor blade':
    provider => 'rpm',
    ensure => present,
    source =>
    'puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
    name =>
    'tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
    }


    Here is where that file is...


    ...modules/mpsvfx/files/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm

    Here is the error I get...

    Error: Execution of '/bin/rpm -i
    puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm'
    returned 1: error: open of
    puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm
    failed: No such file or directory

    Anybody know what I am doing wrong?
    The documentation has this to say about the Package type's 'source'
    parameter
    (http://docs.puppetlabs.com/references/3.2.latest/type.html#package):
    *source*Where to find the actual package. This must be a local file (or on
    a network file system) or a URL *that your specific packaging type
    understands*; Puppet will not retrieve files for you, although you can
    manage packages as file resources.(emphasis added)

    RPM does not understand URLs employing the 'puppet' protocol. You cannot
    use Puppet's built-in file server as a substitute for a proper package
    repository. You can, however, create a bona fide local repository of the
    appropriate type for your native packaging system, and put your package
    file(s) there. It could live on the same host as your Puppet master if you
    prefer.


    John

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Sneha more at Jul 19, 2013 at 11:22 am

    On Friday, July 19, 2013 12:45:50 AM UTC+5:30, Mark Hatch wrote:
    Here is my manifest...

    package { 'tractor blade':
    provider => 'rpm',
    ensure => present,
    source =>
    'puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
    name =>
    'tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm',
    }


    Here is where that file is...


    ...modules/mpsvfx/files/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm

    Here is the error I get...

    Error: Execution of '/bin/rpm -i
    puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm'
    returned 1: error: open of
    puppet:///modules/mpsvfx/tractor-blade-1.7_1191418-linuxFC12_gcc44icc121.x86_64.rpm
    failed: No such file or directory

    Anybody know what I am doing wrong?

    Thanks.
    Mark
    Hi Mark,
          John is right, in package resource you can not directly use source as
    puppet file server,
          OR i think, you can solve this issue by first transferring the .rpm
    file by file resource and then installing it through exec resource by rpm
    -ivh command.
          This is work around solution for what you are doing.

    Regards,
    Sneha.



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Ripunjay Godhani at Jul 19, 2013 at 12:15 pm
    yes Sneha is right

    On 19 July 2013 16:44, sneha more wrote:


    On Friday, July 19, 2013 12:45:50 AM UTC+5:30, Mark Hatch wrote:

    Here is my manifest...

    package { 'tractor blade':
    provider => 'rpm',
    ensure => present,
    source => 'puppet:///modules/mpsvfx/**
    tractor-blade-1.7_1191418-**linuxFC12_gcc44icc121.x86_64.**rpm',
    name => 'tractor-blade-1.7_1191418-**
    linuxFC12_gcc44icc121.x86_64.**rpm',
    }


    Here is where that file is...

    ...modules/mpsvfx/files/**tractor-blade-1.7_1191418-**
    linuxFC12_gcc44icc121.x86_64.**rpm

    Here is the error I get...

    Error: Execution of '/bin/rpm -i puppet:///modules/mpsvfx/**
    tractor-blade-1.7_1191418-**linuxFC12_gcc44icc121.x86_64.**rpm' returned
    1: error: open of puppet:///modules/mpsvfx/**tractor-blade-1.7_1191418-**
    linuxFC12_gcc44icc121.x86_64.**rpm failed: No such file or directory

    Anybody know what I am doing wrong?

    Thanks.
    Mark
    Hi Mark,
    John is right, in package resource you can not directly use source as
    puppet file server,
    OR i think, you can solve this issue by first transferring the .rpm
    file by file resource and then installing it through exec resource by rpm
    -ivh command.
    This is work around solution for what you are doing.

    Regards,
    Sneha.



    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 18, '13 at 7:15p
activeJul 19, '13 at 12:15p
posts4
users4
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase