FAQ
Im trying to install the SCOMAgent.msi on Windows Server 2008 R2 with
puppet version 2.7.19

I try this code and get the error "change from absent to present failed:
Failed to install: The network name cannot be found.":

         package {'System Center Operations Manager 2007 R2 Agent':
             ensure => installed,
             provider => 'msi',
             source => 'C:\Install\MOMAgent.msi',
         }


if I use a command line like 'msiexec /i C:\Install\MOMAgent.msi' the scom
agent will be installed.

Can anyone help me?

Thanx tinu

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Rob Reynolds at Jul 18, 2013 at 3:42 pm
    Hello,

    Can you run puppet apply --debug *themanifestname.pp*
    *
    *
    and submit your output here (minus any sensitive data)?

    Thanks!

    --
    Rob Reynolds
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Final Countdown discount - save
    15%!*

    On Thu, Jul 18, 2013 at 7:20 AM, tinu wrote:

    Im trying to install the SCOMAgent.msi on Windows Server 2008 R2 with
    puppet version 2.7.19

    I try this code and get the error "change from absent to present failed:
    Failed to install: The network name cannot be found.":

    package {'System Center Operations Manager 2007 R2 Agent':
    ensure => installed,
    provider => 'msi',
    source => 'C:\Install\MOMAgent.msi',
    }


    if I use a command line like 'msiexec /i C:\Install\MOMAgent.msi' the scom
    agent will be installed.

    Can anyone help me?

    Thanx tinu

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Tinu at Jul 22, 2013 at 10:35 am
    puppet apply --debug scomagent.pp:

    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    warning: Deprecation notice: Resource references should now be capitalized
    on line 22 in file
    //puppetmaster/puppet/development/modules/services/manifests/scomagent.pp
    warning: Deprecation notice: Resource references should now be capitalized
    on line 27 in file
    //puppetmaster/puppet/development/modules/services/manifests/scomagent.pp
    debug: Creating default schedules
    debug: Failed to load library 'selinux' for feature 'selinux'
    debug: Puppet::Type::File::ProviderPosix: feature posix is missing
    debug: Failed to load library 'ldap' for feature 'ldap'
    debug: Failed to load library 'shadow' for feature 'libshadow'
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/ca.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/log]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/crl.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/lib]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/resources.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/facts]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/graphs]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certificate_requests]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/state.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/clientbucket]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/classes.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_report.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_data]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/run]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]/mode:
    mode changed '2000644' to '0644'
    debug: Finishing transaction 40182696
    debug: Loaded state in 0.00 seconds
    debug: Loaded state in 0.02 seconds
    info: Applying configuration version '1374223809'
    debug: /Schedule[daily]: Skipping device resources because running on a host
    debug: /Schedule[monthly]: Skipping device resources because running on a
    host
    debug: /Schedule[hourly]: Skipping device resources because running on a
    host
    debug: /Schedule[never]: Skipping device resources because running on a host
    debug: /Schedule[weekly]: Skipping device resources because running on a
    host
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 40928160
    debug: Storing state
    debug: Stored state in 0.05 seconds
    notice: Finished catalog run in 0.14 seconds
    debug: Finishing transaction 40159212
    debug: Received report to process from server.domain.com
    debug: Processing report from server.domain.com with processor
    Puppet::Reports::Store

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Rob Reynolds at Jul 22, 2013 at 8:56 pm
    Can you send the manifest and output from puppet apply --debug --trace?

    Also do you have the agent already installed?

    --
    Rob Reynolds
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Final Countdown discount - save
    15%!*

    On Mon, Jul 22, 2013 at 5:34 AM, tinu wrote:

    puppet apply --debug scomagent.pp:


    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb

    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    warning: Deprecation notice: Resource references should now be
    capitalized on line 22 in file
    //puppetmaster/puppet/development/modules/services/manifests/scomagent.pp
    warning: Deprecation notice: Resource references should now be
    capitalized on line 27 in file
    //puppetmaster/puppet/development/modules/services/manifests/scomagent.pp
    debug: Creating default schedules
    debug: Failed to load library 'selinux' for feature 'selinux'
    debug: Puppet::Type::File::ProviderPosix: feature posix is missing
    debug: Failed to load library 'ldap' for feature 'ldap'
    debug: Failed to load library 'shadow' for feature 'libshadow'
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/ca.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/log]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/crl.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/lib]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/resources.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/facts]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/graphs]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certificate_requests]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/state.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/clientbucket]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/classes.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_report.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_data]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/run]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]/mode:
    mode changed '2000644' to '0644'
    debug: Finishing transaction 40182696
    debug: Loaded state in 0.00 seconds
    debug: Loaded state in 0.02 seconds
    info: Applying configuration version '1374223809'
    debug: /Schedule[daily]: Skipping device resources because running on a
    host
    debug: /Schedule[monthly]: Skipping device resources because running on a
    host
    debug: /Schedule[hourly]: Skipping device resources because running on a
    host
    debug: /Schedule[never]: Skipping device resources because running on a
    host
    debug: /Schedule[weekly]: Skipping device resources because running on a
    host
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 40928160
    debug: Storing state
    debug: Stored state in 0.05 seconds
    notice: Finished catalog run in 0.14 seconds
    debug: Finishing transaction 40159212
    debug: Received report to process from server.domain.com
    debug: Processing report from server.domain.com with processor
    Puppet::Reports::Store

    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Tinu at Jul 23, 2013 at 10:51 am
    This manifest get the error above.

    class services::scomagent (
         $install_source = 'puppet:///modules/services/MOMAgent.msi',
         $msi_source = 'C:\Install\MOMAgent.msi',
         $msi_install_dir = '"C:\\Program Files\\System Center Operations
    Manager 2007"',
         $msi_package_name = "System Center Operations Manager 2007 R2 Agent",
         $msi_logfile =
    'C:\ProgramData\PuppetLabs\puppet\var\log\$msi_package_name.log'
    ){
         file { 'C:\\Install':
             ensure => directory,
             mode => '0770',
             owner => 'SYSTEM',
             group => 'Administrators',
         }
         file { $msi_source:
             ensure => file,
             source => $install_source,
             mode => '0770',
             owner => 'SYSTEM',
             group => 'Administrators',
             require => file['C:\\Install']
         }
         package {'System Center Operations Manager 2007 R2 Agent':
             ensure => present,
             provider => 'msi',
             source => $msi_source,
             install_options => {'INSTALLDIR' => $msi_install_dir},
             require => file[$msi_source]
         }
    }

    puppet apply --debug --trace
    \\puppetmaster.domain.com\puppet\development\modules\services\manifests\scomagent.pp
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    warning: Deprecation notice: Resource references should now be capitalized
    on line 21 in file
    //puppetmaster.domain.com/puppet/development/modules/services/manifests/scomagent.pp
    warning: Deprecation notice: Resource references should now be capitalized
    on line 28 in file
    //puppetmaster.domain.com/puppet/development/modules/services/manifests/scomagent.pp
    debug: Creating default schedules
    debug: Failed to load library 'selinux' for feature 'selinux'
    debug: Puppet::Type::File::ProviderPosix: feature posix is missing
    debug: Failed to load library 'ldap' for feature 'ldap'
    debug: Failed to load library 'shadow' for feature 'libshadow'
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_report.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/graphs]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/classes.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/log]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_data]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/state.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certificate_requests]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/resources.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/crl.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/puppetdlock]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/run]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/facts]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/lib]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/ca.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/clientbucket]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/server.domain.com.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: Finishing transaction 39629568
    debug: Loaded state in 0.02 seconds
    debug: Loaded state in 0.00 seconds
    info: Applying configuration version '1374561947'
    debug: /Schedule[daily]: Skipping device resources because running on a host
    debug: /Schedule[monthly]: Skipping device resources because running on a
    host
    debug: /Schedule[hourly]: Skipping device resources because running on a
    host
    debug: /Schedule[never]: Skipping device resources because running on a host
    debug: /Schedule[weekly]: Skipping device resources because running on a
    host
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 40310916
    debug: Storing state
    debug: Stored state in 0.03 seconds
    notice: Finished catalog run in 0.09 seconds
    debug: Finishing transaction 39396972
    debug: Received report to process from server.domain.com
    debug: Processing report from server.domain.com with processor
    Puppet::Reports::Store

    The agent is installed and can configure any other manifests. I can install
    the MSI with this manifest:

    class services::scomagent (
         $install_source = 'puppet:///modules/services/MOMAgent.msi',
         $msi_source = 'C:\Install\MOMAgent.msi',
         $msi_install_dir = '"C:\\Program Files\\System Center Operations
    Manager 2007"',
         $msi_package_name = "System Center Operations Manager 2007 R2 Agent",
         $msi_logfile =
    'C:\ProgramData\PuppetLabs\puppet\var\log\$msi_package_name.log'
    ){
         file { 'C:\\Install':
             ensure => directory,
             mode => '0770',
             owner => 'SYSTEM',
             group => 'Administrators',
         }
         file { $msi_source:
             ensure => file,
             source => $install_source,
             mode => '0770',
             owner => 'SYSTEM',
             group => 'Administrators',
             require => file['C:\\Install']
         }

         $scom_server = 'x3012app061.infra.be.ch'
         $scom_mgmtgrp = 'a88a-scom'

         $msiexec_path = 'c:\Windows\System32\msiexec.exe'
         $install_command = "$msiexec_path /i $msi_source /qn
    INSTALLDIR=$msi_install_dir /L*v $msi_logfile USE_SETTINGS_FROM_AD=0
    MANAGEMENT_SERVER_DNS=$scom_server MANAGEMENT_GROUP=$scom_mgmtgrp
    ACTIONS_USE_COMPUTER_ACCOUNT=1 USE_MANUALLY_SPECIFIED_SETTINGS=1"
         exec {"$msi_package_name":
              command => $install_command,
         }
    }

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at Jul 23, 2013 at 4:24 pm
    Hi Timu,

    On Tue, Jul 23, 2013 at 3:51 AM, tinu wrote:

    This manifest get the error above.

    class services::scomagent (
    $install_source = 'puppet:///modules/services/MOMAgent.msi',
    $msi_source = 'C:\Install\MOMAgent.msi',
    $msi_install_dir = '"C:\\Program Files\\System Center Operations
    Manager 2007"',
    The `install_options` parameter will automatically quote options with
    spaces in them. As it is now, if puppet actually did try to install the
    package, it would pass INSTALLDIR=""C:\Program Files\System Center
    Operations Manager 2007"" on the command line, which may confuse
    msiexec.exe.

    $msi_package_name = "System Center Operations Manager 2007 R2 Agent",
    $msi_logfile =
    'C:\ProgramData\PuppetLabs\puppet\var\log\$msi_package_name.log'
    Since you are using single quotes, the $msi_package_name will not be
    interpolated. You'll need to change this to double quotes, and then escape
    each backslash, e.g. "C:\\ProgramData\\...\\$msi_package_name.log"

    ){
    file { 'C:\\Install':
    ensure => directory,
    mode => '0770',
    owner => 'SYSTEM',
    group => 'Administrators',
    }
    file { $msi_source:
    ensure => file,
    source => $install_source,
    mode => '0770',
    owner => 'SYSTEM',
    group => 'Administrators',
    require => file['C:\\Install']

    }
    package {'System Center Operations Manager 2007 R2 Agent':
    ensure => present,
    provider => 'msi',
    If you are using Puppet 3, the `msi` provider is deprecated. You'll want to
    use `provider => 'windows'` or omit the provider parameter altogether.

             source => $msi_source,
    install_options => {'INSTALLDIR' => $msi_install_dir},
    require => file[$msi_source]
    }
    }
    This defines the services::scomagent class (which should be
    Services::Scomagent to avoid the deprecation warnings below). But you still
    need to declare an instance of that class. Typically that's done in your
    node definition (assign which classes are applied to which nodes):

         class { 'services::scomagent': }

    See also
    http://docs.puppetlabs.com/puppet/3/reference/lang_node_definitions.html

    puppet apply --debug --trace \\puppetmaster.domain.com
    \puppet\development\modules\services\manifests\scomagent.pp

    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    warning: Deprecation notice: Resource references should now be
    capitalized on line 21 in file //
    puppetmaster.domain.com/puppet/development/modules/services/manifests/scomagent.pp
    warning: Deprecation notice: Resource references should now be
    capitalized on line 28 in file //
    puppetmaster.domain.com/puppet/development/modules/services/manifests/scomagent.pp
    debug: Creating default schedules
    ... snip ...
    info: Applying configuration version '1374561947'
    ... snip....
    notice: Finished catalog run in 0.09 seconds
    debug: Finishing transaction 39396972
    debug: Received report to process from server.domain.com
    debug: Processing report from server.domain.com with processor
    Puppet::Reports::Store
    I don't see the error "change from absent to present failed: Failed to
    install: The network name cannot be found." in the output above. I think
    this is because you haven't declared an instance of your class.

    The agent is installed and can configure any other manifests. I can
    install the MSI with this manifest:

    class services::scomagent (
    $install_source = 'puppet:///modules/services/MOMAgent.msi',
    $msi_source = 'C:\Install\MOMAgent.msi',
    $msi_install_dir = '"C:\\Program Files\\System Center Operations
    Manager 2007"',
    $msi_package_name = "System Center Operations Manager 2007 R2 Agent",
    $msi_logfile =
    'C:\ProgramData\PuppetLabs\puppet\var\log\$msi_package_name.log'
    ){
    file { 'C:\\Install':
    ensure => directory,
    mode => '0770',
    owner => 'SYSTEM',
    group => 'Administrators',
    }
    file { $msi_source:
    ensure => file,
    source => $install_source,
    mode => '0770',
    owner => 'SYSTEM',
    group => 'Administrators',
    require => file['C:\\Install']
    }

    $scom_server = 'x3012app061.infra.be.ch'
    $scom_mgmtgrp = 'a88a-scom'

    $msiexec_path = 'c:\Windows\System32\msiexec.exe'
    $install_command = "$msiexec_path /i $msi_source /qn
    INSTALLDIR=$msi_install_dir /L*v $msi_logfile USE_SETTINGS_FROM_AD=0
    MANAGEMENT_SERVER_DNS=$scom_server MANAGEMENT_GROUP=$scom_mgmtgrp
    ACTIONS_USE_COMPUTER_ACCOUNT=1 USE_MANUALLY_SPECIFIED_SETTINGS=1"
    exec {"$msi_package_name":
    command => $install_command,

    }
    }
    Josh

    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Final Countdown discount - save
    15%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Tinu at Jul 25, 2013 at 2:44 pm
    Hello Josh

    Thank you for your answers.

    I changed the $msi_install_dir = '"C:\\Program Files\\System Center
    Operations Manager 2007"' to "C:\\Program Files\\System Center Operations
    Manager 2007",
    and the $msi_logfile to
    "C:\\ProgramData\\PuppetLabs\\puppet\\var\\log\\$msi_package_name.log"

    Result from *Run Puppet Agent*:

    Running Puppet agent on demand ...
    info: Retrieving plugin
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    info: Caching catalog for webtest02.infra.be.ch
    info: Applying configuration version '1374762832'
    err: /Stage[main]/Services::Scomagent/Package[System Center Operations
    Manager 2007 R2 Agent]/ensure: change from absent to present failed: *Failed
    to install: The network name cannot be found.*
    notice: Finished catalog run in 90.96 seconds
    Press any key to continue . . .

    In my node, I have already a declaration for this class as *class {
    'services::scomagent': } *and I can install this MSI with the *exec*.
    *
    *
    We have the following puppet versions:
    Puppetmaster = 2.7.18
    Puppet Agent = 2.7.19

    Any other ideas?

    Tinu

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at Jul 25, 2013 at 6:33 pm
    Hi Tinu,

    On Thu, Jul 25, 2013 at 7:44 AM, tinu wrote:

    Hello Josh

    Thank you for your answers.

    I changed the $msi_install_dir = '"C:\\Program Files\\System Center
    Operations Manager 2007"' to "C:\\Program Files\\System Center Operations
    Manager 2007",
    and the $msi_logfile to
    "C:\\ProgramData\\PuppetLabs\\puppet\\var\\log\\$msi_package_name.log"

    Result from *Run Puppet Agent*:

    Running Puppet agent on demand ...
    info: Retrieving plugin
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    info: Caching catalog for webtest02.infra.be.ch
    info: Applying configuration version '1374762832'
    err: /Stage[main]/Services::Scomagent/Package[System Center Operations
    Manager 2007 R2 Agent]/ensure: change from absent to present failed: *Failed
    to install: The network name cannot be found.*
    notice: Finished catalog run in 90.96 seconds
    Can you launch the "Start Command Prompt with Puppet", right click, select
    Run as Administrator. Stop the puppet service (net stop puppet), and then
    execute:

         puppet agent --test --debug --trace

    And reply with the resulting stack trace?

    Josh

    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Final Countdown discount - save
    15%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Tinu at Jul 26, 2013 at 6:33 am
    Hello Josh

    Here the output from puppet agent --test --debug --trace:

    ruby 1.8.7 (2012-02-08 patchlevel 358) [i386-mingw32]
    C:\Program Files (x86)\Puppet Labs\Puppet\bin>puppet agent --test --debug
    --trace
    debug: Failed to load library 'syslog' for feature 'syslog'
    debug: Failed to load library 'selinux' for feature 'selinux'
    debug: Puppet::Type::File::ProviderPosix: feature posix is missing
    debug: Failed to load library 'ldap' for feature 'ldap'
    debug: Failed to load library 'shadow' for feature 'libshadow'
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_summary.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/resources.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/run]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/graphs]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/crl.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/var/state/last_run_report.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/clientbucket]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/lib]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/classes.txt]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certificate_requests]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/puppet.conf]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/log]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state/state.yaml]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var/state]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/facts]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/client_data]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/ca.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: Finishing transaction 129888816
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/private]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/crl.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/facts]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/run]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys/webtest02.infra.be.ch.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/log]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug:
    /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certificate_requests]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/lib]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/etc]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/var/state]: Autorequiring
    File[C:/ProgramData/PuppetLabs/puppet/var]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs/ca.pem]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/certs]
    debug: /File[C:/ProgramData/PuppetLabs/puppet/etc/ssl/public_keys]:
    Autorequiring File[C:/ProgramData/PuppetLabs/puppet/etc/ssl]
    debug: Finishing transaction 40262460
    debug: Using cached certificate for ca
    debug: Using cached certificate for webtest02.infra.be.ch
    debug: Finishing transaction 131416332
    debug: Loaded state in 0.00 seconds
    info: Retrieving plugin
    debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
    pson
    debug: Using cached certificate for ca
    debug: Using cached certificate for webtest02.infra.be.ch
    debug: Using cached certificate_revocation_list for ca
    debug: Finishing transaction 130438752
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/defaultgateway.rb
    info: Loading facts in
    C:/ProgramData/PuppetLabs/puppet/var/lib/facter/networkadapters.rb
    debug: catalog supports formats: b64_zlib_yaml dot pson raw yaml; using pson
    info: Caching catalog for webtest02.infra.be.ch
    debug: Puppet::Type::Package::ProviderSunfreeware: file pkg-get does not
    exist
    debug: Puppet::Type::Package::ProviderAptitude: file /usr/bin/aptitude does
    not exist
    debug: Puppet::Type::Package::ProviderRug: file /usr/bin/rug does not exist
    debug: Puppet::Type::Package::ProviderPortage: file /usr/bin/emerge does
    not exist
    debug: Puppet::Type::Package::ProviderPkg: file /usr/bin/pkg does not exist
    debug: Puppet::Type::Package::ProviderYum: file yum does not exist
    debug: Puppet::Type::Package::ProviderPorts: file
    /usr/local/sbin/portupgrade does not exist
    debug: Puppet::Type::Package::ProviderNim: file /usr/sbin/nimclient does
    not exist
    debug: Puppet::Type::Package::ProviderUrpmi: file urpmi does not exist
    debug: Puppet::Type::Package::ProviderUp2date: file /usr/sbin/up2date-nox
    does not exist
    debug: Puppet::Type::Package::ProviderPortupgrade: file
    /usr/local/sbin/portupgrade does not exist
    debug: Puppet::Type::Package::ProviderAptrpm: file apt-get does not exist
    debug: Puppet::Type::Package::ProviderFink: file /sw/bin/fink does not exist
    debug: Puppet::Type::Package::ProviderAix: file /usr/bin/lslpp does not
    exist
    debug: Puppet::Type::Package::ProviderOpenbsd: file pkg_delete does not
    exist
    debug: Puppet::Type::Package::ProviderRpm: file rpm does not exist
    debug: Puppet::Type::Package::ProviderZypper: file /usr/bin/zypper does not
    exist
    debug: Puppet::Type::Package::ProviderHpux: file /usr/sbin/swremove does
    not exist
    debug: Puppet::Type::Package::ProviderFreebsd: file /usr/sbin/pkg_delete
    does not exist
    debug: Puppet::Type::Package::ProviderPacman: file /usr/bin/pacman does not
    exist
    debug: Puppet::Type::Package::ProviderApt: file /usr/bin/apt-get does not
    exist
    debug: Puppet::Type::Package::ProviderSun: file /usr/sbin/pkgrm does not
    exist
    debug: Puppet::Type::Package::ProviderDpkg: file /usr/bin/dpkg does not
    exist
    debug: Creating default schedules
    debug: Loaded state in 0.02 seconds
    info: Applying configuration version '1374819845'
    debug: /Stage[4]/require: requires Stage[3]
    debug: /Stage[4]/before: requires Stage[5]
    debug: /Stage[8]/require: requires Stage[7]
    debug: /Stage[8]/before: requires Stage[9]
    debug: /Stage[5]/require: requires Stage[4]
    debug: /Stage[5]/before: requires Stage[6]
    debug: /Stage[6]/require: requires Stage[5]
    debug: /Stage[6]/before: requires Stage[7]
    debug: /Stage[3]/require: requires Stage[2]
    debug: /Stage[3]/before: requires Stage[4]
    debug: /Stage[12]/require: requires Stage[11]
    debug: /Stage[9]/require: requires Stage[8]
    debug: /Stage[9]/before: requires Stage[10]
    debug: /Stage[1]/before: requires Stage[2]
    debug: /Stage[10]/require: requires Stage[9]
    debug: /Stage[10]/before: requires Stage[11]
    debug: /Stage[7]/require: requires Stage[6]
    debug: /Stage[7]/before: requires Stage[8]
    debug: /Stage[main]/Services::Scomagent/Package[System Center Operations
    Manager 2007 R2 Agent]/require: requi
    res File[C:\\Install\\MOMAgent.msi]
    debug:
    /Stage[main]/Services::Scomagent/File[C:\\Install\\MOMAgent.msi]/require:
    requires File[C:\\Install]
    debug: /Stage[11]/require: requires Stage[10]
    debug: /Stage[11]/before: requires Stage[12]
    debug: /Stage[2]/require: requires Stage[1]
    debug: /Stage[2]/before: requires Stage[3]
    debug: /Schedule[daily]: Skipping device resources because running on a host
    debug: /Schedule[monthly]: Skipping device resources because running on a
    host
    debug: /Schedule[hourly]: Skipping device resources because running on a
    host
    debug: Checking existence of registry key
    Registry_key[HKLM\SOFTWARE\Puppet\WCM](provider=registry)
    debug: /Schedule[never]: Skipping device resources because running on a host
    debug: /Schedule[weekly]: Skipping device resources because running on a
    host
    debug: file_metadata supports formats: b64_zlib_yaml pson raw yaml; using
    pson
    debug: Prefetching msi resources for package
    debug: Package[System Center Operations Manager 2007 R2
    Agent](provider=msi): Executing 'msiexec.exe /qn /nore
    start /i C:\\Install\\MOMAgent.msi INSTALLDIR="C:\Program Files\System
    Center Operations Manager 2007"'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/provider/package/msi.rb:115:in `check_result'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/provider/package/msi.rb:78:in `install'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/type/package.rb:63:in `set_present'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/property.rb:81:in `send'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/property.rb:81:in `call_valuemethod'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/property.rb:288:in `set'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/property.rb:342:in `sync'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction/resource_harness.rb:114:in
    `apply_parameter'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction/resource_harness.rb:56:in
    `perform_changes'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction/resource_harness.rb:133:in
    `evaluate'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:49:in `apply'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:84:in `eval_resource'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:104:in `evaluate'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/util.rb:493:in
    `thinmark'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/sys/ruby/lib/ruby/1.8/benchmark.rb:308:in `realtime'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/util.rb:492:in
    `thinmark'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:104:in `evaluate'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:386:in `traverse'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/transaction.rb:99:in `evaluate'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/resource/catalog.rb:141:in `apply'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/configurer.rb:122:in
    `retrieve_and_apply_catalog'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/util.rb:161:in
    `benchmark'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/sys/ruby/lib/ruby/1.8/benchmark.rb:308:in `realtime'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/util.rb:160:in
    `benchmark'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/configurer.rb:121:in
    `retrieve_and_apply_catalog'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/configurer.rb:152:in `run'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:43:in
    `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/agent/locker.rb:21:in `lock'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:43:in
    `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/sys/ruby/lib/ruby/1.8/sync.rb:230:in `synchronize'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:43:in
    `run'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:95:in
    `with_client'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:41:in
    `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:172:in `call'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:172:in `controlled_run'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/lib/puppet/agent.rb:39:in
    `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application/agent.rb:339:in `onetime'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application/agent.rb:313:in `run_command'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:309:in `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:416:in `hook'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:309:in `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:407:in `exit_on_fail'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/application.rb:309:in `run'
    C:/Program Files (x86)/Puppet
    Labs/Puppet/puppet/lib/puppet/util/command_line.rb:69:in `execute'
    C:/Program Files (x86)/Puppet Labs/Puppet/puppet/bin/puppet:4
    err: /Stage[main]/Services::Scomagent/Package[System Center Operations
    Manager 2007 R2 Agent]/ensure: change from absent to present failed: Failed
    to install: The network name cannot be found.
    debug: /Schedule[puppet]: Skipping device resources because running on a
    host
    debug: Finishing transaction 144106908
    debug: Storing state
    debug: Stored state in 0.06 seconds
    notice: Finished catalog run in 88.79 seconds
    debug: Value of 'preferred_serialization_format' (pson) is invalid for
    report, using default (b64_zlib_yaml)
    debug: report supports formats: b64_zlib_yaml raw yaml; using b64_zlib_yaml

    Tinu

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Josh Cooper at Jul 31, 2013 at 6:32 am
    Hi Tinu,
    On Thu, Jul 25, 2013 at 11:33 PM, tinu wrote:

    Hello Josh

    Here the output from puppet agent --test --debug --trace:

    ruby 1.8.7 (2012-02-08 patchlevel 358) [i386-mingw32]
    C:\Program Files (x86)\Puppet Labs\Puppet\bin>puppet agent --test --debug
    --trace
    ...
    debug: Package[System Center Operations Manager 2007 R2
    Agent](provider=msi): Executing 'msiexec.exe /qn /nore
    start /i C:\\Install\\MOMAgent.msi INSTALLDIR="C:\Program Files\System
    Center Operations Manager 2007"'
    ...
    >
    err: /Stage[main]/Services::Scomagent/Package[System Center Operations
    Manager 2007 R2 Agent]/ensure: change from absent to present failed: Failed
    to install: The network name cannot be found.
    I think you have extra backslashes in the MOMAgent.msi path, which is
    consistent with the error message "The network name cannot be found."
    msiexec thinks the double backslashes are a UNC path.

    Make sure you either use single quotes and single backslashes, or if you
    need to interpolate the string, double quotes with double backslashes, but
    not single quotes with double backslashes[1].

    Josh

    [1] https://projects.puppetlabs.com/issues/16246

    --
    Josh Cooper
    Developer, Puppet Labs

    *Join us at PuppetConf 2013, August 22-23 in San Francisco - *
    http://bit.ly/pupconf13*
    **Register now and take advantage of the Final Countdown discount - save
    15%!*

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 18, '13 at 2:05p
activeJul 31, '13 at 6:32a
posts10
users3
websitepuppetlabs.com

3 users in discussion

Tinu: 5 posts Josh Cooper: 3 posts Rob Reynolds: 2 posts

People

Translate

site design / logo © 2022 Grokbase