FAQ
Hi Guys,

I'm unable to load the module cloud provisioner, when I try to run node_aws
it gives me the below errors:

Error: Could not autoload puppet/face/node_aws/list_keynames: no such file
to load -- guid
Error: Could not parse application options: Could not autoload
puppet/face/node_aws/list_keynames: no such file to load -- guid

And when I see the help list I can see the below message:

! node ! Subcommand unavailable due to error. Check error logs.
   ! node_aws ! Subcommand unavailable due to error. Check error logs.

I'm using Puppet 3.2.3 and Ruby 1.9.2

Any hint to fix this ?

Thanks in advance !




--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Shivaraj mathrubai at Jul 17, 2013 at 11:23 pm
    I'm using CentOS
    On Thursday, 18 July 2013 00:21:52 UTC+1, shivaraj mathrubai wrote:


    Hi Guys,

    I'm unable to load the module cloud provisioner, when I try to run
    node_aws it gives me the below errors:

    Error: Could not autoload puppet/face/node_aws/list_keynames: no such file
    to load -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/list_keynames: no such file to load -- guid

    And when I see the help list I can see the below message:

    ! node ! Subcommand unavailable due to error. Check error logs.
    ! node_aws ! Subcommand unavailable due to error. Check error
    logs.

    I'm using Puppet 3.2.3 and Ruby 1.9.2

    Any hint to fix this ?

    Thanks in advance !



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Justin Stoller at Jul 18, 2013 at 12:49 am

    On Wed, Jul 17, 2013 at 4:23 PM, shivaraj mathrubai wrote:

    I'm using CentOS

    On Thursday, 18 July 2013 00:21:52 UTC+1, shivaraj mathrubai wrote:


    Hi Guys,

    I'm unable to load the module cloud provisioner, when I try to run
    node_aws it gives me the below errors:

    Error: Could not autoload puppet/face/node_aws/list_**keynames: no such
    file to load -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/list_**keynames: no such file to load -- guid

    Hrm, it looks like it can't find a dependency... Can you `yum install
    rubygem-guid` ?

    And when I see the help list I can see the below message:
    ! node ! Subcommand unavailable due to error. Check error logs.
    ! node_aws ! Subcommand unavailable due to error. Check error
    logs.

    I'm using Puppet 3.2.3 and Ruby 1.9.2

    Any hint to fix this ?

    Thanks in advance !




    --
    You received this message because you are subscribed to the Google Groups
    "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an
    email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.



    --

    Join us at PuppetConf 2013, August 22-23 in San Francisco -
    http://bit.ly/pupconf13

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Shivaraj mathrubai at Jul 18, 2013 at 6:33 pm
    Thanks Justin, but I already have installed guid, any other thoughts ?

    I was following the steps provided here
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html

    It says the below : Do you know which exact file I should add the PATH on a
    CentOS ? how to add it ?

    After installing it, you must add the lib directory of the module to your
    $RUBYLIB. Add the following to your .profile file (replacing
    /etc/puppet/modules with the directory from the install command, if
    necessary), then run source ~/.profile to re-load it in the current shell:

    export RUBYLIB=/etc/puppet/modules/cloud_provisioner/lib:$RUBYLIB

    On Thursday, 18 July 2013 00:21:52 UTC+1, shivaraj mathrubai wrote:


    Hi Guys,

    I'm unable to load the module cloud provisioner, when I try to run
    node_aws it gives me the below errors:

    Error: Could not autoload puppet/face/node_aws/list_keynames: no such file
    to load -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/list_keynames: no such file to load -- guid

    And when I see the help list I can see the below message:

    ! node ! Subcommand unavailable due to error. Check error logs.
    ! node_aws ! Subcommand unavailable due to error. Check error
    logs.

    I'm using Puppet 3.2.3 and Ruby 1.9.2

    Any hint to fix this ?

    Thanks in advance !



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Jason Oakley at Apr 23, 2014 at 1:58 am
    I have the same issue. There's a bug report on the Puppet site that
    installing the Cloud Provisioner module breaks the node command.
    I wrote a blog post explaining
    everything: http://jasonoakley.com/puppet/beginning-adventures-with-puppet-from-puppetlabs/
    On Friday, 19 July 2013 04:33:43 UTC+10, shivaraj mathrubai wrote:

    Thanks Justin, but I already have installed guid, any other thoughts ?

    I was following the steps provided here
    http://docs.puppetlabs.com/guides/cloud_pack_getting_started.html

    It says the below : Do you know which exact file I should add the PATH on
    a CentOS ? how to add it ?

    After installing it, you must add the lib directory of the module to your
    $RUBYLIB. Add the following to your .profile file (replacing
    /etc/puppet/modules with the directory from the install command, if
    necessary), then run source ~/.profile to re-load it in the current shell:

    export RUBYLIB=/etc/puppet/modules/cloud_provisioner/lib:$RUBYLIB

    On Thursday, 18 July 2013 00:21:52 UTC+1, shivaraj mathrubai wrote:


    Hi Guys,

    I'm unable to load the module cloud provisioner, when I try to run
    node_aws it gives me the below errors:

    Error: Could not autoload puppet/face/node_aws/list_keynames: no such
    file to load -- guid
    Error: Could not parse application options: Could not autoload
    puppet/face/node_aws/list_keynames: no such file to load -- guid

    And when I see the help list I can see the below message:

    ! node ! Subcommand unavailable due to error. Check error logs.
    ! node_aws ! Subcommand unavailable due to error. Check error
    logs.

    I'm using Puppet 3.2.3 and Ruby 1.9.2

    Any hint to fix this ?

    Thanks in advance !



    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To view this discussion on the web visit https://groups.google.com/d/msgid/puppet-users/76ff3b85-838a-4f52-ad93-8c6390d7c6ee%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 17, '13 at 11:22p
activeApr 23, '14 at 1:58a
posts5
users3
websitepuppetlabs.com

People

Translate

site design / logo © 2021 Grokbase