FAQ
Hi,

We use the tagmail report so we get mails about errors on the agents.
This works fine and is quite useful for the production environment.

Now we also have a [dev] environment, where having errors is expected. I
can not find any way to disable the tagmail store only for the
dev-environment. Normally we call

puppet agent --test --environment dev (--noop)

to try out changes on an agent host

I've tried to disable the tagmail for such runs with the following, all
not working:

err, warning, !dev: admin@example.tld
in tagmail.conf on master

[dev]
reports = store
and/or
report = false
in masters puppet.conf

[dev]
report = false
in agents puppet.conf.

Calling puppet agent --test --environment dev --report false

Now I'm out of ideas. Does anyone know how to disable tagmail for a
certain environment?

Thanks

--
Lothar Gesslein
Linux Consultant
Mail: gesslein@b1-systems.de

B1 Systems GmbH
Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

Search Discussions

  • Dan White at Jul 10, 2013 at 12:21 pm
    Command line option is " --no-report"


    “Sometimes I think the surest sign that intelligent life exists elsewhere in the universe is that none of it has tried to contact us.”
    Bill Waterson (Calvin & Hobbes)

    ----- Original Message -----
    From: "Lothar Gesslein" <gesslein@b1-systems.de>
    To: puppet-users@googlegroups.com
    Sent: Wednesday, July 10, 2013 7:47:59 AM
    Subject: [Puppet Users] Disable tagmail store in dev environment

    Hi,

    We use the tagmail report so we get mails about errors on the agents.
    This works fine and is quite useful for the production environment.

    Now we also have a [dev] environment, where having errors is expected. I
    can not find any way to disable the tagmail store only for the
    dev-environment. Normally we call

    puppet agent --test --environment dev (--noop)

    to try out changes on an agent host

    I've tried to disable the tagmail for such runs with the following, all
    not working:

    err, warning, !dev: admin@example.tld
    in tagmail.conf on master

    [dev]
    reports = store
    and/or
    report = false
    in masters puppet.conf

    [dev]
    report = false
    in agents puppet.conf.

    Calling puppet agent --test --environment dev --report false

    Now I'm out of ideas. Does anyone know how to disable tagmail for a
    certain environment?

    Thanks

    --
    Lothar Gesslein
    Linux Consultant
    Mail: gesslein@b1-systems.de

    B1 Systems GmbH
    Osterfeldstraße 7 / 85088 Vohburg / http://www.b1-systems.de
    GF: Ralph Dehner / Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 10, '13 at 11:48a
activeJul 10, '13 at 12:21p
posts2
users2
websitepuppetlabs.com

2 users in discussion

Dan White: 1 post Lothar Gesslein: 1 post

People

Translate

site design / logo © 2022 Grokbase