FAQ
I'm turning an existing ruby script into a type-provider pair. My first
desire was to simply 'require' the original ruby file in the new provider
file. Unfortunately my ruby file doesn't get downloaded from master to
agent. Is there something reasonably simple I can do to ensure that this
file is available for provider.rb? Or should I transfer the original code
into the provider.rb file and eliminate the issue?

--
You received this message because you are subscribed to the Google Groups "Puppet Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
To post to this group, send email to puppet-users@googlegroups.com.
Visit this group at http://groups.google.com/group/puppet-users.
For more options, visit https://groups.google.com/groups/opt_out.

Search Discussions

  • Liu.cy at Jul 4, 2013 at 3:00 am
    http://docs.puppetlabs.com/guides/plugins_in_modules.html
    put it in your modules's lib directory, and it will be transfered to client
    i think.
    On Thursday, July 4, 2013 6:23:11 AM UTC+8, Larry Fast wrote:

    I'm turning an existing ruby script into a type-provider pair. My first
    desire was to simply 'require' the original ruby file in the new provider
    file. Unfortunately my ruby file doesn't get downloaded from master to
    agent. Is there something reasonably simple I can do to ensure that this
    file is available for provider.rb? Or should I transfer the original code
    into the provider.rb file and eliminate the issue?
    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.
  • Larry Fast at Jul 4, 2013 at 3:27 am
    Thanks, yes it was that simple. It would have worked first time if I just
    had put the file in the provider folder instead of the type folder. Doh!
    Cheers,
    Larry

    --
    You received this message because you are subscribed to the Google Groups "Puppet Users" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to puppet-users+unsubscribe@googlegroups.com.
    To post to this group, send email to puppet-users@googlegroups.com.
    Visit this group at http://groups.google.com/group/puppet-users.
    For more options, visit https://groups.google.com/groups/opt_out.

Related Discussions

Discussion Navigation
viewthread | post
Discussion Overview
grouppuppet-users @
categoriespuppet
postedJul 3, '13 at 10:23p
activeJul 4, '13 at 3:27a
posts3
users2
websitepuppetlabs.com

2 users in discussion

Larry Fast: 2 posts Liu.cy: 1 post

People

Translate

site design / logo © 2022 Grokbase